none
Windows Server 2008 R2 - Temporary Profile for Admin Account RRS feed

  • Question

  • Have a new installation of Windows Server 2008 R2 where the server is part of the domain. The domain admin account username is %xyzxyz, and every time I try to log on with that account, it's telling me that it can't load my profile and is logging me on with a temporary profile. My personal login is also a domain admin, although it does not start with a %. I never get the temporary profile problem when using my personal login information. Any help would be greatly appreciated.

     

    Ed

    Friday, September 24, 2010 1:12 PM

Answers

  • Hello CarolinaEd,

    Please check the following KB.

    Error message when you log on to a Windows Vista-based or Windows 7-based computer by using a temporary profile: "The User Profile Service failed the logon. User profile cannot be loaded"
    http://support.microsoft.com/kb/947215

    Brent Hu,
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, September 30, 2010 4:58 AM
    Moderator

All replies

  •  

    Does the Domain Admin account uses a roaming profile? Or is there someting set at the TS profile for this account. It could be that the roaming or ts profile is corrupted. Or if there is a path specified that doesn't exist this will happen. Windows 2008 R2 is al lot more strict with these settings.


    Regards Ronny
    Friday, September 24, 2010 1:25 PM
  • Nope... found the KB about roaming profiles, but not the case here. No roaming profiles in play.
    Friday, September 24, 2010 1:27 PM
  • and also nothing in the TS profile field of this account?

    Another thing to try is the following:
    Start the registry editor and browse to HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ ProfileList here you will find all user SID’s logged on to this RDS server. You will find here a subkey know as SID.bak take a look probably this will be the key of the user you get this error.
    Delete this key and close registry editor (If you are not sure, first make a backup/export of the key before deleteing is). Then logoff and logon again.


    Regards Ronny
    • Proposed as answer by Payot Monday, December 10, 2012 7:20 PM
    Friday, September 24, 2010 1:32 PM
  • i know you don't use roaming profiles, but when you configure roaming profiles you use \\Server1\Profiles\%username% so I think that character "%" is causing the problem. I suggest renaming the account.
    http://roymayo.blogspot.com/
    Friday, September 24, 2010 1:32 PM
  • There is no entry in the profile list in the registry for the %admin account and there is not a folder for that account under c:\users. It's like it refuses to create a profile for that user. The account works fine on Windows Server 2003, profile creates locally, and uses the same profile every time we log on with it.

    Renaming the default admin account would be problematic, at best. Hoping there is another fix for this scenario.

    Friday, September 24, 2010 1:42 PM
  • Hello CarolinaEd,

    Please check the following KB.

    Error message when you log on to a Windows Vista-based or Windows 7-based computer by using a temporary profile: "The User Profile Service failed the logon. User profile cannot be loaded"
    http://support.microsoft.com/kb/947215

    Brent Hu,
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, September 30, 2010 4:58 AM
    Moderator
  • This fix worked great.  I made the mistake of deleting the profile directory in Windows 2008 R2 before discovering the correct way to delete a profile.  Now I know better and this fix did the trick.
    Wednesday, April 20, 2011 8:09 PM
  • This solution worked for me.. Thank you for the detailed explanation...

    santhana gopalan

    Thursday, September 11, 2014 12:53 PM