PE dism error - failed to get and initialize the PE provider


  • This all started with: Win 8.1 could not be installed. error code 0X8007003. I ran DISM successfully with the /RestoreHealth flag, but it made no difference to installing Win 8.1. I ran DISM again (successfully) and looked at the log for "fails". The repeated fail was:

    2011-06-10 10:12:47, Warning               DISM   DISM Provider Store: PID=2552 Failed to Load the provider: C:\Users\ROSMAR~1\AppData\Local\Temp\0709052E-4C8D-43AD-B837-FB57E1CF832A\PEProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)
    2011-06-10 10:12:47, Info                  DISM   DISM Provider Store: PID=2552 Failed to get and initialize the PE Provider.  Continuing by assuming that it is not a WinPE image. - CDISMProviderStore::Final_OnConnect

    How can I fix this? Is this the reason I can't install Win 8.1? Should I be looking at something else to fix whatever is generating error code 0X8007003?


    Thursday, February 27, 2014 2:51 PM


  • WIM format changed in Win 8.1. You need to use the DISM from the ADK from Windows 8.1. Older versions of DISM cannot service drivers or packages for example.
    Thursday, February 27, 2014 4:14 PM