Missing VSS System Writer and CAPI2 error in Event Log RRS feed

  • Question

  • Hello,

    I'm having problems with making full system backup of Windows 2008 R2 x64. It looks like this is related to missing VSS System Writer. When I'm running command "vssadmin list writers" there is no System Writer in writers list and in event log CAPI2 error (event ID 513) is showing with this description:
    Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object.


    TraverseDir : Unable to push subdirectory.

    System Error:

    Unspecified error
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-CAPI2" Guid="{5bbca4a8-b209-48dc-a8c7-b23d3e5216fb}" EventSourceName="Microsoft-Windows-CAPI2" />
    <EventID Qualifiers="0">513</EventID>
    <TimeCreated SystemTime="2010-03-14T01:06:35.639125000Z" />
    <Correlation />
    <Execution ProcessID="968" ThreadID="11588" />
    <Security />
    <Data>Details: TraverseDir : Unable to push subdirectory. System Error: Unspecified error</Data>
    any idea what could be wrong?

    Thanks in advance
    Sunday, March 14, 2010 1:13 AM

All replies

  • Hi there,

    Please try out the following steps to recreate the writers: http://support.microsoft.com/kb/940184. Especially step 9 is interesting for you.

    Also, the capi2 error could be related, if not, you can try to register the capicom.dll by using regsvr32 capicom.dll.

    Hope this helps.


    Stefan Hazenbroek
    Sunday, March 14, 2010 8:21 AM
  • Hello,
    thank you for respoding. I'm pasting errors which I've encountered during dll registration process:

    regsvr32 /i eventcls.dll
    "The module "eventcls.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070715."

    regsvr32 /i swprv.dll
    "The module "swprv.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070715."

    regsvr32 es.dll
    "The module "eventcls.dll" was loaded but the entry-point DllRegisterServer was not found.
    Make sure that "es.dll" is a valid DLL or OCX file and then try again."

    regsvr32 msxml.dll
    "The module "msxml.dll" failed to load.
    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.
    The specified module could not be found."

    regsvr32 msxml4.dll
    "The module "msxml4.dll" failed to load.
    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.
    The specified module could not be found."

    regsvr32 capicom.dll
    "The module "capicom.dll" failed to load.
    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.
    The specified module could not be found."

    I saw in various places that this can be related to Windows\winsxs\Filemaps directory so I've downloaded procmon and monitored this directory activity during listing writers and this is what I've received:

    11:05:08,0906630    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$.cdf-ms    FAST IO DISALLOWED   
    11:05:08,4090228    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_sysmsi_ssee_mssql.2005_mssql_schemasig_6e0561108ca3fa8f.cdf-ms    FAST IO DISALLOWED   
    11:05:08,4105319    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_21f9a9c4a2f8b514.cdf-ms    FAST IO DISALLOWED   
    11:05:08,4855680    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_en-us_429cd25484dc6f94.cdf-ms    FAST IO DISALLOWED   
    11:05:08,6803067    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_wbem_06656d9fdf2f8577.cdf-ms    FAST IO DISALLOWED   
    11:05:08,6887321    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_wbem_en-us_4555b1beb1c13883.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7128309    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_3817e2da53fe06b5.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7144278    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_backup_51adaff948d2b519.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7152438    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_bin_b15b6cdcb237ff50.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7164054    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_bin_en-us_8441843be6121916.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7172837    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_bin_en_508d4b174b5b812d.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7180956    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_data_b15b71d51a488dcd.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7188543    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_db_bc56fa1c00cc1139.cdf-ms    FAST IO DISALLOWED   
    11:05:08,7197237    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\$$_system32_windows_system_resource_manager_en-us_80bdbd2c633521e1.cdf-ms    FAST IO DISALLOWED   
    11:05:09,4148288    svchost.exe    968    QueryStandardInformationFile    C:\Windows\winsxs\FileMaps\_0000000000000000.cdf-ms    FAST IO DISALLOWED   
    11:05:09,4152758    svchost.exe    968    QueryDirectory    C:\Windows\winsxs\FileMaps    NO MORE FILES   
    Sunday, March 14, 2010 9:27 AM
  • Hi there,

    I've been searching around somewhat further, this error seems to be similar to yours: http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/b5236028-4bfe-400c-90e2-b6d40b08e776. Could you try setting the permissions as stated in this thread?

    I hope this helps.


    Stefan Hazenbroek
    • Proposed as answer by DmitryDP Wednesday, December 26, 2012 7:13 PM
    • Unproposed as answer by DmitryDP Wednesday, December 26, 2012 7:15 PM
    Sunday, March 14, 2010 10:43 AM
  • Yep. I've copied Deatheye permissions repair in bat file and runned it. Nothing changed :/
    Sunday, March 14, 2010 10:49 AM
  • Hm, very strange. I can't think of anything else at the moment. Would it be possible for you to open a case with Microsoft Premier Support? I think they would be able to help you alot further.


    Stefan Hazenbroek
    Sunday, March 14, 2010 11:27 AM
  • Thank you for helping. Does anyone has any idea what could be wrong? When I search for "TraverseDir : Unable to push subdirectory" in Google only one result is showing and it is this post. This is almost unbelievable :)
    Sunday, March 14, 2010 10:35 PM
  • When I've removed Bare metal recovery and system state backup is working.
    Sunday, March 21, 2010 9:51 AM
  • Nope. It looks like removing Bare metal recovery and System state was not enough. System reserved and drive C has backuped correcly but when drive D was starting backuping it suddenly stopped with mendioned CAPI2 error and additional:

     <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <Provider Name="Microsoft-Windows-Backup" Guid="{1DB28F2E-8F80-4027-8C5A-A11F7F10F62D}" /> 
      <TimeCreated SystemTime="2010-03-21T10:31:59.424000000Z" /> 
      <Correlation /> 
      <Execution ProcessID="17640" ThreadID="27200" /> 
      <Security UserID="S-1-5-18" /> 
       <Data Name="BackupTime">2010-03-21T10:31:46.408375000Z</Data> 
       <Data Name="ErrorCode">2155347997</Data> 
       <Data Name="ErrorMessage">%%2155347997</Data> 

    Sunday, March 21, 2010 10:46 AM
  • UPDATE: Changing disk size where backup is being stored (remote iSCSI drive) fixed error mentioned in my previous post. But System State still fails with CAPI2 error (right now I'm making backup of System Reserved, C and D).
    Sunday, March 21, 2010 12:02 PM
  • Hello,

    I am seeing the same issue on two servers with the CAPI2 513 error and the missing system writer.

    Did you find a fix on this?


    Wednesday, April 21, 2010 6:14 AM
  • Hello ,


    Based on the research, the VSS System Writer runs in the context of CryptSvc service on Windows Server 2008. To make the system writer works normally, please open services console to verify that the Cryptographic Services logon as the credentials of the "Network Service" account.


    The VSS system writer can be missing due to several reasons,  to isolate this issue, please refer to the following steps to boot the problematic server with clean boot mode to perform the test.


    Steps: Clean Boot


    1. On a problematic server perform a clean boot and check if the issue still exists


    2. Click Start->Run...->type msconfig and press Enter


    3. Click Services tab and select Hide All Microsoft Services and Disable All third party Services.


    4. Click Startup tab and Disable All startup items


    5. Click OK and choose Restart


    After the server reboot, please run "vssadmin list writers" to check if the "System Writer" can be displayed.


    If the issue still exists, please open a CMD prompt as Run As Administrator and type the following commands to see if it the system writer will be occure.


    CD c:\windows\system32


    Takeown /f %windir%\winsxs\filemaps\* /a


    icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"


    icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)"


    icacls %windir%\winsxs\filemaps\*.* /grant "BUILTIN\Users:(RX)"


    Moreover, based on the experience, it has been reported that there is some permissions issue which can cause this kind of issue. Please follow the steps below and check if it can be helpful.


    On domain controller


    1. Open Active Directory Users and Computers


    2. Click View and then "Advanced features"


    3. Right Click built and click properties.


    4. Click security tab.


    5. Grant read permission to 'Authenticated Users'


    6. Click Apply and OK.


    7. Restart Cryptographic Services.


    Note: By Default, it should have read permission for the system to take system state backup.


    Hope this can be helpful.

    MCTS: Windows Vista | Exchange Server 2007 MCITP: Enterprise Support Technician | Server & Enterprise Admin
    • Proposed as answer by Rosaceae Monday, May 10, 2010 7:37 AM
    Wednesday, April 21, 2010 6:42 AM
  • Hi,

    I've got this problem about a month ago. I refer to MSP.

    The problem was caused due to stack full. When we list system writer using “vssadmin list writers”, it will go through all the system files. To do that, the OS use a  search algorithm with a stack which has a size limitation of 1000. When the stack was full, it failed to continue listing files and log an event in the application event log.

    In my case, the following folder contains too many subdirectory and caused the problem.
    C:\Windows\Microsoft.Net\Framework64\v2.0.50727\Temporary ASP.NET Files\*

    1. Open C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\CONFIG\Web.config
    2. Add tempDirectory attribute to compilation tag. For example:
    <compilation tempDirectory="c:\ASPTEMP">

    And also grant the folder with the same privilege with as “C:\Windows\Microsoft.Net\Framework64\v2.0.50727\Temporary ASP.NET Files”.

    3. Restart the IIS Service.

    4. Backup and delete all files under “C:\Windows\Microsoft.Net\Framework64\v2.0.50727\Temporary ASP.NET Files”.

    5. restart the Cryptographic Service.

    6. Try “vssadmin list writers” again.

    Hopes this brings idea for you to solve it.

    • Proposed as answer by Microbolt Monday, January 31, 2011 8:27 PM
    Monday, May 10, 2010 7:44 AM
  • Thanks Rosaceae!

    After going on a wild goose chase setting permissions and nothing working I got looking around in the .Net Folders per your advice.  It looks like in my case I had the same issue with you except in the Framework instead of Framework64 (as most of my web apps are running x86).

    I'll share what I did incase it helps anyone (Ignore that last two of each step if you don't have .Net 4.0 Installed):

    1. Created 4 Folders:
      C:\Asp.net Temp Files\2.0.50727\x86
      C:\Asp.net Temp Files\2.0.50727\x64
      C:\Asp.net Temp Files\4.0.30319\x86
      C:\Asp.net Temp Files\4.0.30319\x64
    2. Set Permissions on the folder (This is how I set them, may be different on your server.  Check existing "Temporary ASP.NET Files" directory for permissions on your server
      icacls "c:\Asp.net Temp Files" /grant "BUILTIN\Administrators:(OI)(CI)(F)"
      icacls "c:\Asp.net Temp Files" /grant "NT AUTHORITY\SYSTEM:(OI)(CI)(M,WDAC,DC)"
      icacls "c:\Asp.net Temp Files" /grant "CREATOR OWNER:(OI)(CI)(IO)(F)"
      icacls "c:\Asp.net Temp Files" /grant "BUILTIN\IIS_IUSRS:(OI)(CI)(M,WDAC,DC)"
      icacls "c:\Asp.net Temp Files" /grant "BUILTIN\Users:(OI)(CI)(RX)"
      icacls "c:\Asp.net Temp Files" /grant "NT SERVICE\TrustedInstaller:(CI)(F)"
    3. Add tempDirectory attribute to compilation tag.  This will keep you from having the problem again in the future.  Add the following attribute to these files:

      <compilation tempDirectory="C:\Asp.net Temp Files\2.0.50727\x86">

      <compilation tempDirectory="C:\Asp.net Temp Files\2.0.50727\x64">

      <compilation tempDirectory="C:\Asp.net Temp Files\4.0.30319\x86">

      <compilation tempDirectory="C:\Asp.net Temp Files\4.0.30319\x64">
    4. Restart IIS so that it will use the new Temp Directory
    5. Deleted old Temp Files
      rmdir /s /q "C:\Windows\Microsoft.Net\Framework64\v2.0.50727\Temporary ASP.NET Files\root"
      rmdir /s /q "C:\Windows\Microsoft.Net\Framework\v2.0.50727\Temporary ASP.NET Files\root"
      rmdir /s /q "C:\Windows\Microsoft.Net\Framework64\v4.0.30319\Temporary ASP.NET Files\root"
      rmdir /s /q "C:\Windows\Microsoft.Net\Framework\v4.0.30319\Temporary ASP.NET Files\root"
    6. Restart Cryptographic Service
      net stop cryptsvc
      net start cryptsvc
    7. Now if all goes well you should be able to see the "System Writer" again!
      vssadmin list writers
    • Edited by Microbolt Monday, January 31, 2011 9:08 PM typo
    • Proposed as answer by ssssstew Thursday, May 3, 2012 6:01 AM
    Monday, January 31, 2011 9:05 PM
  • Rosacaea, Microbolt,

    we had exactly the same problem (>20000 temp files) couple days ago, so thanks for this solution (although we've only deleted the temporary files for now).

    Are you sure that moving the ASP.NET temporary folders out of the Windows folder ensures that they won't get enumerated anymore for the backup purposes and therefore preventing the problem?


    Tuesday, November 22, 2011 8:23 AM
  • I haven't had any more problems with it since I've moved it to the root of the drive.  Been working perfect since then.

    Only issue I've run into is my control panel I use for my web hosting business (Plesk) wants to modify permissions of the drive when it does updates.  I have to go in after an update and remove the two security groups it adds with deny privileges after setup.  Just something to be aware of if your using any kind of control panel.


    Tuesday, November 22, 2011 7:02 PM
  • Thanks for your input, I'll keep that in mind.
    Wednesday, November 23, 2011 7:21 AM
  • I have same problem. Can't make backup of system state and the same error with CAPI2:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-CAPI2" Guid="{5bbca4a8-b209-48dc-a8c7-b23d3e5216fb}" EventSourceName="Microsoft-Windows-CAPI2" /> 
      <EventID Qualifiers="0">513</EventID> 
      <TimeCreated SystemTime="2011-11-24T10:06:37.734458400Z" /> 
      <Correlation ActivityID="{01B14C40-F800-0000-AB0B-F9192BA6CC01}" /> 
      <Execution ProcessID="1156" ThreadID="3868" /> 
      <Computer>*I've delete name and domain*</Computer> 
      <Security /> 
    - <EventData>
      <Data>Details: TraverseDir : Unable to push subdirectory. System Error: Unspecified error</Data> 

    I've done everything described above. But problem still here...

    Some ideas?


    Thursday, November 24, 2011 10:12 AM
  • jMurr, can you be more specific? What "everything" have you tried? There's been many suggestions in this thread.

    Also, is your server using ASP.NET at all?

    Do you get System writer back when you restart cryptosvc?

    Thursday, November 24, 2011 12:58 PM
  • A huge thank you to Microbolt for his detailed steps above, this solved the issue for me.  For our environment it was due to the Technology One nTier application creating 2500 files in that temp asp folder, this is where is stores its nTier client which gets pushed down to users PCs, so relocating this to the new folder allowed the system writer to be created.

    Many hours of Googling finally provided the resolution.  Much appreciated :)


    Thursday, May 3, 2012 6:04 AM
  • Thanks Rosaceae & Microbolt,

    Fixed my problem. Good work. Much appreciated.

    Friday, May 25, 2012 2:09 AM
  • This fix worked for me.

    I tried 5 other fixes including WINSXS folder permission changes and this was the one that worked!

    Thanks so much for putting in the effort to write out the whole fix!

    Wednesday, June 27, 2012 4:05 AM
  • Where exactly are you supposed to put the compilation tags in the web.config file?  I am asking because I added the tag at the end after all of the assembly tags, but this fix didn't work for me?  System Writer is still not showing up.  Just wondering if I put it in the wrong place.
    Saturday, October 6, 2012 11:30 AM
  • The compilation element is already there. You have to add the attribute. So search for


    and change it to

    <compilation tempDirectory="C:\Asp.net Temp Files\2.0.50727\x86">

    or whatever.


    Sunday, October 21, 2012 9:29 AM
  • Thanks to Rosaceae, Microbolt, Scorpio_Milo, Stefan, and everyone,

    Like jMurr, I have tried "everything," meaning 

    • changing directory permissions on the specified directories using icacls
    • moving the ASP.NET temp files out under the root of C:, with associated web.config changes, note-for-note as prescribed by Microbolt
    • looking at the versions of the block level backup files (our are later than the hotfix)

    without joy.

    Like jMurr, I still see the following in the  Application event log:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
    <Provider Name="Microsoft-Windows-CAPI2" Guid="{5bbca4a8-b209-48dc-a8c7-b23d3e5216fb}" EventSourceName="Microsoft-Windows-CAPI2" />
    <EventID Qualifiers="0">513</EventID>
    <TimeCreated SystemTime="2012-12-04T18:31:21.254995900Z" />
    <Correlation />
    <Execution ProcessID="1996" ThreadID="22772" />
    <Security />
    - <EventData>
    <Data>Details: TraverseDir : Unable to push subdirectory. System Error: Unspecified error</Data>

    The error showed up after installation of SharePoint 2013 eval on Windows Server 2008 R2 SP1 x64, with SQL Server 2012 BI Edition.

    Thus this humble request for help: help?

    Thanks again


    Tuesday, December 4, 2012 7:00 PM
    • Edited by _RaFi_ Friday, January 11, 2013 9:44 PM
    Friday, January 11, 2013 8:12 PM
  • Yes, it is definitely an effect of installing SharePoint 2013 Enterprise trial version, and I think of the retail licensed version as well.

    When I uninstall SharePoint, I can once again make bare-metal backups.

    When I re-install SharePoint, once again the System Writer error appears.

    This is an old thread, I understand.  It would be nice if Microsoft looked in here once in a blue moon or so.

    Still need help with this error, and with much else regarding SharePoint 2013 RTM, which seems to me to be far from ready for prime time.


    Friday, February 8, 2013 8:22 PM
  • Yes, I've just experienced this also. Installed SharePoint 2013 RTM on Windows Server 2012, and the System Writer was no longer listed. Uninstalled SharePoint 2013, and I can backup the System state again.

    Michael Wehle

    Saturday, March 16, 2013 2:40 PM
  • this is due to numerous assemblies en gac

    i am expecting a hotfix.

    See ths post.




    Monday, April 1, 2013 2:41 PM
  • We have SharePoint 2013 along with Visual Studio 2012 and SQL Server 2012 installed on Windows 2012.

    Microsoft telephone support has verified with us that this is a know issue and that System Writer fails because it is unable to traverse the number of folders listed in C:\Windows\Microsoft.NET\assembly\GAC_MSIL.

    The suggested workarounds Microsoft had were to uninstall SharePoint 2013, use a VM, or not include Bare Metal and System State as options in Windows Server Backup. They did claim to be working on a solution - this issue has been known about for quite some time however.

    Wednesday, April 24, 2013 3:56 PM
  • There is now a hotfix that addresses this issue. See http://support.microsoft.com/kb/2807849
    Tuesday, May 28, 2013 2:44 PM
  • Hi,

    I managed to solve this issue by this way : none of the present solutions worked for me excepted this one :

    1 - Copy the C:\windows\winsxs\Filemaps\*.* in a backup folder

    2 - Boot on Windows DVD and go to the CMD (repair computer option) to remove manually all the C:\windows\winsxs\Filemaps\*.* files.

    3 - Reboot your server and logon as administrator.

    4 - Set the "Full Control" for administrator on the C:\windows\winsxs\Filemaps folder after having set the owner of this folder to administrator.

    5 - Copy in this folder the Filemaps files backuped.

    6 - Set again the normal rights for the C:\windows\winsxs\Filemaps folder (admin on readonly) and make the files inherit the new rights just set.

    7 - Reboot your serveur

    8 - Validate that the "vssadmin list writers" command lists the "system writer" on Stable.

    Note that i don't think this procedure is aprouved by Microsoft but it worked for me.

    Hope that it will help.

    Best Regards.

    Sunday, December 15, 2013 10:02 AM
  • thanks.. that worked for me



    Pankaj Madaan

    Sunday, March 23, 2014 4:46 AM
  • Microsoft Patch fixed my problem.

    Please note that there is a patch available to fix the problem with too many sub-folders/directories.  “This issue occurs because Windows Server limits any directory from containing more than 1,000 subdirectories. Visual Studio 2012 installs more than 1,000 subdirectories…” as described at:

    http://support.microsoft.com/kb/2807849     -   At the top of this KB article you can download a patch.

    I needed a Windows 2012 patch and was confused about which one to select, but if you read the notes under the “File Information” area (which is not expanded by default) you will find this…

    “Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page.”

    So I downloaded the Win8 patch and installed it and rebooted and I am now able to see “System Writer” when I run this command, “vssadmin list writers” and my backup works as well.

    Regards, Paul.

    Wednesday, April 2, 2014 7:45 AM
  • Thank you expr. This hotfix solve the issue in my case.


    If this helped you resolve your issue, please mark it Answered, thanks! Kind regards

    Monday, June 23, 2014 11:04 AM
  • Dear microbolt,

    Can you explain in detail how to add the attributes in configuration files I just add the below attributes under compilation and it is throwing errors. Please share the steps.

    In my case visual studio 2008 is installed and I dint find many subdirectories under root only 3 sub folders are present.

    C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root



    Thursday, September 15, 2016 3:06 PM
  • This solution worked for me.  A note on how to format the web.config files properly:

    Find the tag <compilation> and replace it with the examples provided. I first just put the <compilation tempDirectory= ......> statement on it's own line below <compilation> and it did not work.  Found this article to help understand the proper syntax: https://msdn.microsoft.com/en-us/library/s10awwz0(v=vs.100).aspx

    Also, had to take ownership and grant new permissions to the admin for the old temp file folders to delete them.  

    Thanks for a well documented solution...

    Many Thanks, JP

    Friday, January 26, 2018 2:14 PM
  • This solution worked, however it took down Exchange OWA in the process, i had to restore the temp files back to the C:\Windows\Microsoft.Net\Framework64\v2.0.50727\Temporary ASP.NET Files\ and restart services, then OWA was back, but system writer is missing again...

    EDIT - infact it could of been the web.config compilation line update that caused owa to stop, couldnt find the new temp directory :/

    Tuesday, July 24, 2018 3:45 PM