none
New-MailboxRepairRequest - error code (NotSupported) RRS feed

  • Question

  • When i in 2013 CU2 v2 run

    "New-MailboxRepairRequest -Mailbox <mailbox> -CorruptionType ProvisionedFolder,SearchFolder,AggregateCounts,Folderview"

    Get-MailboxRepairRequest =

    Identity                Task                    Detect Only             Job State               Progress
    --------                ----                    -----------             ---------               --------
    e05a821c-c4de-4ade-8... {ProvisionedFolder}     False                   Failed                  100
    e05a821c-c4de-4ade-8... {SearchFolder}          False                   Succeeded               100
    e05a821c-c4de-4ade-8... {AggregateCounts}       False                   Failed                  100
    e05a821c-c4de-4ade-8... {FolderView}            False                   Failed                  100

    Detail:

    Source              : OnDemand
    Priority            : Normal
    DetectOnly          : False
    JobState            : Failed
    Progress            : 100
    Tasks               : {ProvisionedFolder}
    CreationTime        : 2013-08-26 15:07:42
    FinishTime          : 2013-08-26 15:12:39
    LastExecutionTime   : 2013-08-26 15:12:39
    CorruptionsDetected : 0
    ErrorCode           : -2147221246
    CorruptionsFixed    : 0
    TimeInServer        : 00:00:00.0030000
    Corruptions         :
    IsValid             : True
    ObjectState         : New

    And event viewer:
    EventID: 4009
    Online integrity check failed to process mailbox (Username,[GUID]), error code (NotSupported).

    Monday, August 26, 2013 1:50 PM

All replies

  • Hello,

    I recommend you use ISInteg tool to check your mailbox.

    I recommend you move the mailbox to other database to check the result.

    Besides, I recommend you check if there is any related error in application log.


    Cara Chen
    TechNet Community Support

    • Marked as answer by cara chen Monday, September 2, 2013 8:05 AM
    • Unmarked as answer by Mikael.Hagberg Monday, September 2, 2013 8:06 AM
    Tuesday, August 27, 2013 2:51 AM
  • Move the mailbox to another database did not solve the problem.

    The application log = "Event viewer" i pasted before.

    I will try the ISInteg to se where it goes.

    Monday, September 2, 2013 8:07 AM
  • I got the same error when I run the cmdlet on all mailboxes on exchange 2013. Mailboxes are fine, were just moved to a new database. Seems a problem with CU2?
    Monday, October 14, 2013 10:44 PM
  • Hello,

    I've got the same error, New-MailboxRepairRequest -> Fails when I'm trying to Repair "FolderView" only succeeded "SerchFolder".

    Did you found any solution ?

    I'm running EX 2013 CU2.

     


    -- Kamil Tatar

    Tuesday, February 11, 2014 9:46 AM
  • Well i run CU3 now... Still not working, just tested:

    Identity                Task                    Detect Only             Job State               Progress
    --------                ----                    -----------             ---------               --------
    9c49440b-03b5-46c3-b... {ProvisionedFolder}     False                   Failed                  100
    9c49440b-03b5-46c3-b... {SearchFolder}          False                   Succeeded               100
    9c49440b-03b5-46c3-b... {AggregateCounts}       False                   Succeeded               100
    9c49440b-03b5-46c3-b... {FolderView}            False                   Failed                  100

    Tuesday, February 11, 2014 11:55 AM
  • I tried to make a RepairRequest, I also get this non informative error.

    I wanted to check the integrity of my own mailbox because I get "Clientvorgang fehlgeschlagen" when replying in Outlook 2013 but the repair does not work.

    e.g.

    Online integrity check failed to process mailbox (Administrator[f6e0d5c5-1abe-41f6-8caf-dcfd0dbf0bfa]), error code (NotSupported).

    Wednesday, April 16, 2014 1:20 PM
  • As far as I know this tool was discontinued?

    Any news on this, Microsoft?!

    Monday, May 19, 2014 10:45 PM
  • I'm having the same issue. I had a mailbox that kept getting quarantined - I tried to check what needed to be repaired - error 4009

    Online integrity check failed to process mailbox

    error code (NotSupported).

    Wednesday, November 12, 2014 4:02 PM
  • Been Having the same problem too.  Seem to get failures on FolderView and ProvisionedFolder views throughout the database.  Originally Microsoft Support put this down to the fact that I'd had a database crash that I'd repaired - I don't know why the Microsoft person in this post said use ISInteg - as this is no longer in Exchange.  

    As far as I know New-MailboxRepairRequest is the replacement and what I was attempting to use to do the same job.  I've migrated some faulty mailboxes causing themselves to be quarantined by Exchange to a fresh database successfully and run the New-MailboxRepairRequest again on the new database and getting the same failures. 

    I'm debating whether it's a bug, have asked Microsoft support to escalate.


    • Edited by C1337R Wednesday, December 3, 2014 9:53 PM
    Wednesday, December 3, 2014 9:50 PM
  • I got rid of this error after I did the following steps:

    1) Installed CU 5
    2) Moved the virtual Exchange 2013 machine to a SSD (due to horrible performance of Exchange)

    After on of those steps it suddenly worked.

    Wednesday, December 3, 2014 11:25 PM
  • Think I'm on CU5, MS support told me to hold off updating any further until CU7, but not really had a good time with support, have just raised a complaint about them.  

    Did you test after CU5 prior to the SSD move?  I'm guessing it's the CU that's fixed it and refreshed things?

    Thursday, December 4, 2014 5:53 PM
  • I guess CU 5 fixed that but I don't know 100% because I did this change in one step and remembered to test this repair function.
    Thursday, December 4, 2014 9:40 PM