none
Snapshot - General access denied error (0x80070005). RRS feed

  • Question

  • Hi,

     When trying to snapshot a VM i get:

    'vm1' could not create auto virtual hard disk C:\Virtual Guests\vm1\vm1_B4F0796F-3EB5-4810-BA04-CA8E1DA3774C.avhd: General access denied error (0x80070005). (Virtual machine ID AE6E811F-A056-4A1C-A501-287914A13021)

    I looked around on the web, and found that the 'Virtual Machines' group isn't on my server, and therefor isnt on the security tab for my snapshot folder.

    Taken from this post: http://joesitblogandotherstuff.blogspot.com/2010/01/could-not-initiate-snapshot-operation.html

    How do I manually create the 'Virtual Machines' group, so I can make snapshots work again?

     


    KL_Dane
    Wednesday, June 2, 2010 12:07 PM

Answers

  • Hi,

     

    I have no experience with mounting iSCSI disk as a folder, I always mount it as a drive such as D:\ and then put my virtual machines on it, I think the guys here will mount the iSCSI disk just like me.

     

    By the way, as you mentioned that “I have experience with HyperV since beta”, so I would like to know whether you mounted the iSCSI disk as a folder without any issue before you installed Windows Server 2008 R2.

     

     

    Best Regards,

    Vincent Hu

     

    • Marked as answer by KL_Dane Tuesday, June 8, 2010 6:56 AM
    Monday, June 7, 2010 3:04 PM
    Moderator

All replies

  • Hi,

     

    Where did you check the “Virtual Machines”? On the folder of the virtual machine or the VHD files? General speaking, after you create a virtual machine, the folder of the virtual machine will get the “Virtual Machines” group in Security tab automatically.

     

    By the way, please take a screen shot, upload it to your site and then paste the link here.

     

    In addition, the following bog may help you.

     

    Howto manually add a VM Configuration to Hyper-V

    http://blogs.msdn.com/b/robertvi/archive/2008/12/19/howto-manually-add-a-vm-configuration-to-hyper-v.aspx

     

     

    Best Regards,

    Vincent Hu

     

    Thursday, June 3, 2010 3:52 AM
    Moderator
  • Hi Vincent,

    Properties of my C:\Virtual Guest : http://img248.imageshack.us/img248/9764/51637568.jpg

    Properties of my C:\Virtual Guest\ccmoss03b : http://img39.imageshack.us/img39/2749/32353196.jpg

    Properties of my C:\Virtual Guest\backendsnapshots : http://img193.imageshack.us/img193/4121/52350447.jpg

    Properties of my C:\Virtual Guest\ccmoss03b\ccmoss03b_C.vhd : http://img442.imageshack.us/img442/1551/25792532.jpg

    Tryin to add 'Virtual Machines' to C:\Virtual Guest\ccmoss03b\ccmoss03b_C.vhd unsuccesful : http://img46.imageshack.us/img46/8807/54983205.jpg

    I have several HyperV servers in my environment, including 6 running failovercluster. I have experience with HyperV since beta, and now this is the last server i re-installed with R2. This is the only time I have encountered this issue though. This HyperV server is a stand alone server!


    KL_Dane
    Thursday, June 3, 2010 8:15 AM
  • Hi,

     

    On the Security tab of the VHD file, there isn’t “Virtual Machines”, you will find the GUID of the virtual machine there, you can refer to the following screen shot. 614E02EC-DC18-4E57-A7DD-86BAF52144CE is the GUID of my virtual machine.

     

     

     

    By the way, I would like to confirm the folder under C:\Virutal Guests on your disk, it seems they are shortcut instead of directory. If there are any misunderstanding, please feel free to let me know.

     

     

     

    In addition, you can create a new virtual machine, save it under C:\Virutal Guests, then you can check whether you can start the new created virtual machine. You can also check the security tab on the new virtual machine’s folder.

     

     

    Best Regards,

    Vincent Hu

     

    Thursday, June 3, 2010 8:39 AM
    Moderator
  • Hi Vincent,

    Regarding the shortcut icon's, it is folders, but each folder is an iSCSI volume - thats why it does not look like a normal folder icon.

    Ok i tried creating a test folder under C:\Virtual Guest and created a new virtual harddrive. Created a new virtual machine, using that folder and vhd. For this test machine everything is working 100% - I can change the snapshot location to C:\Virtual Guest\backendsnapshots and snapshots are still working as intended.

    This server was first a Server 2008 R1 - and then i reinstalled it with Server 2008 R2. I just stopped all guests, and after reinstall i reattached the vmdrives with iSCSI again. I think this might be what is causing this issue, so I will now try to shut one guest down and copy it to a fresh iSCSI drive and then re-create the guest under HyperV. Will let you know how it goes.


    KL_Dane
    Thursday, June 3, 2010 10:37 AM
  • Hi,

    Ok tried everything I could think of, but with no luck. Tried to mount a freshly made iSCSI drive, and copy the vhd over and make a new guest, but same error when trying to snapshot it.

    Is there anyway I can manually add the permission the vhd files need, to be able to do snapshots again?


    KL_Dane
    Thursday, June 3, 2010 12:22 PM
  • Hi,

     

    I guess I got a gleam glimmer.

     

    Base on my experience, it should connect the iSCSI drives to the Hyper-V host and then mount it as a local disk, store the virtual machines on it.

     

    By the way, please create a new virtual machine on the local disk instead of the iSCSI disk and then check whether you get the same issue.

    Note: Please don’t change the location of the snapshot, let it stored in the default path.

     

    Best Regards,

    Vincent Hu

     

    Monday, June 7, 2010 7:10 AM
    Moderator
  • Hi,

    Ok i made a c:\test folder - created a test.vhd HD in same folder, and created a guest named test using this disk. Startet the guest, and took a snapshot - Working!

    I made a iSCSI drive, and mounted it as c:\testguest\test2 folder - created a test2.vhd HD in same folder, and created a guest named test2 using this disk. Startet the guest, and took a snapshot - Not working!

    I made a iSCSI drive, and mounted it as F:\ drive - created a test3.vhd HD in same folder, and created a guest named test3 using this disk. Startet the guest, and took a snapshot - Working!

    So it seems my problem is when i mount the iSCSI drives as a folder, instead of a drive. This is rather weird, because I have a identical server on my frontend_DMZ where everthing is working when I mount the iSCSI drives as folders.

    Is there anyway to get this to wotk when I map the iSCSI drives to a folder, like on my other server?


    KL_Dane
    Monday, June 7, 2010 1:48 PM
  • Hi,

     

    I have no experience with mounting iSCSI disk as a folder, I always mount it as a drive such as D:\ and then put my virtual machines on it, I think the guys here will mount the iSCSI disk just like me.

     

    By the way, as you mentioned that “I have experience with HyperV since beta”, so I would like to know whether you mounted the iSCSI disk as a folder without any issue before you installed Windows Server 2008 R2.

     

     

    Best Regards,

    Vincent Hu

     

    • Marked as answer by KL_Dane Tuesday, June 8, 2010 6:56 AM
    Monday, June 7, 2010 3:04 PM
    Moderator
  • Hi,

    During beta i used local physical drives for the .vhd files. When Windows Server 2008 R1 was release we bought the iSCSI, and have used mounted folder for our iSCSI since.

    One of the best features with R2 is CSV, wich only works as a mounted folder... So I am a bit puzzled if that should be the issue.


    KL_Dane
    • Edited by KL_Dane Wednesday, February 15, 2017 8:16 AM
    Tuesday, June 8, 2010 6:19 AM
  • Hi,

     

    I just took one of my folder mounted iSCSI and remounted it as P:\, and snapshot worked at once. I will settle with this as the solution, and remount all my folder mapped iSCSI drives.

     

    Thanks for all your help, and quick replies Vincent ;)


    KL_Dane
    Tuesday, June 8, 2010 6:55 AM
  • Hi,

     

    Glad to hear that it works!

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, June 8, 2010 9:28 AM
    Moderator
  • Old thread, but for lurkers sent here by a web search to find a solution to the Snapshot problem with a mounted drive, (like I was, yesterday!) I found the answer.

    If, in addition to mounting the drive to a folder, you also give it a drive letter, and examine the ACL, you'll discover that the permissions on the drive letter are default root directory permissions; not the permissions you see assigned by Hyper-V in the Virtual Disks folder. And the VHD files (at least in my case) were in the root directory of the drive-letter-mounted drive.

    Evidently, the part of Hyper-V that sets ACLs on the Virtual Hard Disks folder is mount point-aware, but the part of Hyper-V that creates Snapshots is not. The Shapshotter is using the underlying, root directory ACL of the mounted drive instead of the ACL of the folder in which it's mounted.

    I'd call that a bug.

    The way I worked around it was to create a subfolder in the mounted drive and forced inheritance from the parent folder, then moved the VHD file to the new subfolder. That allows Windows to keep the default root folder permissions, while giving Hyper-V the ACLs it needs to both launch the VM and create snapshots.

    Clarifying--

    VHDs here allow the VHD to be created and the VM to run, but snapshots fail with 0x80070005:

    C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere\SomeFileName.vhd

    VHDs here support snapshots, as well:

    C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere\SomeFolderName\SomeFileName.vhd

     

    • Proposed as answer by JRV529088 Wednesday, October 5, 2011 5:26 PM
    • Edited by JRV529088 Wednesday, October 5, 2011 5:40 PM
    Wednesday, October 5, 2011 5:26 PM
  • Thanks JRV for posting, that helped me! (1.5 years later).

    More info for lurkers:
    You can NOT add the special group "Virtual Machines" through the GUI (that I could find), you must use the icacls command:

    icacls "C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere" /grant "NT VIRTUAL MACHINE\Virtual Machines":F /T

    The "/T" switch will propogate permissions to files/sub-directories under the root of that volume.

    More info at:  Migrating a Virtual Machine problem


    • Edited by JayRO-GreyBeard Sunday, March 31, 2013 1:58 PM removed <tt> tag around command
    Sunday, March 31, 2013 1:56 PM
  • JRV529088, I'm as well very thankful for your post, you solved my Problem. Another happy user within past 5 days after 1.5 years of your posting!
    Thursday, April 4, 2013 12:17 PM
  • I know this is old... but I have been searching for 3 months (on and off) for a solution.

    This explains why I have my issue - resolved by moving the .vhdx file(s) to  .\MountPoint\Server01 C OS.vhdx to .\MountPoint\VHDX\Server 01 C OS.vhdx.

    Specific disk setup:

    IBM V3700 SAS Cluster. Created a volume for each "disk" that my Hyper-V guests would need.  Mount each volume in it's own folder (the Hyper-V server will have, say 6 servers with up to 4 disks each, so the alphabet just ain't big enough).  Put a single .vhdx in each mounted folder root <--- this is the problem.

    Moved the single .vhdx to a subfolder - bingo - checkpoints (and therefore backups) are now warning free.

    My issue was that a "General access denied" would occur when performing the backup - my backups would "complete with warnings".

    Specifically, error message in backup log (so Google will find this article for future searches):

       Component Message: Could not create backup checkpoint for virtual machine '(server name goes here)': General access denied error (0x80070005). (Virtual machine ID 3EF5FCD1-4AF6-4295-A796-D493847D807D)


    • Proposed as answer by kentpo Friday, February 27, 2015 9:42 AM
    Sunday, February 22, 2015 11:54 PM
  • Hey,

    I confirm, the Andrew's post is fixed the problem.

    Create virtual disk in the root of a Cluster volume storage make the backup failed with a access denied:

    To fix the issue, just create a root directory like "vhdx" for example and move in your vhd/vhdx files :

    Erick.



    • Edited by kentpo Friday, February 27, 2015 9:55 AM
    Friday, February 27, 2015 9:49 AM
  • Hey guys i confirm, this solution worked for me:

    C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere\SomeFileName.vhd ->Not Work.

    C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere\SomeFolderName\SomeFileName.vhd -> Works!.

    Altough my problem was in replication, this solution worked for me perfectly.

    Sorry for my Enghisk, I speak spanish.

    Thanks to all. Bye.

    Wednesday, September 16, 2015 3:31 PM
  • This worked for me as well; thanks JRV!
    Wednesday, September 28, 2016 6:17 PM
  • I know it's an old post, but I spent some time to figure out why command provided by JayRO-GreyBeard does not work. :F flag should be placed inside quotes together with account name:

    icacls "C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MountPointHere" /grant "NT VIRTUAL MACHINE\Virtual Machines:F" /T
    Tuesday, February 14, 2017 11:27 AM
  • Even easier fix at least on 2016 was to give everyone full access to the vhdx. Snapshot then VM then immediately delete the snapshot. The original vhdx will now have the correct permissions and you can remove the everyone group.
    Friday, November 9, 2018 11:22 PM