none
KB4036479 will not install RRS feed

  • Question

  • This update, released today, seems to install successfully on 2012 R2 servers, prompts for a reboot, but then after reboot undoes itself with a "We couldn't complete the updates undoing changes" notice. The update history shows it as having been successfully installed, but Windows Update prompts to install it again. We've tried this on five different Hyper-V guests with the same result.

    I just ran an sfc /scannow on one of the systems, and it did find duplicate ownership issues with some files. After fixing those, the install went smoothly. Just a word to the wise.

    Wednesday, September 20, 2017 4:01 PM

All replies

  • OK, maybe I spoke too quickly. This is one of those updates that never realizes that it just installed itself and keeps prompting for another go. The subject guest now shows four successful installs in its update history (none of the last three terminated with the "undoing changes" notice), but if you check for updates again, it shows up as needed.
    Wednesday, September 20, 2017 4:20 PM
  • Do you have a link? Cannot find any reference.

    https://www.catalog.update.microsoft.com/Search.aspx?q=KB4036479

    https://support.microsoft.com/en-us/help/4009470/windows-8-1-windows-server-2012-r2-update-history

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, September 20, 2017 4:23 PM
  • Here you go:

    https://support.microsoft.com/en-us/help/4036479/eliminate-restarts-in-virtual-machine-initial-configuration-in-windows

    Wednesday, September 20, 2017 4:39 PM
  • Funny it isn't in catalog. I was never offered this one.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, September 20, 2017 4:44 PM
  • I am having this same issue on a VM template. This is a clean OS, nothing but Windows Updates, so strange to be running into an update issue. 

    I will try to run SFC /ScanNow as you mentioned to see if that helps in my case. 

    Wednesday, September 20, 2017 4:59 PM
  • SFC /ScanNow did not work for me. I still cannot get this update to install. 

    Anybody else try anything that worked? I am updating four other VMs on Hyper-V right now, and they are all showing that update as available now. I am going to skip it until a resolution is found. 

    Wednesday, September 20, 2017 5:41 PM
  • I have the same issue on a S2012r2 running on a Hyper-V. The sfc /scannow came up clean, and didn't resolve. Hiding the KB4036479 update, for now.

    GwB

    Wednesday, September 20, 2017 6:00 PM
  • Hi wjkessler,

    We are testing this KB in our lab, we'll feedback the result as soon as possible.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 21, 2017 6:08 AM
    Moderator
  • Hi wjkessler,

    Is the Hyper V host 2012R2?

    I tested in my lab to install KB4036479 on VM server 2012R2(Host 2016), I installed the KB successfully and after restart, I checked again for windows update, the KB4036479 didn't show up again. Everything seems OK after installing the KB:

    Welcome to feedback if you have any additional information, I will report this issue to more professional team and involve them to look into it.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Thursday, September 21, 2017 6:27 AM
    Moderator
  • Hi All!

    In my case, this update causes double reboot with rollback on the 2012 r2 Hyper-V node, but was installed successfully on clean test 2012 r2 guest.

    I've get direct link for this update, then extracted it. It contains updated (6.3.9600.18792) Guest Integration Services for 2012 r2. It seems, all ok with the guest OS after installation.

    I hoped, that it also resolved cosmetic issue with incompatibility of time sync protocols between 2016 Hyper-V host and 2012 r2 guest, but got the same check results.

    (Pictures in attach)


    Thursday, September 21, 2017 8:44 AM
  • So far as I have seen, Windows Update only offers this update to Server 2012 R2 guests, and not to 2012 R2 hosts. Usually integration services updates update the 2012 R2 host, and the 2012 R2 guest's integration services have to be re-installed by the ISO.

    It is also unusual that this has not appeared in a cumulative update, as the last integration services update did.

    It always says it has installed but is then reoffered. It also has the annoying feature of preventing the successful installation of any other updates selected on Windows Update at the same time.

    Neil Flanagan

    Thursday, September 21, 2017 11:07 AM
  • Same Problem here with KB4036479 . sfc /scannow did NOT fix it.
    Thursday, September 21, 2017 12:34 PM
  • Thanks, Anne. Yes it is a 2012R2 host, as is the guest.

    Thursday, September 21, 2017 2:21 PM
  • This is happening for me on 2012 R2 guests running on both 2012 R2 DataCenter hosts, and 2016 DataCenter hosts. First noticed on guest of a 2016 host, but just saw yesterday on 2012 R2 hosts as well. 
    Thursday, September 21, 2017 3:09 PM
  • I am also seeing this same behavior on Windows 8.1 guest VMs on a 2012R2 Hyper-V host. 

    Update is offered.

    Update attempts install

    Update terminates with on screen message stating "Unable to complete...". This happens at around 12% complete.

    Update appears to have installed successfully per Windows Update.

    Update is offered again.

    Repeat, repeat, repeat

    Has anyone applied this patch to the Hyper-V host? It's not in the offered list of updates on the specific 2012R2 Hyper-V host that I am referencing. 

    Thursday, September 21, 2017 4:31 PM
  • I'm experiencing the same problem on 2012R2 guests and host with not only KB4036479 but also KB4038774 (https://support.microsoft.com/en-us/help/4038774/windows-81-update-kb4038774), both being advertised through WSUS since the morning of 20 SEP 2017.

    They both install successfully, ask for a reboot, then they reboot twice, and still show as available in Windows Update despite the history showing them as successfully installed. 

    Event log shows them requiring reboot, then being changed to "Installed" after the reboot, than back to "Staged" upon the next check for updates.

    I've had to decline the updates in WSUS while MS works on fixing these patches.

    • Edited by IamGimli Thursday, September 21, 2017 4:54 PM
    Thursday, September 21, 2017 4:50 PM
  • I was getting both the KB4038774 and KB4036479 offered on my 2012r2 guest running from a Windows 10 Hyper-V. I downloaded and installed KB4038774 from the catalog https://www.catalog.update.microsoft.com/Search.aspx?q=KB4038774 and rebooted. But the KB4036479 is still listed as an update available, and trying to install it only reboots and says it's available again. Under the update history, it shows that update as successful each time I tried. The KB4036479 isn't available from the catalog to try, yet.

    GwB

    Thursday, September 21, 2017 6:10 PM
  • Update: even after manually updating the Integration services on the VMs, the two updates still show up as available to install and their installation fails.
    Thursday, September 21, 2017 7:00 PM
  • Same issue on several Windows Server 2012 R2 VM's as well. Windows Update history shows that it was installed successfully, but on each reboot it shows up again for install. The host is Windows Server 2012 R2 as well.
    Thursday, September 21, 2017 9:37 PM
  • Update for Windows Server 2012 R2 (KB4036479) is offered after it has already been successfully installed.  You can install it over and over, and it is still offered.

    This occurs on VMs running on both 2012R2 and 2016 Hyper-V clusters.

    This causes Cluster Aware Updating to get stuck in an endless loop:

    CAU looping

    The update history shows the update installed successfully several times:

    Windows update history

    We are using WSUS, so I am simply declining the update for now.  I would like a fix though.


    -Tony

    Thursday, September 21, 2017 11:13 PM
  • I am encountering the same issue, WS2012 R2 Guest, KB4036479 is offered to this machine from my WSUS server, it installs successfully as shown in the update history, but is continually offered when windows update checks again, I have declined it on my WSUS server until this issue is resolved.  The update is not needed on this WS2012R2 server as it is not running any Hyper-V services.

    Bruce H.


    Bruce H.

    Thursday, September 21, 2017 11:21 PM
  • Also affected here.

    Hosts are 2012R2, as are guests. All were fully updated prior to KB4038774 (successfully installs on it's own) and KB4036479.
    As reported by others here, KB4036479 installs, prompts for reboot, rolls back during boot, claims successful install in update history, but is offered again for update at next check. Risnse and repeat. SFC found no problems.

    Friday, September 22, 2017 12:55 PM
  • Hi my 2 cents.

    I have the same problem, all 2012 R2 guests install and then ask for it again.

    On WSUS it self it errors:  0x8000FFFF: Update for Windows Server 2012 R2 (KB4036479)

    And; Package KB4036479 failed to be changed to the Installed state. Status: 0x8000ffff.

    None guests (Laptops) Win 8.1 all works well, no problems so far..

    On Win 8.1 Guests however it does not, same problem.

    So out here its just affecting Guest systems.

    I have not yet applied it to the Hyper-V hosts it self.

    Have declined it in WSUS for now, until MS can sort this one out.

    Affected KB's

     KB4036479

    Slight correction, KB4036479 is the culprit.
    Like others have sayed, if you select this one with others all will fail.

    Have a nice weekend.





    • Edited by ShadowTracer Friday, September 22, 2017 11:02 PM Correction
    Friday, September 22, 2017 3:13 PM
  • Just to echo what other people are saying, I've had exactly the same problem. I have several host servers (all running Windows Server 2012 R2) and each virtual server (also Windows Server 2012 R2) prompts for this update. If I install it, it claims to have succeeded, but then it prompts for the same update again after the reboot. If I install other updates at the same time, it prompts for all of them again too; the only exception is the Malicious Software Removal Tool, probably because that doesn't require a reboot.

    I installed the other September patches on the guest OS, so that KB4036479 was the only one left. I ran "sfc /scannow" on the host and guest OS, but it didn't find any problems on either of them.

    I then tried installing the September patches on the host OS. (This didn't prompt for KB4036479.) They installed successfully, but then I still had the same problem on the guest OS.

    Looking in Hyper-V Manager, it said that the integration services needed an update on the guest OS. I did that, but I still had the same problem afterwards.

    Looking in the System log, there's an extra event which pops up mid-reboot when I try to install this patch:
    Source: User32
    Event ID: 1074
    Description:
    The process C:\Windows\servicing\TrustedInstaller.exe (PEANUT) has initiated the restart of computer PEANUT on behalf of user NT AUTHORITY\SYSTEM for the following reason: Operating System: Upgrade (Planned)

    Reason Code: 0x80020003
    Shutdown Type: restart
    Comment:

    (I've replaced my actual server name with "PEANUT".)

    That event doesn't appear when I install other patches.
    NB It comes after event ID 6009, i.e. this happens during boot-up rather than shutdown. It also causes a few knock-on errors for the Windows Time service, since that's trying to start up while the rest of the system is shutting down.

    I've had a look at WindowsUpdate.log, but I can't see anything relevant in there. According to the Windows Update history (and the WSUS server), there weren't any errors. However, if I watch the guest OS via Hyper-V Manager, it displays a message just before it gets to the logon screen:

    We couldn't complete the updates. Undoing changes. Don't turn off your computer.

    Friday, September 22, 2017 8:40 PM
  • I have nothing more to add to this conversation, but I have the same exact issue on all my 60 servers (2012R2 guest on 2012R2/2016cluster).


    • Edited by EnricoZogno Saturday, September 23, 2017 6:47 AM
    Saturday, September 23, 2017 6:46 AM
  • Ditto.


    GaryK


    • Edited by gkarasik Saturday, September 23, 2017 4:53 PM
    Saturday, September 23, 2017 4:52 PM
  • Again, nothing to add but experiencing the same problem and have now declined the update at all our sites.
    Saturday, September 23, 2017 5:15 PM
  • We have this too, but only only on 2012R2 guests so far (hosts are Hyper-V Server 2012R2). 

    No. Well...maybe. Actually, yes. It really just depends.

    Saturday, September 23, 2017 10:06 PM
  • I tried to report this at AskWoody.Com, but the site is down again.


    GaryK

    Saturday, September 23, 2017 11:59 PM
  • Having the same issue.

    Installs then reboots, then reboot again saying

    "We couldn't complete the updates undoing changes"

    I am having this issue on multiple servers (around 50)

    I have hidden this update for now until issue is resolved.


    Jed Parkes



    • Edited by Jed (Hypertronics) Sunday, September 24, 2017 10:43 PM original statement was wrong.
    Sunday, September 24, 2017 10:35 PM
  • Same issue on all my Hyper V servers showing installed via WSUS and also have done it as a manual. Log shows successful install then on reboot rolls back.

    Ive declined now to prevent until MS resolve this issue

    Monday, September 25, 2017 1:19 PM
  • Yup, just adding a "me too"  KB4036479 gives "We couldn't complete the updates undoing changes" and then rolls back.  Took me a couple hours today to narrow down which update was causing the issue and rolling back everything that was installed along with it.  I am just hiding it for now.
    Monday, September 25, 2017 8:05 PM
  • Yep my servers have done the exact same thing! Hopefully MS are working on a fix.
    Tuesday, September 26, 2017 5:41 AM
  • I have the same problem with these two updates: updates are distributet via WSUS to all Hyper-V clients guest-OS Windows 2012 R2!
    Tuesday, September 26, 2017 8:16 AM
  • I have problem with this update. It is installed on my 2012r2 and thats the problem. In windows update I have set to "search and ask me to install updates" but this update and KB4040972 and thre others was installed without my permission. This resulted in restarting all of my serwers (exchange, file storage any many more). Should I uninstall this KB or block it on wsus?
    Tuesday, September 26, 2017 10:47 AM
  • Microsoft have pulled the update:

    KB4036479

    Update not available

    The update that is described in this article is currently not available in Windows Update. We are investigating the reason why Windows Update reoffers the update after it is already installed

    Tuesday, September 26, 2017 11:18 AM
  • Am having what appears to be the same issue, affecting one Server 2012 R2 Host and five 2012 R2 VMs.  (I am not experiencing any such related issues with Server 2012 or 2008 R2)

    For each system there is an identical block of seven updates (KB4036479, KB4038774, KB4041085, KB4038792, KB4038793, KB4041092, KB4036586) which will install 'successfully' and then, after reboot, be re-offered as needed updates. I've gone through the install cycle multiple times, and for all seven updates, the update history logs a successful update. 

    If I try installing KB4036479 by itself, it will install successfully, and then after reboot, reappear as a needed update.  The other six updates, if installed individually, will each fail immediately, which is curious, since they all log successful installations when I install all seven as a group.

    Out of curiosity, on one VM I cleared the SoftwareDistribution folder, thus clearing the install history and tried the installs again.  As before, they all successfully install, then reappear seconds later as needed updates.

    Anyway, it's a fine mess.  It would be nice to have a formal response from Microsoft.


    • Edited by Dale Magnant Tuesday, September 26, 2017 9:01 PM
    Tuesday, September 26, 2017 9:00 PM
  • The corresponding KB Article (https://support.microsoft.com/en-us/help/4036479/eliminate-restarts-in-virtual-machine-initial-configuration-in-windows Article ID: 4036479 - Last Review: Sep 25, 2017 - Revision: 16) currently states: "Update not available - The update that is described in this article is currently not available in Windows Update. We are investigating the reason why Windows Update reoffers the update after it is already installed."

    Anyhow, the update was (and is still being) offered to my clients via _Windows Update_ this morning e.g. on 2017-09-27T02:45:00Z.

    It is also still being published to _WSUS_.

    BTW: SQL Server 2016 SP1 Cumulative Updates WSUS Metadata seems to be broken too since CU2: https://social.technet.microsoft.com/Forums/en-US/43df0a37-6975-477b-9fb5-af89f9f851a5/updates-arent-offered-reported-as-required-for-sql-server-2016-sp1-express-installations-on?forum=winserverwsus

    Maybe this is also related to the CU1 deployment being broken in the first place: https://social.technet.microsoft.com/Forums/en-US/3dce20f6-9420-4c66-ad13-8791f874a88e/unable-to-install-cu-1-for-sql-server-2016-sp1-through-windows-update-service?forum=sqlsetupandupgrade

    Wednesday, September 27, 2017 7:48 AM
  • Don't have much to add, except I also tried to get it from WindowsUpdate instead of WSUS, but that doesn't work either. The update shows up as successfull in the history, but has been rolled back after the reboot.

    All affected servers are 2012 R2 VM's, they run on 2012 R2 hosts.

    The update is still offered today, also from Windows Update itself (27-9-2017, 20:45 GMT+1)

    Update KB4038774 works perfect, if installed seperately from the above mentioned update. which fails and also fails all other updates that get installed at the same time.

    Edit: The update seems to be pulled now (27-9-2017 21:05 GMT+1)
    • Edited by Nico Buma Wednesday, September 27, 2017 7:09 PM
    Wednesday, September 27, 2017 6:50 PM
  • We logged a Premier case, and Microsoft confirmed issues with KB 4036479 and that its' subsequently been pulled from deployment.

    Our SCCM deployment saw it expired some time on 20/9 AWST. We're declining it in WSUS and any WSUS-based deployments are also now working.

    As mentioned above, decline it in any WSUS policy you may have, or deselect it for installation as a manual workaround, then other outstanding queued updates install fine.

    Thursday, September 28, 2017 1:46 AM
  • No longer being offered through WinUp on my guest servers.


    GaryK

    Friday, September 29, 2017 10:51 PM