RDP to Server Drops after Authentication or even earlier


  • This one's made me crazy - 

    Server 2008 R2 Standard Running as a virtual on Hyper-V  This is the only server of many that exhibits this issue:

    1) From A Windows 7 PC - attempting a Remote Desktop Connection, one of two things will happen:
        - Authentication happens, and then the session will drop (While the blue "Welcome" screen is up, -or- 
        - Remote Desktop will come back and report - "unable to establish a connection."

    2) I can RDP into the Host Server and connect to the culprit using the Hyper-V console just fine.

    3) Remote settings on the culprit are enabled to allow connections from users using any version of RDP

    There are no errors logged in Application, Security, or System at the time of the failed attempt.  If thee system would even leave me a trail of bread crumbs, I would feel better.

    Any ideas or places to look will be greatly appreciated!

    Monday, January 21, 2013 7:22 PM

All replies

  • Hi,

    1. Are you able to RDP from the hyper-v host to the problem server?  Not via Hyper-V console connection, but using Remote Desktop Connection.

    2. If you connect to the problem server's console using Hyper-v manager, are you able to open Remote Desktop within the VM and connect back to localhost?

    3. When the problem occurs, have you checked that Remote Desktop Services service is Started?  Also, please check if it is still listening on port 3389 using netstat -ano command.

    4. Did this behavior start after applying windows updates?

    5. If this Server 2008 R2 is running under Hyper-V 3 please make sure to install the latest integration services in the VM.



    Monday, January 21, 2013 10:08 PM
  • So, here's answers to your questions, and a little deeper insight and different symptom now:

    1. RDP from the Hyper V host (not the console) exhibits the same behavior

    2. Cannot RDP from the culprit system to its localhost (

    3. Remote Desktop Services was stopped (also set to manual - - hmmmmm.) Set Service to Automatic Start and started the service.  netstat -ano prior did not show listening on port 3389.  After starting services, we show listening on port 3389.

    4. Unknown.  Will have to check logs and anecdotal information.  It is a server we've had online for a while, but are just getting ready to move it from test into production.  I can tell you that its updates are current (as are all others in our server farm - actually its more like a server garden - about 20).

    5. N/A

    With RDP service running - we still see the same behavior - the "Welcome" screen appears breifly, then the machine disconnects.

    Examination of the events log reveals: (Clipped text of error logged below:)

    Log Name:      Application
    Source:        Application Error
    Date:          1/22/2013 1:16:12 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      VIPRODAPP04.Somedomain.Org
    Faulting application name: svchost.exe_TermService, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
    Faulting module name: rdpcorekmts.dll, version: 6.1.7600.16952, time stamp: 0x4f1f9e66
    Exception code: 0xc0000005
    Fault offset: 0x000000000000a793
    Faulting process id: 0xb88
    Faulting application start time: 0x01cdf8e59d08dc55
    Faulting application path: C:\Windows\System32\svchost.exe
    Faulting module path: C:\Windows\system32\rdpcorekmts.dll
    Report Id: f233146e-64d8-11e2-aa53-00155d22dd04

    Does that help narrow things down?


    Tuesday, January 22, 2013 9:46 PM
  • Hi Paul,

    Yes, that narrows it down.  It appears your rdpcorekmts.dll file is incorrect version, which is causing RDS service to crash.

    How come you are not using Service Pack 1 on your server?  I recommend installing service pack 1 unless you have a good reason not to, such as a specific application incompatibility.  After installing SP1 please check for updates and install all important updates multiple times until none remain.

    If installing SP1 and all updates does not resolve the issue (or you do not want to install SP1), then you may try uninstalling KB2667402 and KB2621440, restart, go to windows update and check for updates again and re-install them (2621440 & 2667402).  After completing this please verify that rdpcorekmts.dll is different version than you have now, and see if you are able to connect using Remote Desktop.



    Wednesday, January 23, 2013 12:12 PM
  • Hi TP:

    I think we're getting closer.

    We are running SP1. Sorry I neglected to say that in my earlier description.

    KB2667402 shows in update history as failed.  Attempting to install again fails with error code 8024200D.  Tried downloading the MSU file and it failed as well.

    KB2621440 shows as successfully installed in update history, so uninstalled it, rebooted the server, re-installed it, restarted the server, and attempted install of KB2667402 - received the same error code "Windows Update encountered an unknown error."  Looking up this error code in online help delivers no information.

    No joy here (yet.) - Any ideas on why the KB install would fail?


    Wednesday, January 23, 2013 7:53 PM