none
WdsClient: There was a problem initializing wds mode RRS feed

  • Question

  • Having an issue with deploying windows 7 through WDS on Windows Server 2003.

    I can boot to the PXE fine, have captured an image connects through DHCP fine. Capture image is on the WDS server, modified etc.

    I run into an issue when actually trying to install an image to a PC. It loads, sees the boot image, appears to load the boot image, then during the "Starting Windows" screen, after about 10 seconds it throws an error. "WdsClient: There was a problem initializing wds mode"

    I've tried recreating the boot image, using a discover image, all to no avail.

    I know this has been asked before, most solutions seem to be based around having multiple network cards, or no drivers for them. Doesn't seem to be the issue as I can hit Shift+f10 to open the command prompt, I have an ip, can ping the WDS server by FQDN and IP. I feel as though it is an issue with my boot/capture image as it seems to loads that fine, but when it is starting the next process it breaks. 

    Any Thoughts?

    Tuesday, July 5, 2011 2:34 PM

Answers

  • Got it. 

    Option 67 was configured to PXEboot.com as someone on our network must've tried to configure this before.

    Changed it to wdsnbp.com and now it appears as though everything is a go. Install is going as we speak.

    Thanks for the link Tim, that got me going in the right direction. Also, router forwarding was not really an option with the network setup we have so we need to use DHCP, which I understand is not quite as reliable, but it's going to have to do the trick.

    • Marked as answer by bolson32 Wednesday, July 6, 2011 4:13 PM
    Wednesday, July 6, 2011 4:13 PM

All replies

  • Hi,

     

    First if you have multiple Network Interface Card (NIC)s installed on your computer, disable the unused (Not connected) NICs on the client computers in the BIOS.

     

    In addition, you may have a problem with the network or the configuration of the Windows Deployment Services server. A common cause is if a client is on a different subnet from the Windows Deployment Services server and you have not configured the server to get the network signal through the router.

     

    To fix this, see the "Configuring Your Router to Forward Broadcasts" section in the following article:

     

    http://technet.microsoft.com/en-us/library/cc732351(WS.10).aspx

     

    Tim Quan

     

    • Proposed as answer by mohaltron Sunday, September 22, 2013 10:08 AM
    Wednesday, July 6, 2011 3:34 AM
    Moderator
  • Only 1 NIC installed, Client and WDS server are both on the same subnet. I have added UDP port 4011 to always allow on our router/firewall.

    I'm thinking currently it may be an issue with DHCP not being configured properly, but I'm not sure.

    I currently have Do not listen on Port 67 and Configure DHCP option 60 to PXEClient both unchecked. Both checked also did not work. My DHCP server is on another server. Not my WDS Server.


    Although I'm not sure how it can be a DHCP issue since it boots to PXE fine, and captures an image.
    Wednesday, July 6, 2011 3:30 PM
  • Got it. 

    Option 67 was configured to PXEboot.com as someone on our network must've tried to configure this before.

    Changed it to wdsnbp.com and now it appears as though everything is a go. Install is going as we speak.

    Thanks for the link Tim, that got me going in the right direction. Also, router forwarding was not really an option with the network setup we have so we need to use DHCP, which I understand is not quite as reliable, but it's going to have to do the trick.

    • Marked as answer by bolson32 Wednesday, July 6, 2011 4:13 PM
    Wednesday, July 6, 2011 4:13 PM
  • Hi Bolson,

    Please advise how you configured option 67 i am running 2k8 R2


    Meshax


    • Edited by Meshack KE Friday, March 30, 2012 5:04 PM
    Friday, March 30, 2012 5:03 PM
  • Hi,

     

    First if you have multiple Network Interface Card (NIC)s installed on your computer, disable the unused (Not connected) NICs on the client computers in the BIOS.

     

    In addition, you may have a problem with the network or the configuration of the Windows Deployment Services server. A common cause is if a client is on a different subnet from the Windows Deployment Services server and you have not configured the server to get the network signal through the router.

     

    To fix this, see the "Configuring Your Router to Forward Broadcasts" section in the following article:

     

    http://technet.microsoft.com/en-us/library/cc732351(WS.10).aspx

     

    Tim Quan

     

    this solution worked for me, I'm using VMware workstation 10 and have two network cards, one of them NAT and the other is host-only network, after disable the NAT network card, now it is OK and I can connect to the WDS server.
    Sunday, September 22, 2013 10:11 AM
  • I ran into a little different issue with the same error message (WdsClient: There was a problem initializing wds mode).  In my case I had to create a new Boot Image in WDS.
    Monday, September 23, 2013 8:21 PM
  • Hi Guys,

    I had this problem too, and I tried anything I could including the method Tim mentioned. But no luck. I spent a few days on it. Exhausted!

    But the problem was narrowed to certain settings incorrect with dhcp. So I deleted and added dhcp role, then it worked.

    So if you have this problem, just focus on DHCP settings, or simply re-add dhcp role.

    Thanks

    Alex Morgan Super.

    Thursday, August 6, 2015 11:06 PM