none
Device Management Hyper-V Core Server

    Question

  • I can access the core server , i can work with the disk management, event view i can see the serive but when I try to access the Device Manager it gives me this error

    "Unable to access the computer HVS1.
    Make sure that this computer is on the network, has remote administration enabled, and is running the Plug and Play and Remote Registry services.

    The error was : Access is denied."
    Sunday, September 6, 2009 8:45 AM

Answers

  • Hi,

     

    This is an expected behavior.
     

    Device Manager:

     

    You must first enable the Allow remote access to the PnP interface policy setting. To do this, on a computer running Windows Vista or a full installation of Windows Server 2008, open the Local Group Policy Editor MMC snap-in, connect to the computer running a Server Core installation, navigate to Computer Configuration\Administrative Templates\Device Installation, and then enable Allow remote access to the PnP interface. Restart the computer running a Server Core installation.

    Note that when Device Manager is used remotely, it is read-only.

     

    For more information, you can refer to:

     

    Server Core Installation Option Getting Started Guide

    http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=B16F4DC4-A3D3-4DC7-AA51-A1C6728B217A&displaylang=en

     

     

    Best Regards,

    Vincent Hu

     

    Monday, September 7, 2009 6:36 AM
    Moderator

All replies

  • Still read only. why?
    Monday, September 7, 2009 4:36 AM
  • Hi,

     

    This is an expected behavior.
     

    Device Manager:

     

    You must first enable the Allow remote access to the PnP interface policy setting. To do this, on a computer running Windows Vista or a full installation of Windows Server 2008, open the Local Group Policy Editor MMC snap-in, connect to the computer running a Server Core installation, navigate to Computer Configuration\Administrative Templates\Device Installation, and then enable Allow remote access to the PnP interface. Restart the computer running a Server Core installation.

    Note that when Device Manager is used remotely, it is read-only.

     

    For more information, you can refer to:

     

    Server Core Installation Option Getting Started Guide

    http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=B16F4DC4-A3D3-4DC7-AA51-A1C6728B217A&displaylang=en

     

     

    Best Regards,

    Vincent Hu

     

    Monday, September 7, 2009 6:36 AM
    Moderator
  • did you mean Device Manager will always be read only?

    I see the same read only prompt on the devices manager both Hyper-V core on a workgroup and Hyper-V joined to the domain.

    And also Hyper-V on the workgroup I can't access the disk management while Hyper-V on the joined domain I can add remove the hdd.

    thanks in advance. mentioned that I'm running the Hypervisor core not the windows core.

    Monday, September 7, 2009 8:47 AM
  • Hi,

     

    Q: did you mean Device Manager will always be read only?

     

    >>> Yes, you can refer to the document in the link I provided in my last reply.

     

    Disk Management is different from Device Manager, you can add or remove hard drive if you have the right privilege. When Device Manager is used remotely, it is read-only all the times no matter you are in a workgroup or a domain environment, and no matter Hyper-V Server(the free version) or Windows Server 2008 Core Edition.

     

    Best Regards,

    Vincent Hu

     

    Monday, September 7, 2009 8:58 AM
    Moderator
  • what about disk management- where do I give the privilige to add/remove hdd.

    Monday, September 7, 2009 6:54 PM
  • Hi,

     

    If you want to manage a Disk Management remotely, please perform the following steps:

     

    1.    To allow all MMC snap-ins to connect, at a command prompt, type:

    Netsh advfirewall firewall set rule group=“remote administration” new enable=yes

     

    2.    To allow only Disk Management MMC snap-ins to connect, at a command prompt, type:

     

    Netsh advfirewall firewall set rule group=“Remote Volume Management” new enable=yes

     

    Note: You must first start the Virtual Disk Service (VDS) on the computer running a Server Core installation. Please also enable “Remote Volume Management” in your client computer.

     

    3.    You must be a domain user who is a member of the local administrators group on the Server Core computer you want to manage.

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, September 8, 2009 8:38 AM
    Moderator
  • ·         Hi,

     

    Have you tried the suggestion? I want to see if the information provided was helpful. Your feedback is very useful for the further research. Please feel free to let me know if you have addition questions.

     

     

    Best regards,

    Vincent Hu

    Thursday, September 10, 2009 2:33 AM
    Moderator
  • I can't connect the device manager to the Hyper-V core server as well. However, I can't change the policy setting "Allow remote access to the PnP interface" because I'm running in a workgroup environment. How to do this in a workgroup environment?

    Thanks,
    Christian

    Monday, September 21, 2009 11:36 AM
  • Hi,

     

    How to do this in a workgroup environment?

     

    >> Please perform the following steps:

     

    1.    on a computer running Windows Vista or a full installation of Windows Server 2008, type the computer name/IP address of the Server Core computer in run such as “\\computer-A or \\xxx.xx.xx.xx”, the system will ask you for user name and credential of the Server Core computer. After you type the user name and the credential, you will have the credential cache on your client computer.

    2.    Open Group Policy Object Editor MMC snap-in, connect to the computer running a Server Core installation, navigate to Computer Configuration\Administrative Templates\Device Installation, and then enable Allow remote access to the PnP interface. Restart the computer running a Server Core installation.

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, September 22, 2009 4:29 AM
    Moderator
  • Hi Vincent,

      Thanks for the guidance on this.

      While it seems that the guidance is a solution I have the following situation which continues to prevent me from accessing Device Manager remotely on the Hyper-V 2008 R2 server.


     I am in a single domain environment.

     I log onto a W2K8 R2 system in the domain using a domain administrator account.

     I open MMC and add the "Local Group Policy Editor" snap-in.

     I successfully connect to the Hyper-V 2008 R2 server

     I expand "Computer Configuration\Administrative Templates"

     But I am do not see the "Device Installation" folder so I am unable to access the "Allow remote access to the PnP Interface" setting.

    Any clue you can provide would be helpful.

    Thanks,
    René Nielsen

    Friday, December 11, 2009 4:28 PM
  • The full correct path is Computer configuration\Adminstrative Templates\System\Device Installation

    Thursday, January 14, 2010 9:24 PM
  • Hello to all,
    what is the way to Manage devices on a Server Core? If I will disable an device, for example an NIC, what can I do?

    Thx

    Holger
    Thursday, February 11, 2010 1:33 PM
  • So I have a realtek gigabit nic that is not working as it should. I would like to install a different driver for this. How do I do that if remote device manager is read only?

     

    thanks

    Michael


    MPlotsker
    Tuesday, November 2, 2010 2:20 PM
  • So I have a realtek gigabit nic that is not working as it should. I would like to install a different driver for this. How do I do that if remote device manager is read only?

    thanks

    Michael


    MPlotsker
    Download the driver and use the pnputil.exe (on the server) command to install the *.inf driver

    Wednesday, May 30, 2012 8:44 AM