none
2012 Licensing Problem RRS feed

  • General discussion

  • I would like to make everyone aware of an issue with RDS and the FIX from Microsoft services which I consider unacceptable.

    The setup is as follows. One 2012 DC with Terminal server licensing installed. Two 2012 servers with RDS enabled. Take note that RDS was NOT deployed using the wizard as there is no need for all of the resources of a server farm for 2 servers. On each of the RDS enabled servers, group policey was used to enable and specify the RDS server and licensing mode. The RD Licensing Diagnoser was used to verify, and report that no licensing problems for the Remote Desktop Session Host Server existed, and the tray icon that reports that you are running a trial version of RDS does NOT appear.

    Advance forward a few months and users start reporting that they cannot login and that they are receiving “The remote session was disconnected because there are no RDS license servers available to provide a license."

    After doing all that I could I filed a case with Microsoft Support at the Highest Level Possible. After a month I finally was able to talk to someone. After 2 more weeks, here is the solution they gave me….

    1. Open the registry, Navigate to HKLM\System\CurrentControlSet\Control\TerminalServer\RCM
    2. Delete the GracePeriod Key
    3. Reboot

    This continues to occur every few months. I wish someone at MS would FIX the problem.

     


    Lee


    Tuesday, November 5, 2013 3:59 PM

All replies

  • Hi Lee,

    1. Do you own Per Device or Per User RDS CALs?

    2. After you had licensing configured properly, did you verify that your purchased RDS CALs were being issued?  In the case of Per Device they would show up in RD Licensing Manager.  In the case of Per User you would need to create a Per User Usage report, export it to .csv file, and then view it in Notepad.

    3. For Per User, please check on the RD Licensing server log for 4105 warnings.  Additionally, please check the log for entries for successful issues, renewals, etc.  I am curious if your RD Licensing is otherwise operating properly or not.

    As a side note, if you do not mind the RD Connection Broker being loaded on one of your RDSH servers then you could go ahead and create a RDS deployment.  RD Connection Broker does not use that much resources (unless it is large active environment), and RD Web Access uses a tiny amount of resources.  The downside of having RDCB on one of your RDSH servers is if it goes down you lose your broker capability, but from your description it sounds like that would not matter.  Upside is you would be able to use the standard 2012 methods to manage your RDS environment.

    Thanks.

    -TP

    Tuesday, November 5, 2013 7:00 PM
    Moderator
  • i had the same case opened last week, i was told a hotfix is being developed for this but no ETA, every 120 days i have to go in and remove the registry key you've mentioned until this is resolved.  it's a pretty widely known issue with 2012 RDS, my license server is not on a DC and i have a full scenario-based deployment running (5 collections actually) and all of them have this issue.
    • Edited by armin19 Tuesday, November 5, 2013 8:10 PM
    Tuesday, November 5, 2013 8:09 PM
  • Hi,

    I would like to check if you need further assistance.

    Thanks.


    Jeremy Wu

    TechNet Community Support

    Thursday, November 7, 2013 7:31 AM
    Moderator
  • Hi armin19,

    Please provide more details on your environment.  It would be helpful if you would answer the three questions I asked Lee Taylor above.

    I have not seen the problem you describe first hand, although I have seen people here mention resetting the grace period.  Often it is hard to tell what the circumstances are because people will reply to someone else that they reset the grace period without giving any details about their situation, exact symptoms, and why they decided to do it.

    Thanks.

    -TP

    Thursday, November 7, 2013 3:01 PM
    Moderator
  • sure.

    i have 5x 2012 RDS farms, nearly identical in configuration dispersed throughout the globe, each farm has:

    • 2x RDSH
    • 1x RDCB, RDWeb, RDLicense server with 2012 CALs deployed as User Mode
    • We are pointing directly to the license server in our collection settings (only 1 collection per farm) and also again via GPO settings to override license server auto discovery options
    • These systems were rolled out using scenario-based installs so while RDWeb is there, it's not actually being used (nothing published to it), users are leveraging session-based desktops via RDP client both internally and externally
    • systems are all domain joined, we're still on 2003 functional level in AD

    i first encountered this issue around the 120 days mark after the first farm went into production, we saw that users could not login and event ID 1130 was being thrown for every login attempt.

    i saw this article and followed the steps to resolve it:

    http://www.360ict.nl/blog/no-remote-desktop-licence-server-availible-on-rd-session-host-server-2012/

    however, after another 120 days passed, i ran into the same issue again, realizing this was not a permanent fix.  after just opening the case with MS on this a couple of weeks ago, they've told me it's a bug and so for now, i proactively purge the L$RTMTIMEBOMB_nnnn key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod, i restart TermService so i don't have to reboot the whole box and it's fine for another 120 days

    during the issue and even when it's not occurring, licensing diagnostics come up clean, i haven't taken a report while the issue is occurring but when it's not occurring the reports  show CALs being assigned to all users by the license server.

    basically, it seems like even though we have a license server that is activated with user CALs, the Review section shows green checks under both sections, and reporting is fine - the system is stuck in 120 day trial mode for some reason.

    now MS did say they know about this and they're working on a fix, hopefully not to just get me off the phone, but they didn't have a different workaround and advised that i continue doing what i'm doing.

    what i don't really understand is that when i remove the L$RTMTIMEBOMB_nnnn key from the registry, it gets recreated upon the first user logon that has to go talk to the license server. in a working 2012 environment, should this key even exist if an active license server is already available?
    • Edited by armin19 Thursday, November 7, 2013 4:27 PM
    Thursday, November 7, 2013 4:22 PM
  • For those trying to post an "answer". The above is a statement not a question AND includes the official answer from Microsoft Tech Services.

    Lee

    Monday, November 11, 2013 1:11 PM
  • Hi Lee,

    I thought you were looking for assistance, and a possible resolution to the issue.  The fact that you were given a certain answer by Microsoft support does not mean that I (or someone else) will be unable to solve the problem.  There are Server 2012 RDSH servers that have been running for more than 120 days that are not experiencing the licensing issue that you describe.

    I will switch the thread type to discussion since you have indicated that your text is a statement and not a question.

    -TP

    Monday, November 11, 2013 2:55 PM
    Moderator
  • Microsoft is full of SHIT.

    I paid good money for the software bought all the licenses and trying to be above board.

    yet the system does not work.

    I cannot have more than 2 people access the server remotely.

    So why was I required to pay for licenses that the system doesn't recognize.

    Who is going to pay for my time to rest the license every 120 days.

    This is not acceptable

    Monday, December 2, 2013 3:31 PM
  • I tried delete the file in regedit, but unable to.

    I am logged in as administrator.

    is ther any other way to delte that file or enable to allow remote access by the licences

    Monday, December 2, 2013 5:18 PM
  • There is a hotfix for this issue now:

    http://support.microsoft.com/kb/2916846

    Tuesday, March 18, 2014 1:31 AM
  • Don't expect the hotfix to work...
    Tuesday, March 25, 2014 4:11 PM
  • Hotfix doesn't do it. Regkey is comming back after logging in.

    I've installed another server as license server now. This server doesn't get the regkey so I hope this is the workaround for now...

    Friday, April 18, 2014 8:49 AM
  • I don't think KB2916846 is meant to fix this problem, it seems to be addressing something entirely different but if it's worked for anyone, please let us all know.

    Regarding the regkey, the solution wouldn't be to have it purged out permanently, it always has to be there on the RDSH. once you delete it and reboot or restart the TermService service, when the first user logon which requires an RDS license hits the box, the key will automatically be recreated.  this usually won't include admin logons or admin sessions as they don't need a license.

    this key is also present on RDSH servers which are not impacted by this issue.

    the license server shouldn't have this key unless it becomes part of the farm so that's expected.

    it's the hex value of the key that's the problem, being incorrectly set to 120 days grace period instead of a valid licensed system.  you're basically resetting the 120 days grace timer every 4 months as a workaround.

    Tuesday, May 13, 2014 8:41 PM
  • well, in this thread the hotfix seems to have worked so either you've done something to the registry permissions of that key that the hotfix is not taking effect or maybe it's not fixing the issue in all environments

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/d3b99475-32ac-4846-870b-455417266609/remote-desktop-configuration-tool?forum=winserverTS

    Thursday, May 22, 2014 1:46 PM
  • Hello,

    I'm running into the same issue with unable to login to remote server, and unable to delete the registry key.  Anyone have pointer to resolving this issue?

    Your help is much appreciated!

    Thursday, November 27, 2014 3:06 AM
  • You may need to change the permissions on the reg key to be able to delete it.

    Lee

    Thursday, November 27, 2014 2:14 PM
  • you should try the hotfix instead of the regkey hack. if in fact your issues is due to the bug discussed in this thread the hotfix should take care of it

    http://support.microsoft.com/kb/2916846

    a lot of confusion with this problem is that everyone leans towards the bug but the issue may be that they are not properly pointing their servers to the license server so make sure you've done that correctly

    Tuesday, December 2, 2014 3:18 PM
  • Thanks. This hotfix worked for me eventually. I installed it and rebooted, but I was still getting the error about licensing when I tried to RDP into the server. Then I opened the RD Licensing Diagnoser (while logged in at the console) and it said there are no problems. I tried to RDP again and then it worked fine.
    Wednesday, June 17, 2015 6:58 PM
  • Note we no longer have this issue since updating to 2012 R2

    Lee

    Wednesday, June 17, 2015 7:15 PM
  • Hi Lee but i am facing similar issue on Server 2012 R2 as well.

    Need to remove the graceperiod entry once in 120 days for the RDP to work.

    Thursday, November 24, 2016 6:04 AM
  • OK - I have 2 servers with different clients where I have (finally!!!) resolved this problem.

    Server 1 - has 3 additional Remote Desktop licences on top of the in-built administrative licences. The 3 RDP licences were loaded and appeared in the Licensing manager status screen thingy, all looked perfect and worked perfectly - until 120 days - then the grace period messages started appearing. After MUCH mucking around, I finally resolved it by re-loading the additional 3 RDP licences into the licencing part of Remote Desktop (sorry, I'm not looking at the server right now so names/terminology may not be 100%). The licences went through, activated etc, and everything is now working. The licence window shows 2 instances of installed 3-user RDP licences, however only one of those shows as active. Looks like the initial load of the RDP licences didn't activate properly!

    Server 2 - only using the built-in administrative licences. During the installation, I opted to install Remote Desktop services, expecting that this gave access to the 2 administrative remote desktop sessions - wrong! This loads up the full terminal-server functionality and is NOT required for normal admin use. The 120-day problem with no RDP access at all, was fixed after I uninstalled Remote Desktop services under add/remove roles, and then I had to go into System Properties, Remote tab, and enable the Allow Remote Connections To This Computer option.

    Both machines working now - I'm happy. I'll be even more happy if it's still running in another 121 days!!!!!!!!!

    Friday, February 3, 2017 12:33 AM
  • Hi All,

    I almost followed a suggestion that instructs to install a third-party psexec software in order to remove GracePeriod key via regedit. This wasn't required at all.

    I just run regedit as admin, exported 'GracePeriod' just in case, then right click on it then "Permissions" and was able to add "Full control" to my admin user account then delete it.

    After a reboot the 'GracePeriod' key has returned but am no longer able to change permissions for it as above - would it be because newly generated is now in use?

    I hate Microsoft and their overcomplex s**te! Wasting 20+ times more time than on linux to achieve goals.

    D

    Thursday, November 29, 2018 4:10 PM
  • this is an issue identified several years ago on 2012 (non-R2) and addressed via the mentioned hotfix.  you should not need to butcher the registry to work around it as long as the hotfixes are up to date and you are properly connecting the license server
    Thursday, November 29, 2018 7:45 PM