none
Problem Deploying Xerox Printer Using GPP For Non-Admin Users RRS feed

  • Question

  • Hello!  I am experiencing a problem when deploying printers, specifically a Xerox 7655 printer.  When the user logs in, waits for the Xerox printer to show up in the printers list, waits for about 1 minute and then logs out, an error message appears at the welcome screen stating:
    ___
    [Title] Xerox Printer Driver
    [Body] An unexpected error occured in the print driver.
    Close the current driver window and retry the operation.
    014:000:0662
    ___

    This error message only appears once.  If the user clicks OK and then logs back in and then logs out, the error message does not appear.  However, if the user deletes the printer (without deleting the driver) and then relogs in, then the same message appears once.

    The printer server is running Windows 2008 SP2 32bit and the client workstation is Windows XP SP3 32bit.

    The problem does not occur if the user is given admin rights.

    Here is what I have tried:
    1. I tried both PCL and PS printer drivers and both produced the error message.
    2. The other HP printers I have do not produce this problem for non-admin users.
    3. I enabled GPP tracing and here are some lines that may be relevant:

    ___
    2009-06-10 16:27:02.046 [pid=0x294,tid=0x840] Started applying policy.
    2009-06-10 16:27:02.046 [pid=0x294,tid=0x840] GPE data file : \\<domain>\SysVol\<domain>\Policies\{3A943DC9-7B92-4D96-8755-2511AE370421}\User\Preferences\Printers\Printers.xml
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Set user security context.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Opened file.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Got file size.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Created file buffer.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Completed read file data.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Terminated file buffer.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Closed file handle.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Read GPE XML data file (475 bytes total).
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Set system security context.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Completed parse of GPE XML data.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Completed loading of package.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Completed get tree root.
    2009-06-10 16:27:02.062 [pid=0x294,tid=0x840] Started package execution.
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Set package timestamp variable (2009-06-10 23:27:01).
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Starting class <Printers>.
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Handle Children.
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] {9A5E9697-9095-436d-A0EE-4D128FDFBCE5}
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Starting class <SharedPrinter> - GD Xerox 7655.
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Set user security context.
    2009-06-10 16:27:02.078 [pid=0x294,tid=0x840] Set system security context.
    2009-06-10 16:27:03.098 [pid=0x294,tid=0x840] Set user security context.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Set system security context.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Properties handled.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Handle Children.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] EVENT : The user 'GD Xerox 7655' preference item in the 'Printers - GD {3A943DC9-7B92-4D96-8755-2511AE370421}' Group Policy object applied successfully.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Completed class <SharedPrinter> - GD Xerox 7655.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Completed class <Printers>.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Completed package execution.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] Completed execution of apply package.
    2009-06-10 16:28:49.116 [pid=0x294,tid=0x840] GPH data file : C:\Documents and Settings\All Users\Application Data\Microsoft\Group Policy\History\{3A943DC9-7B92-4D96-8755-2511AE370421}\S-1-5-21-1109287675-766858259-666385194-4658\Preferences\Printers\Printers.xml
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x840] Updated GPH.
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x840] EVENT : The client-side extension could not apply user preference items for the 'Printers - GD {3A943DC9-7B92-4D96-8755-2511AE370421}' Group Policy object because Windows is shutting down or the user is logging out..
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x840] Completed apply GPO. [ hr = 0x86011007 "The client-side extension could not apply user preference items for the 'Printers - GD {3A943DC9-7B92-4D96-8755-2511AE370421}' Group Policy object because Windows is shutting down or the user is logging out.." ]
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x840] User impersonation uninitialized.
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x63c] Leaving ProcessGroupPolicyExPrinters() returned 0x86011007
    2009-06-10 16:28:49.132 [pid=0x294,tid=0x63c]
    ____

    The GPP appears to hang at 16:27:03 until I begin to log out at 16:28:49 at which point the error is produced.

    Has anyone else experienced similar issues? 

    I would appreciate any help with this.  If anyone needs any more information about this, please let me know.

    Thanks.
    Thursday, June 11, 2009 12:04 AM

All replies

  • Hi,

    Based on the symptom, the Xerox printer required admin rights to install while normally printer drive doesn't require admin rights during user log on. Please try to update the Xerox printer driver on server and test.

    If latest driver cannot solve the problem, please try to install the printer manually on clients using non-Admin users.

    Please also try the suggestions below to check if the error persists.

    Deploy printers by using Group Policy
    http://technet.microsoft.com/en-us/library/cc722179(WS.10).aspx

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 12, 2009 5:58 AM
    Moderator
  • Hello Mervyn!  I forgot to mention that I was able to install the Xerox printer driver successfully as a non-admin user if I do it manually (browse to print server and then double printer share) with no errors.

    I have verified that I have the latest Xerox drivers and have tried both the PS and PCL variants.

    I was aware of the GP method of deploying printers, but it requires running PushPrinterConnections.exe upon startup and I am trying to get something cleaner like GPPs if possible.  The GPPs work great except for these Xerox drivers.

    Also, I verified that the GP setting "Prevent users from installing printer drivers is set to disabled".

    Is there anything else I can do?  Thanks.
    Friday, June 12, 2009 6:51 AM
  • Hi,

    If this issue only occurs on Xerox printer, please involve Xerox Support to check if they may modify their driver.

    As a workaround, please try to create a user log on script to add the printer.

    Set WshNetwork = WScript.CreateObject("WScript.Network")
    PrinterPath = "\\SERVER\PRINTER"
    WshNetwork.AddWindowsPrinterConnection PrinterPath

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 15, 2009 2:10 AM
    Moderator
  • Any solution to this? We are having the exact same problem.
    Thursday, April 8, 2010 1:16 AM
  • I am having the same issue.  Technician from Xerox emailed me the link to download the lastest version and Installed the driver and no luck  so I am using the VBS as Mervyn Zhang mentioned as temporary solution till we deploy all workstations with Windows 7 this summer.  Listed below are the links that tech send to me.  Hopefully, you guys can resolve this or find other solution.  Lmk.

    English 32- Bit Drivers:
    PS Driver: 
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101092&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP&Xtype=download&uType=
     
    PCL Driver:
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101093&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP&Xtype=download&uType=
     
    PCL6 Driver: 
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101094&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP&Xtype=download&uType=
     
    English 64- Bit Drivers:
    PS Driver: 
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101560&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP%20x64&Xtype=download&uType=
     
    PCL Driver:
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101561&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP%20x64&Xtype=download&uType=
     
    PCL6 Driver: 
    http://www.support.xerox.com/go/getfile.asp?Xlang=en_US&XCntry=USA&objid=101562&EULA=1&prodID=WC7655_WC7665&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP%20x64&Xtype=download&uType=

    Friday, May 7, 2010 6:39 PM
  • Hi Folks,

    I just spent about 3hrs today to try and solve this. I ended up patching one of the driver files so that the error message doesn't appear.

    Open x2utilE9.dll from the driver package in XVI (http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm), jump to file offset 0x1F29D (valid in file version 5152.1100.0.0; latest as of 17/05/10), and do Edit > Overwrite String - select Hex String radio button and enter 90 00 00 , then press OK. Finally, press Save.

    Your mileage may vary/no warranty implied, blah blah blah standard covering my ____.

    Let me know how you go!

    Thanks,

     

    Josh

    Monday, May 17, 2010 5:15 AM
  • I should add that I'm using the Xerox Global Print Driver (Postscript) here. I can post an MD5 hash of x2utilE9.dll if you want to determine whether your printer's driver uses the same file. It should as this file doesn't appear to include any printer specific details (it does none of the print job rendering or Printer Preferences dialog box).
    Monday, May 17, 2010 6:14 AM
  • I am having the same issue with GPP and Xerox drivers, I am attempting to work this magic on the global PCL6 driver, however I am unable to locate the correct offset. Driver version is 5.152.11 and I am working with x2utilE9.dll.  Perhaps I am missing a step.    

     

    Correction:  I have located the offset and I am testing the results now...

    Thursday, June 10, 2010 12:54 PM
  • MoRgZ06's solution works great and suppresses the error, however the user login time is slowed to a crawl.  3+ minutes!  The printer will work, but this wait is unacceptable.  
    Friday, June 11, 2010 3:52 PM
  • I noticed a delay when it initially downloads and installs the driver, but none after that. Do you experience the delay every login?

    I haven't yet brought this up with Xerox as I'm not sure who to contact. I'm based in AU and we have a support agreement with Fuji Xerox here, but I doubt they'll support the Xerox Global Print Driver.

    Saturday, June 19, 2010 6:43 AM
  • Hi all,

    This problem should have been overcome with the Xerox driver GPD 5.173.11. Neverthless if intend to deploy it or pre-test I would advise to get GPD 5.173.13 which solves some MS Office apps printing bugs.

     

    • Proposed as answer by MoRgZ06 Friday, October 8, 2010 5:01 AM
    Monday, September 6, 2010 4:13 PM
  • Awesome, thanks, Larbac.
    Friday, October 8, 2010 5:01 AM
  • Awesome, thanks, Larbac.

    Hi, 

    by now you will not find that version anymore :)

    You have GPD 5.185.15 available on www.xerox.com\global, it should not influence on that issue.

    Did this worked for you? I ask because I found this topic as still not answered.

    Larbac

    Friday, October 8, 2010 6:51 PM
  • Sorry, are you saying 5.185.15 fixes the issue? I haven't tested the driver yet.
    Saturday, October 9, 2010 5:18 AM
  • Sorry, are you saying 5.185.15 fixes the issue? I haven't tested the driver yet.
    GPD 5.173.13 solves the problem but it has been replaced for 5.185.15. There are no changes that would affect installation files on the latest version. Therefore I believe it will work.
    Saturday, October 9, 2010 4:23 PM
  • We downloaded the latest PCL6 drivers (5.152.4.2) from the Xerox website today.  We experienced the same issue with Group Policy Preferences as well.  As a current (and possibly permanent) workaround, we utilized the Windows Server 2003 R2 method for deploying printers using group policy (http://technet.microsoft.com/en-us/library/cc722179(WS.10).aspx).  The printer deployed as expected with no problems.  While this is not preferred, this will deploy the printer without the users experiencing the error message.

    Thanks,

    Ryan

    • Proposed as answer by tommaz3 Friday, November 18, 2011 11:38 AM
    • Unproposed as answer by Aakash Shah Friday, November 18, 2011 2:22 PM
    Tuesday, May 17, 2011 9:24 PM
  • Solution to the problem of error:
    [Title] Xerox Printer Driver
    [Body] An unexpected error occured in the print driver.
    Close the current driver window and retry the operation.
    014:000:0662
    is to install the drivers:
    http://www.support.xerox.com/support/global-printer-driver/file-download/enus.html?operatingSystem=win7&fileLanguage=en&contentId=118007&from=downloads&viewArchived=false
    http://www.support.xerox.com/support/global-printer-driver/file-download/enus.html?operatingSystem=wins2008x64&fileLanguage=en&contentId=118008&from=downloads&viewArchived=false

    Friday, November 18, 2011 11:42 AM