none
putty: network error permission denied

    Question

  • Hello, I posted this here and they send me to your TechNet forum. Because i misread the topic i also posted it here and the owner suggested i post it under Windows Server Forums > Security .  I hope i finally am in the right place.

    I use windows 7 home premium x64 and want to connect to a linux server through a vpn tunnel with Putty (SSH). I set Windows Firewall to block all outbound traffic by default and allow only those which are in my rulelist to pass through.

    I allow putty to connect inbound and outbound but i get the message "fatal error ->network error: permission denied". It seems that the Windows Firewall is blocking putty even when i set it to allow. I found a thread a Vista forum here with the same issue. The support didnt answer, but the user figured the port which is part of the problem. He opened for TCP on port 22 for all outgoing applications. This works, but doesnt fullfill my security policy.

    Which application (other than putty) do i need to allow TCP outgoing on port 22 to avoid this error?

     

    PS: I have set my FW to tell me when it is blocking an application and i dont get any messages even when it blocks. I get only the error message from putty and have to guess that its my firewall blocking.

    B) Is there a tool/buildt in function that allows me to check what gets blocked?

    B1) Can i set my system to log attempts of outgoing traffic?

    • Edited by Fusch Thursday, October 28, 2010 10:06 AM extended with suggestive questions
    Thursday, October 28, 2010 9:56 AM

Answers

  • Thanks for nothing... solved it myself.

    The error is inside windows 7, the location of the file putty.exe in combination with the path set in the firewall. It doesnt make sense but thats windows.

    I only get the error when the firewall includes %username% in the path of allowed application rule. The solution is to move putty.exe to another location so the path doesnt include %username%.

    My user account is an administrator account. F*** windows c***, always some bs in the background that compromises the user and the whole systems integrity and consistens.

    • Marked as answer by Fusch Saturday, November 6, 2010 10:01 AM
    Saturday, November 6, 2010 10:01 AM

All replies

  • Thanks for nothing... solved it myself.

    The error is inside windows 7, the location of the file putty.exe in combination with the path set in the firewall. It doesnt make sense but thats windows.

    I only get the error when the firewall includes %username% in the path of allowed application rule. The solution is to move putty.exe to another location so the path doesnt include %username%.

    My user account is an administrator account. F*** windows c***, always some bs in the background that compromises the user and the whole systems integrity and consistens.

    • Marked as answer by Fusch Saturday, November 6, 2010 10:01 AM
    Saturday, November 6, 2010 10:01 AM
  • Actually I recently ran into this issue myself, I have windows 8.1. I found that you have to "troubleshoot compatibility". Once the troubleshooter does its job, you save the settings. Every session should now runs in earlier versions of windows. Vista and newer seems to be lacking vital ssh networking settings. 
    Saturday, January 25, 2014 8:54 PM