locked
CentOS 6.3 on Windows Server 2012 Hyper-V 3.0 Bug? (PANIC: Early Exception) RRS feed

  • Question

  • Hi everyone,

    I've been testing WS2012 for some time but recently I've been running some tests in the lab with Linux. I'm shocked no one else has reported this error but then I doubt that many people run large Linux VM's on Hyper-V.

    If I assign 4 GB memory to a VM it installs and runs CentOS perfectly with very impressive performance. 

    However, if I assign more than around 6 GB of Memory (8 GB completely breaks it) the CentOS installer does not even load and shows the following message:

    PANIC: Early exception 06 rip 10:ffffffff81c451bb error 0 cr2 0

    I would like to add that this also happens on a fully installed VM CentOS 6.3 with IC 3.4. Screenshot attached. Hopefully this can be resolved by an update... :-)

    Hyper-V 2012 CentOS Errror

    Tuesday, October 30, 2012 8:21 PM

Answers

  • Hi ,

    Does the issue occur on all hyper-v host? If you move the vm to another host, does the issue still occur? Currently I don't have a test vm at hand. I will test it if possible.

    Please reinstall the IC 3.4 when the vm's memory is 4G and then increase to 6G. See if it works.

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Edited by HuAaron Wednesday, October 31, 2012 3:23 PM
    • Marked as answer by Lawrence, Monday, November 19, 2012 2:33 AM
    Wednesday, October 31, 2012 3:22 PM
  • Hi , Please try to disable NUMA spanning in Hyper-v setting and see how it goes. Thanks.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Lawrence, Monday, November 19, 2012 2:33 AM
    Thursday, November 1, 2012 2:52 PM

All replies

  • Hi ,

    Does the issue occur on all hyper-v host? If you move the vm to another host, does the issue still occur? Currently I don't have a test vm at hand. I will test it if possible.

    Please reinstall the IC 3.4 when the vm's memory is 4G and then increase to 6G. See if it works.

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Edited by HuAaron Wednesday, October 31, 2012 3:23 PM
    • Marked as answer by Lawrence, Monday, November 19, 2012 2:33 AM
    Wednesday, October 31, 2012 3:22 PM
  • Yes it does appear to happen on all hosts I have here. It is only if a large amount of vRAM is assigned to the VM. The hosts I have here are Intel based servers, fairly recent 5500 series processors. 

    By the way, this happens when trying to install CentOS also so it does not indicate this issue is related with IC. I have a VM which was installed with 4 GB and has IC 3.4 installed too, soon as I raise the vRAM to something like 8 GB it comes up with the same error.  

    Wednesday, October 31, 2012 8:13 PM
  • Per the LIS 3.4 Readme, try adding numa=off  to the end of the kernel line in /boot/grub/grub.conf.  You should be able to then shutdown the VM and increase the RAM.

    Wednesday, October 31, 2012 8:32 PM
  • Hi , Please try to disable NUMA spanning in Hyper-v setting and see how it goes. Thanks.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Lawrence, Monday, November 19, 2012 2:33 AM
    Thursday, November 1, 2012 2:52 PM
  • Hi , Please try to disable NUMA spanning in Hyper-v setting and see how it goes. Thanks.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 1, 2012 2:52 PM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as 'Answered' as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!


    Lawrence

    TechNet Community Support

    Monday, November 19, 2012 2:33 AM
  • Hi,

    Thanks for the suggestion. Disabling NUMA spanning didn't appear to work for me unless I edit the grub configuration file. I'll do some more testing to see if I can get it working. 

    Thanks. 

    Monday, November 19, 2012 8:03 PM
  • I got this same result with CentOS 6.3 and Hyper-v 2012, only for our situation, it was allocated 8gb and when I move it above 12gb I get the panic.  

    This is now a production server which was running fine but the app devs wanted to give the VM more RAM to test for headroom.

    The key thing I would like to add is that our Host has 24gb total and NUMA spanning is on. If I set the VM to just under 12gb it runs fine - note, this is the available RAM per physical CPU on this hardware. This is a reproduceable result and it just happens that we can live with 12gb and did not disable NUMA spanning.

    I do not think the above suggested "Answers" are more than workarounds and I would like to know if this is a NUMA bug in Hyper-v, IC 3.4 or something in kernel 2.6.32?


    Jae

    Monday, December 3, 2012 5:14 AM
  • I can confirm this issue remains unresolved and is a Hyper-V bug.

    As instructed, I disabled NUMA in Hyper-V Settings and added "numa=off" in grub.conf - no dice.

    Is anyone at Microsoft working on a fix for this bug?  It's difficult to take Hyper-V 2012 seriously for production when we can't rely on it to run VM's properly with more than 4 GB of RAM.

    Thursday, December 6, 2012 2:56 PM
  • Okay.  Figured out a workaround that's allowing 8 GB RAM now.

    It took all of the following steps:

    1. Add "numa=off" in grub.conf in Linux

    2. Disable NUMA in "Hyper-V Settings", then restart the Hyper-V service

    3. In the VM Settings, "Memory" settings, check the "Enable Dynamic Memory" option (I just left the default values).

    I'm not sure how much RAM this will now allow, as my dev machine has limited RAM, but these changes seem to have alleviated the original panic upon boot problem for now.

    Rick

    www.softnas.com

    


    • Edited by rbraddy Thursday, December 6, 2012 3:18 PM
    • Proposed as answer by SDConnors Friday, January 18, 2013 5:59 AM
    Thursday, December 6, 2012 3:18 PM
  • Yes I also think this a little bug. 

    The dynamic memory would work because it only assigns the memory required to boot, and scale for the application. In theory it would work but I'd prefer to have a statically assigned amount of memory on a Linux VM.

    I think MS need to investigate this issue and provide an update to Hyper-V, since in every other respect Hyper-V 3.0 is fantastic. Unfortunately some workloads will require the odd Linux server for something or other. 

    Thursday, December 6, 2012 8:19 PM
  • "numa=off" at the bottom of "grub.conf" worked for me! ~ thanks all

       Was getting the Panic just trying to assign above 2Gb RAM in a Hyper-V Virtual machine running CentOS 6.3

       * 24Gb DDR3 1333Mhz plus 8 Intel Xeon x64 CPUs available to slice/dice on R710 Server running Windows Server 2012 Hyper-V Core  (foundation)

       Note that NUMA was already off in Hyper-V Manager settings.


    • Edited by SDConnors Friday, January 18, 2013 6:06 AM
    Friday, January 18, 2013 6:04 AM
  • Thanks for all the responses as they help solved the problem.  After some experimentation my colleague and I found that the only change needed was to add the "numa=off" flag\parameter to the grub.conf as suggested by Stick72.  In case anybody made the same mistake as us, this needs to be added to the end of kernel line after the other kernel flags\parameters (as Stick72 suggested!).  We also found that the  changes 2 and 3 suggested by rbraddy had no added benefit.  In fact turning off NUMA in Hyper-V settings had no effect except reducing the amount of RAM we could allocate to a VM.


    • Edited by julezman Friday, January 18, 2013 12:56 PM
    Friday, January 18, 2013 12:54 PM