SSTP Error 0x8007274D


  • I am tying to create a VPN connection in order to access my files at home. I am trying to use SSTP but unfortunately with no success. The error that I am getting is this;

    Error 0x8007274D: No connection could be made because the target machine actively refuse it.

    Can anyone tell me what can I do to avoid this error and connect successfully to my home network?

    Monday, April 30, 2012 8:39 PM


All replies

  • Hi Donellzz,

    Thanks for posting here.

    Could you first generally discuss how did we set SSTP up before and the network conditions like the topologic which include where is RRAS located (behind NAT or connect to internet directly ). If so have we configured the port mapping in order to forward the connection request to internal RRAS server on NAT? Have we also set RADIUS server ?

    We may first to troubleshoot with following the KB article below:

    How to troubleshoot Secure Socket Tunneling Protocol (SSTP)-based connection failures in Windows Server 2008

    Meanwhile, we may also check our current settings with following the introduction in the links below:

    SSTP Remote Access Step-by-Step Guide: Deployment

    Screencast: Deploying SSTP Remote Access

    “SSTP” in RRAS blog:

    Virtual Private Networks


    Tiger Li

    Tiger Li

    TechNet Community Support

    Tuesday, May 01, 2012 6:07 AM
  • Did you got it solved?

    I'm having the same problem...

    Monday, July 08, 2013 7:40 PM
  • same problem with the problem is not from server side or vpn server because i test it with different s SSTP vpn servers and got same error 0x8007274D!! 

    i created a new user account and test SSTP connection and got perfectly results! so all problem is on administrator account!!  now  you tel me how i can restore to default or fix my certificates problem in administrator account for this problem?

    • Edited by Hamilton2011 Thursday, September 26, 2013 4:04 PM
    Thursday, September 26, 2013 4:03 PM
  • Please help I'm having the exact error msg..I'm running windows Server Essential 2012..I followed the video from Techtubeonline (,(, to setup and configure Direct Access for win 7 clients..All green lights, but the SSTP doesn't work which is probaby why the connector is not installing on remote win7 clients..When i test the from a pc that is joined locally to the server the sstp fails to connect with error 0x8007274D..My remote web access works fine..The website cloud base part of it works good..Also I can't remote desktop to the server through the website, another error..I been working on this for 3 months trying to get  the direct access connector to download and install on 4 remote windows 7 machines..PLEASE HELP..
    Friday, December 20, 2013 6:15 PM