none
Can't install security update to XP

    Question

  • PC has been trying for several weeks to install: Security Update for Microsoft .NET Framework 1.1 SP1 on Windows XP, Windows Vista, and Windows Server 2008 x86 (KB2742597).  Keeps failing as can't install when I shutdown the pc.  Then each time I startup, I send the error report generated by the software.

    I ran the micosoft fixit.  It said it corrected the errors with updates with wrong addresses or words to that effect.

    The yellow shield keeps showing up on the task bar for updates to be installed and same deal if I manually do it.

    Can I find the file somewhere and delete it?

    Thanks.

    Sunday, January 27, 2013 1:43 AM

Answers

  • Hi, this tool and steps may help: http://blogs.msdn.com/b/astebner/archive/2008/03/07/8108332.aspx

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Marked as answer by Hereb Friday, February 01, 2013 2:01 AM
    Sunday, January 27, 2013 7:21 AM
  • Thanks Lawrence.  I checked my 2nd pc and it does not have net 1 on it and most, if not all, of the programs are the same on both so I deleted net frame 1 and thankfully the pc continues to work.  Plus the update symbol is gone and it has not tried to do that update through two reboots.  So, hopefully that is it.

    I appreciate your response to my problem.  Herb

    Friday, February 01, 2013 2:00 AM

All replies

  • Hi, this tool and steps may help: http://blogs.msdn.com/b/astebner/archive/2008/03/07/8108332.aspx

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Marked as answer by Hereb Friday, February 01, 2013 2:01 AM
    Sunday, January 27, 2013 7:21 AM
  • PC has been trying for several weeks to install: Security Update for Microsoft .NET Framework 1.1 SP1 on Windows XP, Windows Vista, and Windows Server 2008 x86 (KB2742597). 

    Aside from the ideas that Don offered, I'd ask these questions:

    • Do the machines actually have the Microsoft .NET Framework v1.1 installed?
    • If so, are there any applications on the machines that actually NEED the Microsoft .NET Framework v1.1?
    • If not, then I'd say the better solution is to UNINSTALL the Microsoft .NET Framework v1.1 rather than fighting with trying to keep up with patches for it.

    The Microsoft .NET Framework v1.1 was wholly replaced by the much better Microsoft .NET Framework v2 in 2003, and anything written in the past two years ought to be fully functional under .NET2 if it's a .NET application.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Thursday, January 31, 2013 2:30 PM
    Moderator
  • Don, thank you for your quick reply.  I am not a knowing computer user so I wasn't sure with the information.  However, I really do appreciate your rapid answer.  I deleted net frame 1 from my computer and it is working fine and the update is gone per Lawrence's reply.

    Again, thanks.  Herb

    Friday, February 01, 2013 1:56 AM
  • Thanks Lawrence.  I checked my 2nd pc and it does not have net 1 on it and most, if not all, of the programs are the same on both so I deleted net frame 1 and thankfully the pc continues to work.  Plus the update symbol is gone and it has not tried to do that update through two reboots.  So, hopefully that is it.

    I appreciate your response to my problem.  Herb

    Friday, February 01, 2013 2:00 AM