WSUS 2012 Tools Directory Missing RRS feed

  • Question

  • I am struggling to get WSUS 2012 working again on my new server.  The system was working until I installed McAfee ePO, which resulted in a port conflict.  I reinstalled ePO to use different ports, but WSUS never accepted client connections after that.  I have uninstalled and reinstalled WSUS about six times with no luck.  The last three times I've reinstalled WSUS, the Tools directory is missing so I am unable to perform the post installation tasks.  Can anyone tell me what would be causing this?  I've performed the install both through Server Manager and PowerShell with no change.  I really need some help on this one.


    Wednesday, November 20, 2013 1:48 PM

All replies

  • Dear,

    Please check this link to restore the Tools directory on your server:


    Hope it helps you,


    Housam Smadi

    Wednesday, November 20, 2013 1:58 PM
  • Housam,

    Thanks for the quick reply.  That does help to a point.  I was able to find the wsusutil.exe file and moved it into the Tools directory.  However, when I run the command:

    .\wsusutil.exe postinstall CONTENT_DIR=D:\WSUS

    I get the error:

    Fatal Error: Database creation failed.

    I am trying to use the internal database.  Is there something I'm missing in the postinstall command for this?


    Wednesday, November 20, 2013 2:43 PM
  • Dear Joe,

    You post installation command is correct.

    Please check event viewer for any related issues to WSUS installation.

    Also make sure that NT AUTHORITY\Network Service account have FULL CONTROL permissions on these two folders:

    • %windir%\Temp
    • %windir%\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files


    Housam Smadi

    Wednesday, November 20, 2013 3:18 PM
  • Housam,

    To summarize my current situation:

    1) A reinstall of WSUS failed to create the Tools directory, causing the postinstall steps to fail.
    2) I found a copy of wsusutil.exe on the server, created a Tools directory, and copied the file.
    3) wsusutil.exe postinstall CONTENT_DIR=D:\WSUS failed with a database error.  Found an error in the logs stating that the database files already existed.  I deleted the susdb.mdf and susdb_log.ldf files and was then able to complete the postinstall commands.
    4) WSUS service is now running, and logs state that no clients have ever checked in to the server.

    However, I now find that the AdministrationSnapin directory was also missing following the reinstall.  As a result I could not launch the WSUS console.  I created the AdministrationSnapin directory and placed a copy of wsus.msc there but the console crashes with the error "could not load file or assembly."  Obviously there are other files missing from the AdministrationSnapin directory.

    I'm very concerned that other files/directories are missing as well.  Is there a solution for this?  Can I get a list of expected files/directories so maybe I can put together the missing files?


    Thursday, November 21, 2013 1:11 PM
  • Hi ,

    By default, in Windows Server 2012, WSUS 4.0 uses port 8530. Please check if this port is being used. To check if the system files are missing, run the following command to perform a check:

    DISM.exe /Online /Cleanup-image /Scanhealth
    DISM.exe /Online /Cleanup-image /Restorehealth

    System Update Readiness Tool


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, November 22, 2013 10:58 AM
  • OK, I ran the commands above.  The results are as follows:

    DISM.exe /Online /Cleanup-image /Scanhealth
    No component store corruption detected.
    The operation completed successfully.

    DISM.exe /Online /Cleanup-image /Restorehealth
    The restore operation completed successfully.  The component store corruption was repaired.
    The operation completed successfully.

    However, nothing seems to have changed. The AdministrationSnap directory only contains the wsus.msc file that I placed there, and the console will not load.  Also, the System Update Readiness Tool does not apply to Windows 2012.

    The frustration level is getting quite high here.  Any other suggestions?


    Friday, November 22, 2013 2:41 PM
  • OK, a little progress has been made.  On Friday I ran a System File Scan (fsc /scannow) and to my surprise DID replace the missing files and directories for WSUS.  This allowed me to access the console, complete the configuration steps, and initiate an initial sync. 

    I'm still not seeing any PC's check in to the server, so that is what I'll be working on today.


    Monday, November 25, 2013 1:32 PM
  • I now find that trying to open the link from a client PC


    fails with a "cannot display the webpage" error.  However, if I open the same link on the wsus server it works.  So I obviously have an ISS or networking issue.  I have confirmed that the addressing is correct and can be reached/pinged from client PC's.  The Windows firewall is off on the server.  I'm not sure where else to look on this issue.  Does anyone have any suggestions?


    Tuesday, November 26, 2013 1:23 PM
  • More details on this mystery.  I ran Network Monitor on the WSUS server, and filtered on the IP addresses of my workstation and the WSUS server.  I confirmed that my attempts to reach


    were actually reaching the server.  And there appears to be a response back from the server.  Now I'm not sure what to do next.  Can anyone look at the following trace information and provide any insight?



      Frame: Number = 1800, Captured Frame Length = 66, MediaType = ETHERNET
    - Ethernet: Etype = Internet IP (IPv4),DestinationAddress:[00-15-5D-10-29-01],SourceAddress:[D4-BE-D9-CC-2C-C4]
      - DestinationAddress: Microsoft Corporation 102901 [00-15-5D-10-29-01]
         Rsv: (000000..)
         UL:  (......0.) Universally Administered Address
         IG:  (.......0) Individual address (unicast)
      - SourceAddress: D4BED9 CC2CC4 [D4-BE-D9-CC-2C-C4]
         Rsv: (110101..)
         UL:  (......0.) Universally Administered Address
         IG:  (.......0) Individual address (unicast)
        EthernetType: Internet IP (IPv4), 2048(0x800)
    - Ipv4: Src =, Dest =, Next Protocol = TCP, Packet ID = 27775, Total IP Length = 52
      + Versions: IPv4, Internet Protocol; Header Length = 20
      + DifferentiatedServicesField: DSCP: 0, ECN: 0
        TotalLength: 52 (0x34)
        Identification: 27775 (0x6C7F)
      + FragmentFlags: 16384 (0x4000)
        TimeToLive: 128 (0x80)
        NextProtocol: TCP, 6(0x6)
        Checksum: 5598 (0x15DE)
    - Tcp: Flags=......S., SrcPort=54150, DstPort=8530, PayloadLen=0, Seq=3290609950, Ack=0, Win=8192 ( Negotiating scale factor 0x2 ) = 8192
        SrcPort: 54150
        DstPort: 8530
        SequenceNumber: 3290609950 (0xC422B91E)
        AcknowledgementNumber: 0 (0x0)
      + DataOffset: 128 (0x80)
      - Flags: ......S.
         CWR:    (0.......) CWR not significant
         ECE:    (.0......) ECN-Echo not significant
         Urgent: (..0.....) Not Urgent Data
         Ack:    (...0....) Acknowledgement field not significant
         Push:   (....0...) No Push Function
         Reset:  (.....0..) No Reset
         Syn:    (......1.) Synchronize sequence numbers
         Fin:    (.......0) Not End of data
        Window: 8192 ( Negotiating scale factor 0x2 ) = 8192
        Checksum: 0x6495, Good
        UrgentPointer: 0 (0x0)
      - TCPOptions:
       + MaxSegmentSize: 1
       + NoOption:
       + WindowsScaleFactor: ShiftCount: 2
       + NoOption:
       + NoOption:
       + SACKPermitted:

    Wednesday, November 27, 2013 1:45 PM
  • Thank you so much. You saved my life
    Saturday, August 5, 2017 4:05 PM