none
UDP traffic dropped. Hyper-V server 2008 R2. RRS feed

  • Question

  • Hello!
    I'm trying to make my VMs services receive UDP packets from Internet.

    I have following configuration:

    Internet --> asus router (192.168.1.1) with portforward --> physical Hyper-V Server 2008 R2 (192.168.1.10) --> virtual WS2008 R2 (192.168.1.2)

    TCP works fine. I'm able to connect RDP and IIS.
    But UDP packets are never received on VM (Installed wireshark on VM). Can't test if they received on HyperV, because WinPCAP refuse installing.
    I disabled any "Offload" rated settings (using regedit in Hyper-V Server, since there is no GUI) on every adapter (HyperV Physical NIC, HyperV Virtual switch and VM virtual NIC).

    I had previous setup that worked fine with UDP
    Internet --> asus router --> WS2003
    So its not router, its somewhere in Hyper-V Server 2008 R2 or VM (Windows Server 2008 R2).

    Any ideas?
    Wednesday, November 18, 2009 1:13 PM

All replies

  • Check the firewall settings on the NICs typically UDP is always blocked from the internet.  Are you trying to port forward to the host and then relay that to the guest?  If so that will not work as the VM to the network is an actual server. 
    If you need to get to the VM change your port forward to be directly to the .2 IP.
    Joe


    Joseph Noga MCITP, MCSE, MCSA, MCTS CCNA,CCDA,CCVP Managing Consultant Artemis Technology LLC
    Wednesday, November 18, 2009 3:01 PM
  • Router 192.168.1.1
    Guest 192.168.1.2
    Host 192.168.1.10

    Windows Firewall on Host and Guest is off for all 3 profiles (also tested with enabled + added allow incoming UDP rules to both Host and Guest. no luck)

    I'm forwarding ports from Router right to Guest. Guest now have same IP address as my previous real hardware Windows 2003 server.

    I also tried to replace "Network Adapter" with "Legacy Network Adapter", no luck.
    Checking "Spoofing of MAC addresses" didn't help too.
    Setting Guest same MAC address as Host didn't work too (Guset just lost connection to network)
    Wednesday, November 18, 2009 7:04 PM
  • Can the server receive UDP from the local subnet?  

    Another thing to try is disabling IPv6 that might help as well.

    http://support.microsoft.com/kb/929852

     


    Joseph Noga MCITP, MCSE, MCSA, MCTS CCNA,CCDA,CCVP Managing Consultant Artemis Technology LLC
    Thursday, November 19, 2009 3:58 PM
  • I can receive UDP from local subnet. (Guest to Host and back)

    Yesterday I tried some things.

    In Host:
    Stopped windows firewall service. As a result - lost connection to all network services, running on Host :-D

    In Guest:
    Added IPSec rule to allow all UDP Traffic, no effect.
    In windows firewall - unchecked all connections in "What connections to protect", no effect
    Unchecked everything but ipv4 in connection settings, no effect.
    In properties of connection, set both gateway and interface metrics to 1 and it worked. My services on Guest now getting UDP traffic from outside.

    After that my Host-Guest communication became unstable (ping jumps like 1-50-1-50-1-50, slow file transfer and laggy RDP) and I checked back everything in connection settings.
    Still can receive UDP, and Host-Guest communication back to normal.

    true weirdness.
    Can you explain what happening?
    Friday, November 20, 2009 6:25 AM
  • Hello,

    i think i have the same problem as Savvkin.

    TCP works fine. I'm able to connect RDP and IIS but with UDP i have massive problems.
    Dns is working fine but then i want to use SIP in Guest i cant receive UDP packets. Seems like they are dropped.

    i tried the metric changes to 1 in the guest for gateway and interface but it didnt work for me.

    in my case it works fine with legacy Network Adapter but not with the normal network adapter which i want to use :-(

     Network Card on the Host is a Broadcom BCM5716C NetXtreme II GigE (NDIS VBD Client)
    Checksum and Large Send features are disabled on all network cards. (Guest and Host)

     

    some one knows what to do?

    Thanks!

     

     

    • Edited by Martin Be Wednesday, August 11, 2010 7:19 AM
    Wednesday, August 11, 2010 7:00 AM
  • In my guest machine:

    Currently everything but QoS is enabled in my LAN connection.

    In IPv4 metric of Interface and Gateway set to 5.

    In Network Adapter all Checksum Offloads are Disabled, Jumbo Packet is Disabled.

    Firewall for Domain, Private and Public Profiles is set to Off.

     

    Hope it helps.

    Wednesday, August 11, 2010 7:17 AM
  • Thanks for your reply!

     

    i have the same settings like you now, but it doenst work for me :-(

    • Proposed as answer by Chris Tandy Sunday, December 12, 2010 5:23 PM
    Wednesday, August 11, 2010 7:34 AM
  • Hi

    I have just fixed this for my installation

    If you forward port 10000 in your asus router, it appears in the virtual machine on port 10001, therefore, decrement the port number in the asus router to 9999 and it will appear in the virtual machine on port 10000 (i.e. the one you want)

    I have no idea if this is a problem with the router or the virtual switch but my setup now works.

    Chris

     

    • Proposed as answer by Chris Tandy Sunday, December 12, 2010 5:27 PM
    Sunday, December 12, 2010 5:27 PM