none
Disable or extend Windows Server 2008 desktop inactivity lock timeout

    Question

  • Hi,

    I have just installed Windows Server 2008 and notice that after a period of inactivity the screen lock activates and I have to hit Ctrl-Alt-Del and enter the password to unlock it.  Is there any way to either extend the timeout or disable the timeout all together?

    Any help would be greatly appreciated.

    Thanks

    N.

    Monday, January 5, 2009 9:11 PM

Answers

  • Hi,

     

    Please perform the following suggestions:

     

    Suggestion 1:

     

    1, Right click on desktop, select Personalization

    2, Select Screen Saver,

    3, Clear the check box "On resume, display logon screen".

     

    Suggestion 2:

     

    1, Open registry in run.

    2, Navigate to HKCU\ControlPanel\Desktop\ScreenSaveActive, set the value to 0.

     

    Note: Please backup the registry before modify the registry.

     

    Suggestion 3:

    1, Type gpedit.msc in run

    2, Navigate to User Configuration > Administrative Templates > Control Panel > Display > Password protect the screen saver

    3, Double click on “Password protect the screen saver”

    4, Select Disable

     

     

    Best regards,

    Vincent Hu

    • Marked as answer by parkcrest Tuesday, January 6, 2009 3:59 PM
    Tuesday, January 6, 2009 10:15 AM
    Moderator

All replies

  • Hi,

     

    Please perform the following suggestions:

     

    Suggestion 1:

     

    1, Right click on desktop, select Personalization

    2, Select Screen Saver,

    3, Clear the check box "On resume, display logon screen".

     

    Suggestion 2:

     

    1, Open registry in run.

    2, Navigate to HKCU\ControlPanel\Desktop\ScreenSaveActive, set the value to 0.

     

    Note: Please backup the registry before modify the registry.

     

    Suggestion 3:

    1, Type gpedit.msc in run

    2, Navigate to User Configuration > Administrative Templates > Control Panel > Display > Password protect the screen saver

    3, Double click on “Password protect the screen saver”

    4, Select Disable

     

     

    Best regards,

    Vincent Hu

    • Marked as answer by parkcrest Tuesday, January 6, 2009 3:59 PM
    Tuesday, January 6, 2009 10:15 AM
    Moderator
  • Strange, I've never had this problem before but recently even after my settings were as per your suggestion my screen is going to the lock screen. I double checked the registry settings and everything seems fine.

    I'm guessing a recent patch must have changed this behavior since I can think of nothing else, nor a way to have it stop doing that.

    Any other things going on that would cause the lock screen to activate?

    I use windows 2008 enterprise build 6002 with sp2 as a workstation.

    Monday, July 5, 2010 5:04 PM
  • Same here - screensaver and prompt for password are disabled, but after about 10 minutes, the screen locks. Extremely annoying when you're watching video, etc.
    Saturday, January 15, 2011 7:35 PM
  • Muchas gracias a todos, al final se solucionó desmarcando la opcion del protector de pantalla. Me estaba volviendo loco con el tema de directivas y al final era eso tan "simple", gracias de nuevo.

    Friday, May 20, 2011 3:54 PM
  • Server 2008 R2 used as a domin controller. I did not have a personalization button on the desktop. I did have the Regedit second suggestion. Worked great. Thanks.
    Friday, September 16, 2011 3:41 PM
  • Had the same problem....it is a really inconvenient issue when you are hosting a web server.  There is a setting under 'Administrative Tools > Remote Desktop Services > Remote Desktop Session Host Configuration' that needs to be updated:

    http://www.ryanbelanger.com/remote-desktop-session-automatic-logoff-on-windows-2008-r2/

    Thursday, July 18, 2013 3:15 PM