locked
Exchange 2013.... ECP error Line 43 RRS feed

  • Question

  • I'm not getting a 404 error i am getting a configuration error i tried the config.old and still nothing here is all the information it gives me.

    Server Error in '/ecp' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Microsoft.Exchange.Clients.Strings, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Source Error:
    Line 41:                 the compiler.  All assemblies in the GAC and owa\bin are referenced automatically.
    Line 42:                 -->
    Line 43:                 <add assembly="Microsoft.Exchange.Clients.Strings, Version=15.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" />
    Line 44:                 <add assembly="Microsoft.Exchange.Data.Directory, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    Line 45:                 <add assembly="Microsoft.Exchange.Clients.Common, Version=15.0.0.0,Culture=neutral, publicKeyToken=31bf3856ad364e35" />

    Source File: C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\ecp\web.config    Line: 43

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.Exchange.Clients.Strings, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34212             

    Thursday, November 20, 2014 3:31 PM

Answers

  • Hi,

    This issue may be caused by BinSearchFolders path setting incorrectly. Please take the following steps to solve this issue.

    1. Open IIS >> Exchange BackEnd website >> ECP virtual directory >> In the Middle Pane >> Application Settings >> BinSearchFolders
    2. Change the path with C:\Program Files\Microsoft\Exchange Server\V15\bin;C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin
    3. Then reset IIS to check this issue.

    Best Regards.

    Friday, November 21, 2014 1:56 AM

All replies

  • Hi,

    This issue may be caused by BinSearchFolders path setting incorrectly. Please take the following steps to solve this issue.

    1. Open IIS >> Exchange BackEnd website >> ECP virtual directory >> In the Middle Pane >> Application Settings >> BinSearchFolders
    2. Change the path with C:\Program Files\Microsoft\Exchange Server\V15\bin;C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin
    3. Then reset IIS to check this issue.

    Best Regards.

    Friday, November 21, 2014 1:56 AM
  • You are exactly right. Thank you for the help. My 2013 Exchange server had this issue after the latest cu8 security update.
    THANK YOU!
    Monday, June 15, 2015 2:21 AM
  • Hi,

    This issue may be caused by BinSearchFolders path setting incorrectly. Please take the following steps to solve this issue.

    1. Open IIS >> Exchange BackEnd website >> ECP virtual directory >> In the Middle Pane >> Application Settings >> BinSearchFolders
    2. Change the path with C:\Program Files\Microsoft\Exchange Server\V15\bin;C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin
    3. Then reset IIS to check this issue.

    Best Regards.

    Помогите, что значит измените путь! на какой?
    Friday, June 19, 2015 9:57 AM
  • Brilliant exactly it!

    Friday, March 11, 2016 2:05 PM
  • I want to share that I received this same error as a result of trying to upgrade to CU12.  I read that others have had this same issue when upgrading to CU8.  The upgrade failed on the Mailbox Role.  If your Exchange Server installation directory is on a separate volume, then don't change it to C:\.  Only do this if your installation directory resides on C:\.

    The error is caused  because the CAS and Mailbox Role Services were not completely "upgraded" in the CU installation.  The fix for me was to do the following 3 steps:

    1) Go to the Registry Key "MailboxRole" and delete the Watermark. (Watermark is created by the CU upgrade when it fails.  It indicates at which point the upgrade failed - it is ok to delete it.)  Make a backup of the Registry Key MailboxRole before deleting it, just in case.

    2) My DiscoverySearchMailbox didn't have the 'homemdb' attribute.  So I recreated the DiscoverySearchMailbox, populated the Attribute 'homemdb' with the same path as one of the existing Arbitration Mailboxes.

    3) Then I was able to successfully reinstall the upgrade using an elevated command prompt with the following command: Setup.exe /M:Upgrade /Iacceptexchangeserverlicenseterms

    Post install, I rebooted and was able to successfully launch the ECP.

    -Steven


    • Edited by SL_EX Sunday, April 24, 2016 11:05 PM
    Sunday, April 24, 2016 11:03 PM