none
Prevent second NIC from registering in DNS RRS feed

  • Question

  • Hi 

    We have a problem with some of our servers that have two network cards,

    For example, SQL server has 2 NICs and from time to time, the DNS adds the second one (it should not) and as a result of that addition, some of the services are not available anymore – they connect to a management NIC that is not configured as PIPE for the SQL services.

    I unchecked the box " Register this connection's addresses in DNS" and deleted registrations from DNS.

    Windows Server 2012 

    thanks in advance

    Monday, July 15, 2019 7:17 PM

Answers

All replies

  • Hello,

    Thank you for posting in this forum.

    " I unchecked the box " Register this connection's addresses in DNS" and deleted registrations from DNS. "

    So after you do this, the second NIC still registers its record in the DNS, right?

    How do these two NICs get the IP address?

    If they are assigned by DHCP, have you set up DHCP to automatically update DNS records for clients?

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 16, 2019 1:54 AM
  • Hi 

    yes, DNS registration is repeated.

    IPs configured static and no DHCP.


    Tuesday, July 16, 2019 9:12 AM
  • Hello,

    I did the same experiment in my environment, and the second NIC will not be registered in the DNS.

    Please double check that you have successfully unchecked " Register this connection's addresses in DNS ". Uncheck Register this connection's addresses in DNS->Click OK->Click OK.

    If the second NIC still registers its record in DNS, then check the timestamp to see when this record was created.

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 16, 2019 9:53 AM
  • thanks.

    Did you restart the server after the change?

    Tuesday, July 16, 2019 10:04 AM
  • Hello,

    After unchecking that option, I tried "ipconfig /registerdns" and restarted the client and server.

    However, the second network card is still not registered in the DNS.

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 17, 2019 1:30 AM
  • I resolved that by disabling dynamic dns  in registry for this NIC
    • Marked as answer by RASH MAAR Thursday, July 18, 2019 7:52 AM
    Thursday, July 18, 2019 7:52 AM
  • Hello,

    Thank you for your update.

    Good to hear that you have solved this issue by yourself. In addition, thanks for sharing your solution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 18, 2019 8:02 AM