locked
External WD Hard Drive Not Showing In File Explorer RRS feed

  • Question

  • My External WD ( 500GB My Passport) Hard drive Is Not showing In File Explorer...I Have Tried Re-installing It But Nothing Worked....Any Idea About Solving This Problem Without Losing Any Data ?

    • Edited by ISL270 Saturday, July 19, 2014 12:44 PM
    Saturday, July 19, 2014 12:39 PM

Answers

All replies

  • Are drivers installed ? Do you see it in Device manager?

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by ISL270 Saturday, July 19, 2014 2:04 PM
    • Unmarked as answer by ISL270 Saturday, July 19, 2014 2:04 PM
    Saturday, July 19, 2014 12:45 PM
  • Yes I Can See It In Device Manager And Disk Managment But I Can't See/Open It In File Explorer

    Saturday, July 19, 2014 2:04 PM
  • Then try assigning drive letter to it. Have a look at the following link:

    http://windows.microsoft.com/en-us/windows/change-add-remove-drive-letter#1TC=windows-7


    Balaji Kundalam

    Monday, July 21, 2014 6:46 AM
  • But I Can't Click On Change Letter Because It Is Not In Bold It's In Gray I Can't Click On It
    Tuesday, July 22, 2014 3:33 AM
  • Can you post a screenshot of the Disk Management with the drive connected?

    Balaji Kundalam

    Tuesday, July 22, 2014 3:46 PM
  • I Can't Post Any ScreenShot Because Is Says "Body Text Can't Post Any Image Or Link Until We Able To Verify Your Account"
    Tuesday, July 22, 2014 11:19 PM
  • Hi,

    Please verify your account.

    http://windows.microsoft.com/is-IS/windows-live/account-verify-ID-email-address

    Or you could upload to OneDrive and then post the shared link (change the link as text) here.


    Karen Hu
    TechNet Community Support

    • Marked as answer by ISL270 Wednesday, July 23, 2014 6:03 AM
    Wednesday, July 23, 2014 1:19 AM
  • Thanks Karen Hu But It Is Still The Same Problem
    • Edited by ISL270 Wednesday, July 23, 2014 6:40 AM
    Wednesday, July 23, 2014 6:04 AM
  • Please Can Any One Help Me With My Hard Drive Problem
    Thursday, July 24, 2014 12:52 AM
  • Did you check with some other computers?

    Also, I suggest you to run Seagate SeaTools from the following link, to scan the hard drive for errors (works with non-Seagate hard drives as well):

    http://www.seagate.com/in/en/support/downloads/item/seatools-win-master/


    Balaji Kundalam

    Thursday, July 24, 2014 4:55 AM
  • Okay , I Have Downloaded It But How Could I Use It To Fix My Problem....I Have Made A Short Drive Test Drive Only
    Thursday, July 24, 2014 7:58 PM
  • ISL270

    1. When you open Disk Management do you get a box asking you to Initialize Disk?  Or did you when you first setup the disk?

    Is the disk volume showing in the top half of the Disk Management console?

    2. When looking in Disk Management, does the DiskX (where X is the disk number for your external drive) show as unknown and/or Not Initialized?

    If it is showing as Not Initialized:

    • Right Click the disk and click Initialize Disk
    • Select either MBR or GPT (Your preference)

    3. Does the Disk show as Offline?

    If it is showing as Offline

    • Right Click the disk and click Online

    4. Is the disk showing as Unallocated?

    If it is showing as Unallocated

    •  Right Click the disk space and click New Simple volume and follow the wizard.

    Lets us know.

    Thanks
    Sean


    MCTS: Windows 7

    MCITP: Windows 7 Enterprise Administration

    MCSA: Windows 7

    Friday, July 25, 2014 12:04 AM
  • My External WD ( 500GB My Passport) Hard drive Is Not showing In File Explorer...I Have Tried Re-installing It But Nothing Worked....Any Idea About Solving This Problem Without Losing Any Data ?

    a lot of these USB disks are garbage. Remove the hard disk from the case and connect it to an available desktop which will be able to read the disk.

    the cheap usb controllers are often the cause of the problem


    Corsair Carbide 300R with window
    Corsair TX850V2 70A@12V
    Asus M5A99FX PRO R2.0 CFX/SLI
    AMD Phenom II 965 C3 Black Edition @ 4.0 GHz
    G.SKILL RipjawsX DDR3-2133 8 GB
    EVGA GTX 6600 Ti FTW Signature 2(Gk104 Kepler)
    Asus PA238QR IPS LED HDMI DP 1080p
    ST2000DM001 & Windows 8.1 Enterprise x64
    Microsoft Wireless Desktop 2000
    Wacom Bamboo CHT470M
    Place your rig specifics into your signature like I have, makes it 100x easier to understand!

    Hardcore Games Legendary is the Only Way to Play!

    Friday, July 25, 2014 12:21 AM
  • Thank You Sean Mallonee , The Only Problem I Have From All The Problems You Have Said Is That My Disk Is Not Showing In The Upper Part Of The Disk Management 
    Friday, July 25, 2014 2:16 AM
  • Sorry Vegan Fanatic But I Couldn't Understand You
    • Edited by ISL270 Friday, July 25, 2014 2:18 AM
    Friday, July 25, 2014 2:18 AM
  • ISL270,

    In the bottom box next to the Disk number that represents your disk drive is the box have a black or Blue stripe along the top of it?

    Thanks
    Sean


    MCTS: Windows 7

    MCITP: Windows 7 Enterprise Administration

    MCSA: Windows 7

    Friday, July 25, 2014 5:00 AM
  • Yes It Has A Blue Stripe A Long The Top Of It
    Friday, July 25, 2014 9:12 AM
  • Sorry Vegan Fanatic But I Couldn't Understand You
    http://www.youtube.com/watch?v=Zbg8EEMwEsM

    Corsair Carbide 300R with window
    Corsair TX850V2 70A@12V
    Asus M5A99FX PRO R2.0 CFX/SLI
    AMD Phenom II 965 C3 Black Edition @ 4.0 GHz
    G.SKILL RipjawsX DDR3-2133 8 GB
    EVGA GTX 6600 Ti FTW Signature 2(Gk104 Kepler)
    Asus PA238QR IPS LED HDMI DP 1080p
    ST2000DM001 & Windows 8.1 Enterprise x64
    Microsoft Wireless Desktop 2000
    Wacom Bamboo CHT470M
    Place your rig specifics into your signature like I have, makes it 100x easier to understand!

    Hardcore Games Legendary is the Only Way to Play!

    Friday, July 25, 2014 12:21 PM
  • Sorry I Didn't Understand "Place your rig specifics into your signature like I have, makes it 100x easier to understand"
    Friday, July 25, 2014 9:35 PM
  • Any Help Please

    Tuesday, July 29, 2014 9:52 AM
  • If the suggestions failed to resolve the issue, it means it's more of hardware issue. Hence you can take it to the nearest WD service center to have it replaced.

    Balaji Kundalam

    Tuesday, July 29, 2014 4:53 PM
  • ISL270,

    If you right click on the box with the blue bar and select Change Drive Letter and Paths for: does the drive come up with a letter attached?

    Thanks
    Sean


    MCTS: Windows 7

    MCITP: Windows 7 Enterprise Administration

    MCSA: Windows 7

    Wednesday, July 30, 2014 5:15 PM
  • I Have Made This Video So You Could Understand My Problem Better :- https://www.youtube.com/watch?v=OIzmt0Gpgc0

    (((See It In HD)))

    • Edited by ISL270 Friday, August 1, 2014 11:12 PM
    Friday, August 1, 2014 11:10 PM
  • From your video I am seeing that the volume does not have a drive letter assigned. Right click the volume and assign a drive letter. Thanks Sean

    MCTS: Windows 7

    MCITP: Windows 7 Enterprise Administration

    MCSA: Windows 7

    Saturday, August 2, 2014 2:19 AM
  • But I Can't Click "Change Drive Letter And Paths" So I Can Add A Letter To It

    Saturday, August 2, 2014 1:27 PM
  • Help

    Tuesday, August 5, 2014 4:05 PM
  • Hi ISL,

    is this brand new disk?Doesnt seem like it.from your vid i can see that disk ahve 2 partitions.Can you right click on the partition on the right side (tha have 1.72gb space) and choose assign drive letter instead?

    If you dont have anything important on that disk,please choose delete partition on both right and left partition on that disk.Then restart diskmanagement and see if it ask to initialize the disk.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, August 5, 2014 4:20 PM
  • You can try this:

    Go to Start ->type cmd -> right click on it -> click on Run as administrator. Type diskpart and press Enter. Type automount enable and then press Enter. Now, connect the hard drive. If already connected, disconnect and reconnect the hard drive and then check.


    Balaji Kundalam

    Wednesday, August 6, 2014 7:48 AM
  • But I Have very Important Files On It ...... By The way I Don't Know How To Mark As Helpful
    Wednesday, August 6, 2014 9:50 AM
  • You can try this:

    Go to Start ->type cmd -> right click on it -> click on Run as administrator. Type diskpart and press Enter. Type automount enable and then press Enter. Now, connect the hard drive. If already connected, disconnect and reconnect the hard drive and then check.


    Balaji Kundalam

    http://prntscr.com/4a2iok     This Link Is For A Pic For What Happened (No Thing)
    • Edited by ISL270 Wednesday, August 6, 2014 9:59 AM
    Wednesday, August 6, 2014 9:59 AM
  • Did you try assigning drive letter then?

    Balaji Kundalam

    Wednesday, August 6, 2014 2:50 PM
  • Yesss
    Wednesday, August 6, 2014 10:29 PM
  • Sorry for the delay.

    Does it work with other computers? What happens when you connect the hard drive to other computers (inlcudes other operating systems like Linux)?

    Also, you can try running SFC scan and then try asigning drive letters. Refer the link for more information:

    http://support.microsoft.com/kb/929833/en-us

    Also, try running Microsoft Fixit from the following locations:

    http://support.microsoft.com/mats/windows_file_and_folder_diag/

    http://support.microsoft.com/mats/hardware_device_problems/

    http://support.microsoft.com/mats/Windows_USB_diagnostics


    Balaji Kundalam

    Tuesday, August 12, 2014 7:56 AM
  • Do you use this on other computers or is the computer you can't see it on the one use the drive on?

    Try assigning a letter thru disk part and see what it says.

    http://technet.microsoft.com/en-us/library/cc757491(v=ws.10).aspx

    Tuesday, August 12, 2014 1:37 PM
  • I Have Tried It On Another Two Laptops With Windows 8 (It Didn't Work On Them Also)

    Really Thanks For Your Effort And Answers But Also Nothing Worked

    • Edited by ISL270 Thursday, August 14, 2014 7:42 PM
    Thursday, August 14, 2014 7:38 PM
  • Yes, I Have Tried It On Another Computers And Didn't Work

    The Hard Drive Is Showing Disk Management And device Manager But Not Showing In cmd

    Thursday, August 14, 2014 7:47 PM
  • Seems there is an issue with the hard drive. Did you perform Short Generic/Long Generic test using Seagate SeaTools? And what's the result of Short Drive Test?

    Balaji Kundalam

    Friday, August 15, 2014 12:09 PM
  • It Says "Short Generic - Fail"
    Friday, August 15, 2014 11:49 PM
  • It Says "Short Generic - Fail"
    send it to RMA if available or trash if the warranty is done

    Corsair Carbide 300R with TX850V2
    Asus M5A99FX PRO R2.0 CFX/SLI
    AMD Phenom II 965 C3 Black Edition @ 4.0 GHz
    G.SKILL RipjawsX DDR3-2133 8 GB
    EVGA GTX 660 Ti FTW Signature 2 (GK104 Kepler)
    Asus PA238QR IPS LED HDMI DP 1080p
    ST2000DM001 & Windows 8.1 Professional x64
    Microsoft Wireless Desktop 2000 & Wacom Bamboo CHT470M

    Place your rig specifics into your signature like I have, makes it 100x easier to understand!

    Hardcore Games Legendary is the Only Way to Play!

    Friday, August 15, 2014 11:57 PM
  • I agree with Vegan Fanatic. The drive needs to be replaced, usually replaced for free if under warranty.

    If the data needs to be recovered, you can contact any local data recovery company to have it recovered.


    Balaji Kundalam

    Saturday, August 16, 2014 5:09 AM
  • Okay , Thanks For All Your Support And Replays :D


    • Edited by ISL270 Saturday, August 16, 2014 8:35 PM
    Saturday, August 16, 2014 8:33 PM
  • Turn on Enable insecure guest logons using Local Group Policy Editor

    Computer Configuration > Administrative Templates > Network > Lanman Workstation. Change the setting of Enable insecure guest logons to Enabled

    Wednesday, January 22, 2020 8:25 PM