Printer spooler 'access denied' on local printers


  • I set up a few HP LaserJet printers by IP address, using the Microsoft drivers.  The installation was smooth and trouble-free.

    However, Windows cannot print. It seems that some of the default permissions are not working. 

    I eventually found an error in the PrintService event log:

    "The document Print Document, owned by Administrator, failed to print on printer HP 4250. Try to print the document again, or restart the print spooler.
    Data type: RAW. Size of the spool file in bytes: 193874. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\SERVER. Win32 error code returned by the print processor: 5. Access is denied."

    This is a fresh standalone out-of-the-box installation without a single piece of non-MS software installed, and only one admin and one user account. 
    I removed and re-installed one of the printers and rebooted, without any success.

    I'm not enjoying my Server 2012 experience very much yet...

    Saturday, October 27, 2012 1:45 AM

All replies

  • You are printing directly from the essentials server, or via a client pc?

    Robert Pearman SBS MVP | |

    Saturday, October 27, 2012 6:52 AM
  • I am printing directly from the essentials server.
    Monday, October 29, 2012 7:47 PM
  • I found a solution.  C:\Windows\System32\spool\PRINTERS folder, security tab.  I gave the "Everyone" group permission to read & execute, list folder contents, read, and write.  It solved my issue.  Now the other question is why would it not be authenticating the correct group in the first place?  When I'm using a domain admin account and I see Administrators (DOMAINHERE\Administrators) with full control, logic would tell me that the I should've already had access to it.
    • Proposed as answer by 11111111111333 Wednesday, June 19, 2013 5:08 PM
    Thursday, November 01, 2012 5:03 PM
  • I have not had to do this on my system, what are the other permissions you have on that folder, id like to compare?

    Robert Pearman SBS MVP | |

    Friday, November 02, 2012 11:42 AM
  • "All Application Packages" - Read & Execute, List Folder Contents, Read

    CREATOR OWNER - Full Control

    SYSTEM - Full Control

    Administrators (DOMAIN\Administrators) - Full Control

    Users (DOMAIN\Users) - Read & Execute, List Folder Contents, Read

    Print Operators (DOMAIN\Print Operators) - Full Control

    TrustedInstaller - Full Control

    EVERYONE - Read & Execute, List Folder Contents, Read, Write

    All permissions were default except for EVERYONE.  Once I added that, I was able to print.

    Friday, November 02, 2012 4:28 PM
  • Bump. I'm having exactly the same issue too. Does anyone know the correct security settings that need to be modified to allow access? (i.e. what needs to be done to resolve the issue without having to allow everyone write access to a system folder?)

    This happens to me with a vanilla install of Server 2012 Essentials and just using the Microsoft XPS Document Writer printer.

    Robert, did you set up 2012 Essentials with the default domain it provides? This doesn't seem to be an issue with the full Server 2012 OSs and they don't install a default active domain. So that seems to be the point of difference.


    • Edited by Andrew Cardy Friday, June 21, 2013 9:34 AM More info
    Friday, June 21, 2013 8:42 AM
  • Giving this folder WRITE permissions for anyone that needed to print ("Everyone") worked for me. We are using the full version of server 2012 as a domain controller with file and print sharing enabled.
    Thursday, September 05, 2013 6:34 PM
  • Jjames162's solution is top class Fully agree. Well done J Santiago. MCITP EA, CCNP
    Saturday, January 25, 2014 7:01 PM
  • I know it's a bump... but we were having the same issue on a fresh 2012 install.  The server is a DC, so I wonder if that is affecting the default permissions.  Granting DOMAIN\Users Write access to the spooler folder resolved it.

    Monday, August 04, 2014 9:38 PM
  • Wow. This is nothing short of mind blowing.

    Here's an even stranger wrinkle. My server was a 2012R2 Essentials box -- being used as a home server.

    I had an HP 6310 all in one that was shared on the box and working for two months when it leaked smoke and died.

    I purchased a new version of the printer ... an Officejet 8610.. and have been through two days of pulling (what's left of) my hair out -- loading and unloading drivers, ports, printer management role... couldn't get a print job out of the printer. All the diagnostics and other commands worked...just wouldn't print.

    So howcum it printed before and then it wouldn't -- there's clearly something systemic happening here....

    This fixed it though... Thanks to jjames162

    Thursday, March 05, 2015 3:33 PM
  • Hi Greg,

    What was the fix and your conclusion to the cause of this problem? I have the same problem in our environment.  Thanks!

    Wednesday, April 27, 2016 11:03 PM