none
group policy preference 4098 error 0x8007007b

    General discussion

  • We're using Group policy preferences to deploy shared printers to users but certain computers keep getting the following error on some of the printers deployed but not all of them.

    Event Type: Warning
    Event Source: Group Policy Printers
    Event Category: (2)
    Event ID: 4098
    Date:  2009/02/25
    Time:  8:34:07 AM
    User:  NT AUTHORITY\SYSTEM
    Computer: computername
    Description:
    The user 'printer' preference item in the 'Information Systems Settings {3FABC171-BB2D-482A-911C-B0D11D227D8B}' Group Policy object did not apply because it failed with error code '0x8007007b The filename, directory name, or volume label syntax is incorrect.' This error was suppressed.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    The most users are only members of the local users group on their computers. The user's computers are Windows XP sp3 with the CSE installed and the print server is Windows 2003 SP2. I can temporarily resolve the issue by re-applying the printer's security settings on the server but the error does come back within a week. On another note, some of the printers won't map for the user. They'll get an error saying "You do not have sufficient access to your computer to connect to the selected printer." Even though all the printers have the default permissions with everyone group having print permissions set. Any help would be appreciated.

    Thanks,
    Ryan

    Friday, March 06, 2009 2:12 PM

All replies

  • Hi,

    How did you setup the printer in Group Policy Preference? If after clicking New, you chose TCP/IP Printer, please try to delete the original printer and create a new Shared Printer. Run "gpupdate /force" to update GP and test on clients.

    If the issue persists, please enable the following policies in GPO for client computers.

    [Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon]

    Create a reg file containing the following content and import on user logon.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Group Policy\{BC75B1ED-5833-4858-9BB8-CBF0B166DF9D}]
    @="Printers Policy Processing"
    "NoSlowLink"=dword:00000000
    "NoBackgroundPolicy"=dword:00000000
    "NoGPOListChanges"=dword:00000000
    "BackgroundPriorityLevel"=dword:00000000

    Run "gpupdate /force" and restart the clients to test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 09, 2009 11:06 AM
    Moderator
  • The printers were setup as shared printers in the GPP and I already had the [Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon] set to enabled. I can try the registry change but I have a couple questions with it.  First with the key name will the {BC75B1ED-5833-4858-9BB8-CBF0B166DF9D} need to be changed to the guid of the policy that's applying the printer? Also from the looks of the entries it appears to be disabling all the settings. Wouldn't these be the default settings in group policy unless they have been manually changed? Also when you set these setting are they only applied for that one policy then?
    Monday, March 09, 2009 6:00 PM
  • Hi,

    You don’t need to change {BC75B1ED-5833-4858-9BB8-CBF0B166DF9D}, this guid refer to "Printers Policy Processing" policy. You can also try to enable the following policy instead. 

    [Computer Configuration\Administrative Templates\System\Group Policy\Printers Policy Processing]

    Please enable:
    1. Allow processing across a slow network connection
    2. Process even if the Group Policy objects have not changed.

    Run "gpupdate /force" and restart the clients to test.

    Thanks. 


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, March 10, 2009 10:47 AM
    Moderator
  • I enbled the policy settings for workstations but that still didn't fix the issue. We're still getting the errors on the workstations. I've used the Sysinternals tool "Procmon.exe" on the workstations to try and see where it's erroring out but can't find anything that looks to be getting denied. It's a really wierd issue as it's not consistant for which users or printers it happens with. I also just noticed one more thing with the printers on a workstation that are receiveing the error. The printers with the error don't have the associated port when you go into the properties of them.
    Monday, March 23, 2009 5:46 PM
  • Hi,

    After getting this error on clients, could you manually add the printer?

    At the same time, please try to collect the following information for research.

    On DC:

    1.    Open the GPO, navigate to:

    [Computer Configuration\Policies\Administrative Templates\System\Group Policy\Logging and Tracing]

    2.    Double-click Registry Policy Processing Properties, click Enable, change Tracing to On. Click OK.

    3.    Test on clients, find "%SYSTEMDRIVE%\Documents and Settings\All Users\Application Data\GroupPolicy\Preference\Trace\user.log" and send to tfwst@microsoft.com for research.

    On Clients, collect MPS Report of clients:

    A.    Download MPS Reporting Tool (MPSRPT_PFE.EXE) from the following link:
    (http://www.microsoft.com/downloads/details.aspx?FamilyID=00ad0eac-720f-4441-9ef6-ea9f657b5c2f&DisplayLang=en)

    Please note: The link may be truncated when you read the E-mail. Be sure to include all text between '(' and ')' when navigating to the download location.

    B . Right click MPSRPT_PFE.EXE and select Run as Administrator to run this tool, and you will see a Command Window start up.

    C . Please type Y with the message of <Include the MSINFO32 report? (defaults to Y in 15 seconds)[Y,N]?

    D . When the tool is done you will see an Explorer Window opening up the %systemroot%\MPSReports\Setup\Reports\cab folder and containing a <Computername>MPSReports.cab file. After collecting, please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the file and then give me the download address.


    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 30, 2009 10:30 AM
    Moderator
  • It doesn't appear to be related to only the GPP. A user that is receiveing the error can't manually add the printer either as either a basic user or as a member of the local power user. If you make the user a local admin it doesn't stop the GPP error but then they can successfuly add the shared network printer. After that the GPP error is fixed, at least temporarily. However we'd like to not have users added to the local admins groups on the workstations. Also the work around of re-applying the printer's security settings on the print server will allow the standard user with out the local admin permissions to add the network printer and it does temporarily fix the GPP errors. A user may experience the errors on 1 computer but not on another. So the error's appear to be computer related but the GPP will work for some users with the same printers but fail for others on the same computer. In fact on the same computer it can be different printers causing the errors for 2 users getting the same GPP. It seems like there's an issue with resolving the printer's permissions some how. The everyone group has print permsions on the network printers and the users are all in the same domain as the printers. The users are only members of the local users group on the workstation but users are supposed to be able to add network printers. I've used the Sysinternals tool "Procmon.exe" on both the Workstations and the print server to try to see any problems with the processes happening. There doesn't appear to be anything being denied at either end that i can see. Would you still like both the GP logging and the MPS Reporting Tool info?
    Tuesday, April 07, 2009 6:26 PM
  • Ryan,

    I am having the same issue - have you gotten it resolved yet?

    Dave
    Thursday, May 28, 2009 2:33 PM
  • Nope, I've just been using the resource kit tool EventCombMt to search the workstation's event logs for the errors and then reset the permissions on the printers causing the errors. This gets rid of the errors for a little while but they do come back.
    Wednesday, July 08, 2009 2:15 PM
  • We are seeing the same issue. I can't figure out what is causing the problem. I have had success to solve the problem on some of the client computer by adding the Domain Users account to the printer security and giving the group Print and Manage printers right, afterwards I can get the shared printer installed. I don't want our users to have Manage Printers rights so I tried removing it again and it actually still works afterwards...... I find it very strange.

    Out of 80 users we have had around 10 with this problem and almost never the same printers, but the above "solution" with the temporary permissions have solve the problem on some of the users computer, but not all.
    Lasse
    Friday, September 25, 2009 1:24 PM
  • I just started seeing this warning right after I installed Microsoft .NET Framework 3.5 Service Pack 1 and .Net Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86.

    Has anyone found a solution to this issue? I've tried re-installing KB951847 and Group Policy Preferences (KB943729), but neither seem to remove the warning.

    Thanks,
    Mike


    Mike
    Wednesday, December 30, 2009 8:18 PM
  • I have the same issue but I have found a way to get rid of it... Until next reboot. You have to start a console with administrative privilege and restart the spooler. Then you will have to refresh the group policy in user context so, start a new console wihtout administrative privilege and then run "gpupdate /targert:user". Printer should now apeare.

    Since my users does not have administrative privilege, I have create a gpo that trap event id 4098 from group policy printer that restart the spooler. My user only have to run "gpupdate /targert:user" if the printer are not installed.

    I have found a way to make sure I reproduce the problem. It could be helpfull if you want to try if my workaround is good for you since it is intermitent. All you have to do is to restart the computer and then logon immediatly when the computer is ready to do so. It is 100% effective for me. It look like a service dependency issue...

    It is only a workaround but ther is definatly a serious problem with shared printer installation by GPO. I hope this will help someone to find a real solution for this painful problem. Painfull it is when you have a lab with 100 computer with new users every day that don't know they should run gpupdate. Can someone at microsoft  do someting please. If you need someone for further testing, I'm you man.

    Thanks

     

    Thursday, August 26, 2010 7:16 PM
  • hi there, can you have a look on this thread with similar issue and solution

    http://social.technet.microsoft.com/Forums/en/winserverGP/thread/54933f91-ce4f-4b13-90ab-8ba428cd5ba7

    please try out the solution and let us know. thanks.

    Tuesday, September 14, 2010 2:16 AM