locked
Hyper-V + Centos6 + Linux IC 3.1 = Network Problem RRS feed

  • Question

  • Hi
    I have a network problem with my Centos 6 installation in Hyper-V. I tried a lot of things, but nothing seems to work, therefore I hope that somebody in here can help me.
    First, I must explain our configuration:
    Host-System: Windows Server 2008 with Hyper-V 
    Guest-Systems: up to 10 Centos 5.2 Server with Linux IC Driver
    Network-Configuration:
    Host-System with two physical NICs
    1 reserved for Remote Access
    the other one is bound to an external Virtual Network Switch called "extern"
    We configured 3 different Virtual Switches:
    "intern" - a private virtual network. All server need an IP from the network 192.168.80.x
    "DMZ" - a private virtual network. All server need an IP from the network 88.88.88.xx (<-- for example). These IPs are also reachable from outside the network (e.g. Internet)
    "extern" - an external virtual network. This is the network the physical NIC is bound to. Only our firewall is bounded to this network
    Situation:
    We have ca. 10 Server all running with Centos 5 on Hyper-V with Linux IC Driver. Every server has two virtual NICs, one bounded to the network "intern", the other one bounded to "DMZ".
    Only our Firewall, which is also the Gateway for our servers, is additionaly bounded to the external virtual network switch named "extern".
    The server act like they should do: every server can reach the other server through their specified networks and the firewall/gateway can also reach all other servers through all networks. And every new Server we installed (before now) worked the same way, we never had any network problems.
    But after installing a new Centos Server with Centos 6 (centos6) with Linux IC 3.1 drivers and configuring the NICs, I had the following problem:
    the firewall can ping centos6 through the network "intern", but not through "extern". This is very mysterious, because it is supposed to reach it through all networks (like the other servers).
    I also had to set a static MAC-Adress on the new centos6-Server because there were some installation issues with the network cards, but they technically work now. The other servers run with dynamic MAC-Addresses
    I hope i explained it in the right way. If there are any questions, I will answer them. I tried everything, but nothing helped.
    thank you for helping in advance
    Sam

    • Edited by SamTical Friday, September 16, 2011 8:20 AM
    Friday, September 16, 2011 8:17 AM

Answers

  • This is unlikely to be an issue with the Hyper-V drivers. We don't do anything to affect routing or the like - the only thing the hv_netvsc driver does is provide is recognition of the Hyper-V optimized virtualized hardware. Have you confirmed that an identical physical hardware system has the same issue?


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, September 18, 2011 4:19 PM