locked
Error applying certificate to RDP-TCP connection in Session host config RRS feed

  • Question

  • Hi,

    I'm trying to configure my session host connections to be secured using a certifcate issued by a CA.  I've had no problems configuring the gateway or broker server but am getting the following error when I am configuring the session host:

    Remote Desktop Session Host Configuration:
    There are no certificates installed on this Remote Desktop Session Host server.

    If you are not familiar, where to change this setting you must right click the "RDP-TCP" connction, select properties and then press "Select" on the General tab.

    The certificate is installed in the personal certificates of the current user.

    This is happening on both the servers in my farm and is causing an error message due to the certificate mismatch.  Any assistance or a workaround would be great.

    Thanks
    Soops

     

     


    Microsoft Certified Systems Administrator: Microsoft Windows Server 2003 Microsoft Certified Technology Specialist: Microsoft Exchange Server 2007, Configuration
    • Moved by Lionel Chen - MSFT Thursday, June 3, 2010 2:38 AM (From:Windows Server 2008 R2 Remote Desktop Services)
    Friday, April 30, 2010 1:16 PM

Answers

  • hi soops, the certificate must be installed in the personal cert of the computer account and not your personal.  Once that's done it will be visible and selectable.
    • Marked as answer by soops Tuesday, May 4, 2010 8:45 AM
    Friday, April 30, 2010 4:54 PM

All replies

  • hi soops, the certificate must be installed in the personal cert of the computer account and not your personal.  Once that's done it will be visible and selectable.
    • Marked as answer by soops Tuesday, May 4, 2010 8:45 AM
    Friday, April 30, 2010 4:54 PM
  • James you're an absolute superstar!  Thank you
    Microsoft Certified Systems Administrator: Microsoft Windows Server 2003 Microsoft Certified Technology Specialist: Microsoft Exchange Server 2007, Configuration
    Tuesday, May 4, 2010 8:46 AM
  • I'm also getting the same error as soops. I've ensured that the certificate is installed in the Computer\Personal store, but still don't seem to be able to choose it.

    I've successfully used this certificate for signing the RemoteApp packages, but cannot use it for the rdp-tcp setting.

    Anyone got any insight here?

    Wednesday, August 17, 2011 4:22 AM
  • The end result of this was importing it into the User\Personal store then clicking and dragging the cert to Computer\Personal. Unfortunately this removes the private key, a feature of Windows 2008 and above. Directly importing into that location resolved my issue.

    • Proposed as answer by PavelXK Monday, July 11, 2016 11:24 AM
    Thursday, August 25, 2011 1:58 AM
  • I am also getting the same error, I tried the solution given above by JamesB24 and also imported the certificate directly into Personal Store but it's not working.

    Any solution is well appreciated, I am trying to fix this from past couple of days but in vain

    Thursday, November 3, 2016 12:23 PM
  • I've got the same issue - do you remember how you fixed it?
    Monday, October 29, 2018 12:04 PM