none
SMB2.1 Large MTU - Enabling offload

    Question

  • I was trying to measure the throughput with the SMB2.1 Large MTU feature with Windows 2012 R2 Standard. I was following the blog - https://blogs.msdn.microsoft.com/openspecification/2009/06/22/smb-2-1-multi-credit-large-mtu-operations/ for the same. I've tried with different 10Gbps Intel Ethernet card with a 10Gbps switch. All the offloads setting are enabled from the Ethernet card perspective... I made changes according to https://blogs.technet.microsoft.com/brad_rutkowski/2007/08/10/how-to-know-if-tcp-offload-is-working/ in order to have TOE enabled. However, the TCP connections still shows "InHost" instead of "offloaded" with netstat -t.

    I also verified the registry settings on my server and client (both are Windows 2012 R2 Standard) using https://msdn.microsoft.com/en-us/windows/hardware/drivers/network/using-registry-values-to-enable-and-disable-task-offloading.

    Any idea, why the TCP connections still shows "InHost" and not "offloaded".

    One more thing: The link https://msdn.microsoft.com/windows/hardware/drivers/network/obsolete-rfcs-that-should-not-be-used says the TCP chimney offload feature is deprecated and should not be used. How true it is?
    Friday, November 11, 2016 9:15 AM

All replies

  • Hi,

    1.>>Any idea, why the TCP connections still shows "InHost" and not "offloaded".

    Please check the settings on nic properties,such as Checksum offloading and Large Send offload being related to TCP chimney.

    2.>>How true it is?

    I prefer follow the latest article.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 14, 2016 7:11 AM
    Moderator
  • Both are enabled:

    However, the connection still shows "InHost" and not "offloaded"

    Best regards,

    Purvang


    • Edited by Purvang Modi Monday, November 14, 2016 8:51 AM Screen shot is not reflecting in the reply
    Monday, November 14, 2016 8:49 AM
  • Hi,

    Sorry I don't reproduce the same issue in our lab,and it seems you have configured all necessary settings.

    If this issues is a state of emergency for you,I suggest you open a case with Microsoft, more in-depth investigation can be done so that you would get a more satisfying explanation and solution to this issue.

    Here is the link:

    https://support.microsoft.com/en-us/gp/support-options-for-business


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 16, 2016 6:37 AM
    Moderator


  • For the above issue, can we use the MSDN incidents to take help from Microsoft? We have taken the MSDN Enterprise subscription.

    Please suggest.

    Thanks,
    Praveen
    Tuesday, April 18, 2017 6:28 AM