none
IE LAN Settings: "Automatically detect settings" RRS feed

  • Question

  • I'm currenting running Windows 7 Enterprise with IE8 and i'm having difficulty de-selecting the "Automatically detect settings" check box under LAN Settings.

    I've configured my proxy settings using a GPO under the Internet Explorer Maintenance which are applying successfully but the "Automatically detect settings" remains selected even though i have disabled "Automatically detect configuration settings".

    Can someone please help? I am trying to apply this on multipul computers so would prefer this to be done via GPO.

     

    Monday, December 19, 2011 7:23 PM

Answers

  • Hi, Joanne

    Firstly uncheck “Automatically detect settings” at the server where you configure Group Policy.

    Or you can save below data to .reg file and input to your registry:

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections]

    "DefaultConnectionSettings"=hex:46,00,00,00,bc,00,00,00,01,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,33,00,00,00,68,74,74,70,3a,2f,2f,73,\

      69,6e,70,72,6f,78,79,2e,66,61,72,65,61,73,74,2e,63,6f,72,70,2e,6d,69,63,72,\

      6f,73,6f,66,74,2e,63,6f,6d,2f,77,70,61,64,2e,64,61,74,9e,ac,06,29,cc,bb,cc,\

      01,00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,02,00,00,00,9d,3c,3c,70,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

     

    Then when you create GPP, it will get the registry entry value form current registry.

    In my test, the value is:

    460000000B00000001000000000000000000000000000000000000000000000020B9952FC3BBCC0100000000000000000000000002000000170000000000000000000000000000000000000000000001000000001C00000000000000000000000000000000200000002000000010000001000000ED0300000906020008000000000000000000000000000000000000000000000000000000000000000000000000000000FFFFFFFFC0B0EAF9D426D011BBBF00AA006C34E4020000000A000066000000000000000000B55700000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


    Lawrence

    TechNet Community Support

    Wednesday, December 21, 2011 1:58 AM
    Moderator

All replies

  • Try that link -  http://www.tomshardware.com/forum/238622-49-uncheck-auto-detect-settings

     

    Please let me know if the issue solved.


    Regards, Liran.
    Monday, December 19, 2011 7:58 PM
  • Hi,

    Thanks for your posting.

    After research, we didn’t find a group policy configuration item to un-check “Automatically detect settings”. But we have a workaround to achieve that, we can un-check this item through modify registry.

    If you use Windows Server 2008 or 2008r2 DC (or Remote Server Administration Tools on Windows7 Enterprise, Professional, or Ultimate editions) you can deploy a GPP to modify registry.

    1. Un-check “Automatically detect settings” at your DC
    2. Create a Group Policy and link it to a scope (OU or domain level not group) that contains your specified user accounts
    3. Edit the GPO: User Configuration-->Preferences-->Windows Settings-->Regisrty-->New-->Registry Item-->Action (Update) -->Key Path: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\DefaultConnectionSettings
    4. Logoff or restart client OS to apply this GPO

    For more information please refer to following MS articles:

    Turn off Auto Detect Settings in IE using GPO
    http://social.technet.microsoft.com/Forums/en/winserverGP/thread/cb6abb30-4360-4d3d-93fc-61823b2a5c20
    IE, Disable 'Automatically Detect Settings' Via GPO
    http://social.technet.microsoft.com/Forums/en/winserverGP/thread/62a4427c-d5a7-4d5b-867c-0f5c6e921315


    Lawrence

    TechNet Community Support



    Tuesday, December 20, 2011 6:32 AM
    Moderator
  • Hi Lawrence,

    I have created a GPO with the following settings but i'm unsure what to input in the Value data field -

    Action: Update
    Hive: HKEY_CURRENT_USER
    Key Path: Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
    Value name: DefaultConnectionSettings
    Value type: REG_BINARY
    Value data: <blank>


    Thanks,
    Joanne

    Tuesday, December 20, 2011 10:05 AM
  • بسم الله الرحمن الرحيم

    Kindly go to your proxy and configure it to disable Automatically detect settings


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator My blog: http://Mabdelhamid.wordpress.com/
    Tuesday, December 20, 2011 10:56 AM
  • Mohamed,

    Thanks for you help but i'm not sure i understand exactly what you're suggesting. Do you know where to set this in a GPO?

     

    Thanks,
    Joanne

    Tuesday, December 20, 2011 11:49 AM
  • بسم الله الرحمن الرحيم

    firstly what Does your kind proxy server ?

    and you should check all inherit group policy in this OU. maybe any inherit GPO had more priority force itself on new GPO

    means If OU linked with 2 GPO and linkd to Defult Domain Group Policy ok

    you should disable Automatically detect settings on inherit policy or give new one more priorty

     


    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator My blog: http://Mabdelhamid.wordpress.com/
    Tuesday, December 20, 2011 12:03 PM
  • Hi, Joanne

    Firstly uncheck “Automatically detect settings” at the server where you configure Group Policy.

    Or you can save below data to .reg file and input to your registry:

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections]

    "DefaultConnectionSettings"=hex:46,00,00,00,bc,00,00,00,01,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,33,00,00,00,68,74,74,70,3a,2f,2f,73,\

      69,6e,70,72,6f,78,79,2e,66,61,72,65,61,73,74,2e,63,6f,72,70,2e,6d,69,63,72,\

      6f,73,6f,66,74,2e,63,6f,6d,2f,77,70,61,64,2e,64,61,74,9e,ac,06,29,cc,bb,cc,\

      01,00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,02,00,00,00,9d,3c,3c,70,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

      00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

     

    Then when you create GPP, it will get the registry entry value form current registry.

    In my test, the value is:

    460000000B00000001000000000000000000000000000000000000000000000020B9952FC3BBCC0100000000000000000000000002000000170000000000000000000000000000000000000000000001000000001C00000000000000000000000000000000200000002000000010000001000000ED0300000906020008000000000000000000000000000000000000000000000000000000000000000000000000000000FFFFFFFFC0B0EAF9D426D011BBBF00AA006C34E4020000000A000066000000000000000000B55700000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


    Lawrence

    TechNet Community Support

    Wednesday, December 21, 2011 1:58 AM
    Moderator
  • Even Microsoft does not recommend using Group Policy?

    A joke.  Are there any plans to fix this issue?

    Here's a fix that can be applied using logonscript:

    IE_UNCHECK_AutoDetectSettings.REG
    ----------------

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections]
    "DefaultConnectionSettings"=hex:3c,00,00,00,11,00,00,00,01,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,01,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
      00,00,00,00,00,00,00,00,00,00,00,00

    -------------------

    Then do REG IMPORT IE_UNCHECK_AutoDetectSettings.REG   during logonscript.

     For a full explanation, read here: http://atyoung.blogspot.no/2012/06/info-regarding-hkeycurrentusersoftwarem.html

    Thursday, March 7, 2013 8:57 AM
  • I would like to share what I have discovered in RegMon since last year and tested working. Just shared this in the Internet, sorry for the delay. =)

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    AutoDetect = 1  (DWord value) 

    - enables "Automatically detect...."

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    AutoDetect = 0 (DWord)

    -disables "Automatically detect...."

    The solution is pretty straight forward. I could not see any MS post/blog advising this setting.

    Note: This is a "volatile" registry item which disappears after applying changes, bottom line, it should work.

    You could simply implement this setting in GP Preferences. Please vote and feedback if it works!

    Tested in IE8/IE10/Windows 7 and 8



    • Proposed as answer by Mon Laq Friday, January 3, 2014 2:49 AM
    • Edited by Mon Laq Friday, January 3, 2014 2:52 AM
    Friday, January 3, 2014 2:49 AM
  • Mon Laq: Confirmed! It works!
    • Edited by Brainworks Tuesday, February 25, 2014 6:01 PM
    Tuesday, February 25, 2014 6:00 PM
  • Thanks Lawrence,

    Your solution was spot on.

    After googling around for answers on how to disable "Automatically detect setting" even though I unticked it in IE Maintenance in GPO, your solution to add the registry in GPP did the trick.

    I tried everything that was suggested in many blogs etc, but your's was the perfect solution to my problem.

    Thanks again.

    Candai

    Wednesday, May 7, 2014 12:41 AM
  • I think it was me who provided the solution. :)
    Wednesday, May 7, 2014 12:52 AM
  • Hi,

    try that links, usefull....

    The Internet Explorer "Automatically Detect Settings" option is unexpectedly enabled at first login

    Please let me know if the issue solved.
    Regards,  Xerxes


    Wednesday, August 20, 2014 11:18 AM
  • Wow - how has noone at Microsoft said anything about this? This is clearly the best answer, and should be marked as such.

    Thanks - really helped!

    Wednesday, December 3, 2014 1:06 PM
  • Hi,

    I know this is over a year old now almost two from your answer, but I have tried your settings and it is failing to untick the option for me.   My GPO setting for this regkey:  http://prntscr.com/99wypc    

    And the top box needing unticked, but doesn't want to :(   http://prntscr.com/99wz5z 

    Microsoft make this such a pain to change.

    Thursday, December 3, 2015 4:53 PM