locked
Disappear local port when restart print spooler RRS feed

  • Question

  • Hello,

    I've a problem, when I restart the print spooler or I reboot the windows, the Local port disappears.
    This error began after I ran the Printer Migrator Restore in Windows Server 2008, the file restore was from Windows Server 2003.

    I added the local port using the snap-in Print Manager(Print Server)
    Ex: \\svr01\Printer01

    If I don't restart the service print spooler I can use normally this port, but I'm restart the service "Print Spooler" this port is removed.

    This behavior didn’t occur before I run Print Migrator


    SO: Windows Server 2008 R2 Standard


    • Edited by RogerioH Friday, September 14, 2012 2:42 AM t
    Friday, September 14, 2012 12:46 AM

Answers

All replies

  • A local printqueue is more a tcp-ip printqueue, a print queue as \\svr01\Printer1 is stored by user, so I would check if you are in a temporary profile, in case of a profile error first. It would explain why it got deleted.

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Friday, September 14, 2012 1:13 AM
  • Yagmoth555,

    I'm not sure if my profile is temporary, how I can check it.

    The strange thing is that it worked before I run Printer Migrator.

    Friday, September 14, 2012 10:25 AM
  • Hi, it should log in your eventlog if so;

    A bit like that;

    Log Name: Application
    Source: Microsoft-Windows-User Profiles Service
    Date: <var>Date</var>
    Event ID: 1511
    Task Category: None
    Level: Warning
    Keywords: Classic
    User: <var>User</var>
    Computer: <var>Computer</var>
    Description:
    Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Friday, September 14, 2012 3:58 PM
  • Yagmoth555, my profile don't is temporary.
    Sunday, September 16, 2012 11:20 AM
  • Since Print Migrator is not supported past Server 2003, this could be known.  What is the information listed under this key?  Print migrator performed a bunch of registry actions, possibly messing with this information.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Local Port


    Alan Morris Windows Printing Team

    Sunday, September 16, 2012 3:24 PM
    Answerer
  • Alan,

    The information this key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Local Port
    (Default) | REG_SZ | (value not set)
    Driver     | REG_SZ | localspl.dll


    Tuesday, September 18, 2012 2:00 PM
  • That's the expected data.

    Local Ports are stored in the registry.  Make sure your local port is listed.  Then stop and start spooler.  The spooler will read from this list.  If it's not listed make sure you have write access to this location.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports


    Alan Morris Windows Printing Team

    Thursday, September 20, 2012 1:11 AM
    Answerer
  • Alan,

    Yes, my port it's on:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports

    Data: \\svr01\Printer01

    I have write and read access.

    Friday, September 21, 2012 8:39 PM
  • Something erase those registrys key. Try to find the process with processmonitor and be sure to enable boot logging (http://www.msigeek.com/6231/how-to-enable-system-boot-time-logging-using-process-monitor-tool)

    Print Migrator is not around in task manager?  I would tend to check if it's still waiting to update something, and can't, so it retry each time the spooler start. I ask because of that KB text below;

    If incompatible printer queues are found when you upgrade from Windows Server 2003 or from Windows Server 2003 R2 to Windows Server 2008, all printer queues may be deleted during the upgrade process.   (http://support.microsoft.com/?id=938923)


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/


    Friday, September 21, 2012 8:49 PM
  • Nobody is erasing registry keys in my case - when the print spooler restarts, it builds the list of local ports and drops some even though they are in the registry.  I suspect that there is a cached list somewhere that it uses...

    • Proposed as answer by Carlos I Friday, March 22, 2013 8:43 PM
    • Unproposed as answer by Carlos I Friday, March 22, 2013 8:43 PM
    Sunday, February 10, 2013 11:14 PM
  • Had similar problem.

    Turned out to be incorrect entries in the [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports].

    The tricky part is that if you look at the registry, you do not see anything wrong, but if you export that key to a file, you'd see a bad line. In my case the line was: @=""

    The solution was to export the key to a file, open the file and remove the bad line, rename the registry Ports to Ports0 (just to back it up) and then import the file.

    • Proposed as answer by Carlos I Friday, March 22, 2013 9:34 PM
    Friday, March 22, 2013 9:33 PM
  • Bingo!  I too had @="" - works great now! Thanks!!!!  There is a visible difference, however... if you look at the old ports, you will see the Default entry blank... on the new ports, the Default entry says "(value not set)".    I tried to acknowledge your entry as "the answer" but couldn't figure out how to do this.  Thanks so much once again.

    • Edited by JohnA5 Saturday, March 23, 2013 2:34 AM
    Saturday, March 23, 2013 2:13 AM
  • Hi Alan,

    Can you please help me in the below issue.

    The problem occurs when I print using remote access printing.I have just sent two documents to print.  When I logged in using my ID pass, the two documents were showing on screen.  I selected both and hit the print key – but only one document printed, and the other one disappeared from the screen. we use remote access printing, ie, we use our ID card to swipe onto any printer (using print from Windows 7)

    Print Server Details:-
    1.windows server 2008 R2 stranded
    2.Print Queues in the server 100+
    3.Tonnes of event error found in print server :-
    Log Name:      Microsoft-Windows-PrintService/Admin

    Source:        Microsoft-Windows-PrintService
     Date:          12/03/2013 12:28:53
     Event ID:      314
     Task Category: Printing a document
     Level:         Error
     Keywords:      Classic Spooler Event,Document Print Job
     User:          SYSTEM
     Computer:     
     Description:
     Document 428, Full page photo owned by Praveen timed out while printing on abcd. The spooler waited for 240000 milliseconds and no data was received.
    Log Name:      Microsoft-Windows-PrintService/Admin
     Source:        Microsoft-Windows-PrintService
     Date:          15/03/2013 14:21:50
     Event ID:      823
     Task Category: Changing the default printer
     Level:         Information
     Keywords:      Print Spooler
     User:         
     Computer:     
     Description:
     The default printer was changed to ,winspool,Ne98:. See the event user data for context information.

     

     


    Reddy

    Monday, March 25, 2013 1:48 PM
  • The spooler is waiting on data from the application.  Could you explain what the Remote Access Printing application is in a different post?  I have no reference to this product.

    Alan Morris Windows Printing Team

    Monday, March 25, 2013 5:47 PM
    Answerer
  • Hi,

    I have the same issue where the port disappears after rebooting the PC. Have exported the port entry from registry, revised and added back with no success. Does MS know that there are a bunch of people having this issue or someone has resolved this.

    Tuesday, September 2, 2014 8:19 PM
  • Having seen this post I checked the registry and found exactly the same issue present on 2 troublesome Win7 x64 machines; that being the @="" mysteriously present in  [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports]
    After exporting, editing and re-importing as described, no more offline or misbehaving OneNote printer. 


    • Edited by rangbot Tuesday, November 11, 2014 9:20 PM
    Tuesday, November 11, 2014 9:18 PM