none
Unable to start cluster service in passive node in windows 2003 cluster RRS feed

  • Question

  • Hi,

    we have two Node windows cluster (win2003),active node cluster service is up and running.we are unable to start the service is passive Node.

    when we are trying to start ,we are getting unable to start the service in local computer,process terminated un expectdley error code 1067

    please find the cluster logs

    00000eac.00000b40::2012/05/29-08:19:09.205 INFO [CS] Cluster Service started - Cluster Node Version 4.3790
    00000eac.00000b40::2012/05/29-08:19:09.205 INFO                                OS Version 5.2.3790 - Service Pack 2 (ADS 03000112L)
    00000eac.00000b40::2012/05/29-08:19:09.205 INFO                                Local Time is  2012/05/29-09:19:09.205
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [CS] Service Starting...
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [INIT] ClusterInitialize called to start cluster.
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [EP] Initialization...
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [DM] Initialization
    00000eac.0000053c::2012/05/29-08:19:09.205 ERR  [DM] DmInitialize: The hive was loaded- rollback, unload and reload again
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [DM] DmpRestartFlusher: Entry
    00000eac.0000053c::2012/05/29-08:19:09.205 INFO [DM] DmpUnloadHive: unloading the hive
    00000eac.0000053c::2012/05/29-08:19:09.283 INFO [Qfs] QfsSetFileAttributes C:\WINDOWS\Cluster\CLUSDB.BKP$ 80, status 2
    00000eac.0000053c::2012/05/29-08:19:09.283 INFO [Qfs] QfsDeleteFile C:\WINDOWS\Cluster\CLUSDB.BKP$, status 2
    00000eac.0000053c::2012/05/29-08:19:09.283 INFO [DM] Loading cluster database from C:\WINDOWS\Cluster\CLUSDB
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [DM] DmpStartFlusher: Entry
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [DM] DmpStartFlusher: thread created
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Initializing...
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Local node name = XXX-CN01.
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Local node ID = 1.
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Creating object for node 1 (XXX-CN01)
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Initializing networks.
    00000eac.0000053c::2012/05/29-08:19:09.393 INFO [NM] Initializing network interfaces.
    00000eac.0000053c::2012/05/29-08:19:09.393 WARN [NM] Failed to open cluster parameters key, status 2.
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [NM] Initialization complete.
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [FM] Starting worker thread...
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [API] Initializing
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [LM] LmInitialize Entry.
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [LM] TimerActInitialize Entry.
    00000eac.00000848::2012/05/29-08:19:09.424 INFO [FM] Worker thread running
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [CS] Service Domain Account = TCXXX\ltcluster1
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [CS] Initializing RPC server.
    00000eac.0000053c::2012/05/29-08:19:09.424 ERR  [INIT] Unable to bind RPC to UDP, status 87.
    00000eac.0000053c::2012/05/29-08:19:09.424 ERR  [CS] ClusterInitialize failed 87
    00000eac.0000053c::2012/05/29-08:19:09.424 WARN [INIT] The cluster service is shutting down.
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [EVT] EvShutdown
    00000eac.0000053c::2012/05/29-08:19:09.424 WARN [FM] Shutdown: Failover Manager requested to shutdown groups.
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [FM] FmpCleanupGroups: Entry
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [FM] FmpCleanupGroups: Exit
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [Dm] DmShutdown
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [DM] DmpShutdownFlusher: Entry
    00000eac.0000053c::2012/05/29-08:19:09.424 INFO [DM] DmpShutdownFlusher: Setting event
    00000eac.000008e0::2012/05/29-08:19:09.424 INFO [DM] DmpRegistryFlusher: got 0
    00000eac.000008e0::2012/05/29-08:19:09.424 INFO [DM] DmpRegistryFlusher: exiting
    00000eac.0000053c::2012/05/29-08:19:09.440 WARN [MM] MMLeave is called when rgp=NULL.
    00000eac.0000053c::2012/05/29-08:19:09.440 ERR  [CS] Service Stopped. exit code = 87

    Tuesday, July 24, 2012 7:23 AM

Answers

  • Hi,

    Issue has been fixed,As i mentioned Earlier i have deleted the Internet folder(passive) in Reg and rebooted the Node.after rebooting service has come up.

    Many thanks for the guidance and Support


    Uthanda

    • Marked as answer by uthandaa Thursday, September 13, 2012 4:02 AM
    Thursday, July 26, 2012 1:39 AM

All replies

  • This stands out to me:

    ERR  [INIT] Unable to bind RPC to UDP, status 87.

    net helpmsg 87

    The parameter is incorrect.

    XXX-CN01 cannot communicate via RPC.  I would start your investigation there.  Did anyone change RPC service startup type? Restrict RPC ports?


    Dave Guenthner [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.technet.com/b/davguents_blog

    Tuesday, July 24, 2012 10:19 AM
  • Hi dave,

    Thanks for the reply

    we haven,t changed the RPC service start up type& there is no restriction in RPC ports.

    we found internet folder in RPC(HKLM\Service\Microsoft\RPC) registry ,we have compared with Active Node(i have compared some other cluster Nodes),in active Node there is No folder called internet inside RPC.

    please let me know if any information required.

    Many thanks

    Uthanda


    Uthanda

    Tuesday, July 24, 2012 10:38 AM
  • Keep investigating RPC.  Can you look at:

    258469 Cluster Service May Not Start After You Restrict Available IP Ports for Remote Procedure Call
    http://support.microsoft.com/kb/258469/EN-US

    Compare this registry key to other working nodes in envrionment, see if anything is different?


    Dave Guenthner [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. http://blogs.technet.com/b/davguents_blog

    Tuesday, July 24, 2012 11:31 AM
  • Hi Dave,

    Internet folder available only in  passive Node(where cluster service down), other working Cluster Nodes,we don't have the internet folder in registry.

    does the MS Link applies to 2003 Ent R2 edition.also please let me know weather internet folder is required in registry.

    Many Thanks

    Uthanda


    Uthanda

    Tuesday, July 24, 2012 11:39 AM
  • Hello Did you try Cluster commandline troubleshooting tools ?

    what is your eventviewer says ..?Also verify below URL

    http://support.microsoft.com/kb/923838

    Clusvc / ?

    Regards,

    Biju

    Tuesday, July 24, 2012 12:38 PM
  • Hi Bijumon,

    i haven't tried any tools.

    i have tried to start the Service in command Prompt but it throwing below error

    C:\Documents and Settings\administrator.>net start clussvc
    The Cluster Service service is starting.
    The Cluster Service service could not be started.

    A system error has occurred.

    System error 1067 has occurred.

    The process terminated unexpectedly.

    in Event log i couldn't see any errors.related to services failure.

    Thanks

    Uthanda


    Uthanda

    Tuesday, July 24, 2012 12:51 PM
  • Hi Dave,

    is there any way to troubleshoot this issue,

    THanks


    Uthanda

    Wednesday, July 25, 2012 2:28 PM
  • Hi

    Whenver the cluster Services goes down , you will get logs in Event viewer. Please check the logs(You can get in working server) and paste here if you can get. And if your OS has only SP1 their is chance you may not get in Evenviewer, let me know what service pack you have installed .

    Also why cant you try unjoin and join domain again and Re-set up the cluster again for this node.

    Anyway before doing all this i suggest you to check below url options-CLUSTER STARTUP OPTIONS.

    http://support.microsoft.com/kb/258078
    Wednesday, July 25, 2012 2:58 PM
  • Hi,

    when i am trying to start the service i am getting following error in my eventlogs

    Event Type:    Error
    Event Source:    ClusSvc
    Event Category:    Startup/Shutdown
    Event ID:    1073
    Date:        7/25/2012
    Time:        5:18:22 PM
    User:        N/A
    Computer:    LTBSS1-CN01
    Description:
    Cluster service was halted to prevent an inconsistency within the server cluster. The error code was 87.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Both server is running with W2K3 SP2 Enterprise edition .we have 2000 SQL cluster running on the Node.if we disjoint Node from domain and if we add to domain again.stil it will be part of SQL and windows cluster or we have to re-do completely.

    THanks


    Uthanda

    Wednesday, July 25, 2012 4:26 PM
  • Hi,

    For Event ID 1073:http://support.microsoft.com/kb/257879


    Regards, Ravikumar P

    Wednesday, July 25, 2012 8:07 PM
  • Hi,

    Issue has been fixed,As i mentioned Earlier i have deleted the Internet folder(passive) in Reg and rebooted the Node.after rebooting service has come up.

    Many thanks for the guidance and Support


    Uthanda

    • Marked as answer by uthandaa Thursday, September 13, 2012 4:02 AM
    Thursday, July 26, 2012 1:39 AM
  • Hi,

    Issue has been fixed,As i mentioned Earlier i have deleted the Internet folder(passive) in Reg and rebooted the Node.after rebooting service has come up.

    Many thanks for the guidance and Support


    Uthanda

    Good to see that your problem has been solved.Write here again for any other help.

    Regards, Ravikumar P

    Thursday, July 26, 2012 1:44 AM
  • Thanks Uthanda!!!

    I was having the same problem in Microsoft Windows Server 2008 R2:

    The Cluster Service service could not be started.
    A system error has occurred.
    System error 1067 has occurred.

    And I fixed deleting the Internet folder of RPC registry in the passive node.


    Saturday, July 27, 2013 4:14 AM