locked
How to set "Use client-provided log on information" on a Windows Server 2012 R2 RRS feed

  • Question

  • Hi,

    In Windows 2003/2008, one was able to configure this setting in the RDP-tcp settings | Log on Settings. This is no longer the case for Windows Server 2012 R2. I have checked GPO settings for RDS ->  nothing.

    I have the problem that when RDP'ing to a Domain Controller, I am constantly requested for my credentials twice. This is annoying.

    Is there any simple way to configure this setting, be it a registry setting or via PS or GPO. I have searched the Internet and have found nothing. One possibility would be to install TSCONFIG from 2008, but this is not a clean solution. I require this on many servers and need a routine way to configure it.

    Any help would be GREATLY appreciated.

    dave

    Tuesday, April 22, 2014 2:43 PM

Answers

  • Hi Everyone,

    One possible work-around is the following:

    

    You can use the MMC.exe from a Windows Server 2008 R2 server and the “Remote Desktop Session Host

    Configuration” snap-in to remotely connect to a Windows Server 2012/R2 and manage the RDP-Tcp

    settings. When you add the snap-in to the console, select “Another computer” and enter the name of the 2012 R2

    server. This should show us the default RDP-Tcp settings for the 2012 R2 server.

    From here you can make canges to the settings.

    Unforutnately, if you have many servers, this si definitely not the "ultimate" solution!

    dave

    • Marked as answer by AnnaWY Monday, May 5, 2014 2:42 PM
    Monday, April 28, 2014 6:28 AM
  • Hi Everyone,

    Another option is to set the registry key HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\fInheritAutoLogon = 1.

    This is then easy to script!

    However, as in my case, you may have the problem with "Always prompt for password upon connection". I have it ENABLED and with fInheritAutologon = 1, it is totally ignored.

    Still working on it !

    dave

    • Marked as answer by AnnaWY Monday, May 5, 2014 2:42 PM
    Tuesday, April 29, 2014 5:36 AM

All replies

  • Hi Dave,

    To avoid keeping providing the credential, please try to disable the setting : Always prompt for password upon connection under
    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security

    For the RDP-tcp settings on server 2012 r2, please check this article:

    RDP-TCP settings tab disappear in Windows 2012 RD

    I hope this helps.

    Thursday, April 24, 2014 4:04 AM
  • Hi Anna,

    Thanks for the reply. Unfortunately,simply Disabling the "Always prompt for password" doesn't help. Even to establish an RDP connection, one must enter in the UserID and password, and then both again to actually connect.

    What works on W2K3 / W2K8 is the setting "Use client-provided log on informaiton" andhtis setting doesn't exist in a GPO.

    david

    Thursday, April 24, 2014 5:48 AM
  • Hi Everyone,

    One possible work-around is the following:

    

    You can use the MMC.exe from a Windows Server 2008 R2 server and the “Remote Desktop Session Host

    Configuration” snap-in to remotely connect to a Windows Server 2012/R2 and manage the RDP-Tcp

    settings. When you add the snap-in to the console, select “Another computer” and enter the name of the 2012 R2

    server. This should show us the default RDP-Tcp settings for the 2012 R2 server.

    From here you can make canges to the settings.

    Unforutnately, if you have many servers, this si definitely not the "ultimate" solution!

    dave

    • Marked as answer by AnnaWY Monday, May 5, 2014 2:42 PM
    Monday, April 28, 2014 6:28 AM
  • Hi Dave,

    Thanks for your sharing =], which will help others who have the similar issue with you.

    Monday, April 28, 2014 6:42 AM
  • Hi Everyone,

    Another option is to set the registry key HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\fInheritAutoLogon = 1.

    This is then easy to script!

    However, as in my case, you may have the problem with "Always prompt for password upon connection". I have it ENABLED and with fInheritAutologon = 1, it is totally ignored.

    Still working on it !

    dave

    • Marked as answer by AnnaWY Monday, May 5, 2014 2:42 PM
    Tuesday, April 29, 2014 5:36 AM