none
Cannot Install ADWS on server 2003 Standard SP2

    Question

  • running server 2003 SP2 - Extended my schema to 2008 no problems. Installed latest RSAT on a windows 7 domain client, cannot connect due to no ADWS service running on my DC.

    I attempted to install the ADWS service and received an error at the point where my netlogon was too low a version.
    After researching I found the hotfix for just this issue (KB969428) and installed the hot fix.
    ADWS (KB968934) fails again - this time it succeeds all prerequisite checks (passing netlogon) up to prerequisite check for System.DirectoryServices.AccountManagement

    After looking in to this, it appears to be looking for a .net component that is newer than 3.5 SP1 - Should I install Beta 4 of .net to resolve this? If so, what are the ramifications of having to uninstall and reinstall .net when v4 final is released? if not, how else can I resolve this issue?

    Below is my KB968934.log - I left the first section in to show where it failed at netlogon, scroll down and you will see netlogon pass the prerequisite check and where my next failure occurs. Thank you in advance for any help you can provide.


    [KB968934.log]
    0.651: ================================================================================
    0.651: 2010/01/16 17:37:13.060 (local)
    0.651: d:\0d7eebb766afefb1aedf7c46cb11\update\update.exe (version 6.3.15.0)
    0.681: Hotfix started with following command line:
    0.732: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    1.002: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    1.002: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    1.002: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    1.062:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    1.072: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    1.072: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    1.092:  C:\WINDOWS\system32\netlogon.dll is Present
    1.162: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    1.162: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    1.162: Condition Check for Line 3 of PreRequisite returned FALSE
    1.182: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    1.182: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    1.242: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    1.242: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    106.604: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    106.604: User Input: OK
    106.604: Update.exe extended error code = 0xf0f4
    106.604: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    3.675: ================================================================================
    3.675: 2010/01/16 18:03:18.466 (local)
    3.685: d:\2f8814c6dfbec22952bc64751eaa77a2\update\update.exe (version 6.3.15.0)
    3.775: Hotfix started with following command line:
    6.169: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    6.920: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    6.920: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    6.920: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    6.940:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    6.950: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    6.950: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    6.950:  C:\WINDOWS\system32\netlogon.dll is Present
    7.080: FileVersion of C:\WINDOWS\system32\netlogon.dll is Greater or Equal To 5.2.3790.4482
    7.080: Condition succeeded for section Prereq.CheckDCLocatorQFEInstalled.Section in Line 3 of PreRequisite
    7.390:  C:\WINDOWS\Assembly\GAC_MSIL\System.DirectoryServices.AccountManagement\3.5.0.0__b77a5c561934e089\System.DirectoryServices.AccountManagement.dll is Present
    8.342: FileVersion of C:\WINDOWS\Assembly\GAC_MSIL\System.DirectoryServices.AccountManagement\3.5.0.0__b77a5c561934e089\System.DirectoryServices.AccountManagement.dll is Less Than 3.5.30729.4126
    8.342: Second Condition in Prereq.CheckSDSAMQFEInstalled.Section Failed
    8.342: Condition Check for Line 4 of PreRequisite returned FALSE
    8.352: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    8.352: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    8.422: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    8.422: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    16.143: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    16.143: User Input: OK
    16.143: Update.exe extended error code = 0xf0f4
    16.143: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    • Moved by Marco Shaw Sunday, January 17, 2010 11:54 AM wrong forum (From:Windows Server 2008 R2 Management)
    Sunday, January 17, 2010 12:18 AM

Answers

  • Hi,

    Please install the hotfix KB969166 and check if you can install ADMGS now.

    A hotfix rollup package for Active Directory Web Service is available for the .NET Framework 3.5 SP1
    http://support.microsoft.com/kb/969166

    Thanks.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Meinolf Weber Wednesday, January 20, 2010 9:09 PM
    • Marked as answer by LJRiveraSR Wednesday, January 20, 2010 10:18 PM
    Wednesday, January 20, 2010 3:52 AM
    Moderator
  • Hi,

    To use Windows Server 2008 R2 or Windows 7 client application such as the Active Directory module for Windows PowerShell or the Active Directory Administrative Center to access or manage directory service instances that are running on Windows Server 2008-based or Windows Server 2003-based computers, you can install the Active Directory Management Gateway Service. For more information, see What does the Active Directory Management Gateway Service do?

    In addition, you may also need to install the hotfix KB969429, in order that Windows 7 can locate the Active Directory Management Gateway service. 

    Windows 7 clients cannot locate the Active Directory Management Gateway service that is installed on Windows Server 2003-based domain controllers
    http://support.microsoft.com/kb/969429
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Meinolf Weber Wednesday, January 20, 2010 9:09 PM
    • Marked as answer by LJRiveraSR Wednesday, January 20, 2010 10:19 PM
    Tuesday, January 19, 2010 5:44 AM
    Moderator

All replies

  • Hi,

    To use Windows Server 2008 R2 or Windows 7 client application such as the Active Directory module for Windows PowerShell or the Active Directory Administrative Center to access or manage directory service instances that are running on Windows Server 2008-based or Windows Server 2003-based computers, you can install the Active Directory Management Gateway Service. For more information, see What does the Active Directory Management Gateway Service do?

    In addition, you may also need to install the hotfix KB969429, in order that Windows 7 can locate the Active Directory Management Gateway service. 

    Windows 7 clients cannot locate the Active Directory Management Gateway service that is installed on Windows Server 2003-based domain controllers
    http://support.microsoft.com/kb/969429
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Meinolf Weber Wednesday, January 20, 2010 9:09 PM
    • Marked as answer by LJRiveraSR Wednesday, January 20, 2010 10:19 PM
    Tuesday, January 19, 2010 5:44 AM
    Moderator
  • I've already attmepted all of this. The reason for the post is Active Directory Management Gateway Service will not install.

    I think I know why. The box I am running 2003 server on is a Pentium II. Possibly same reason I cannot install silverlight. No SSE instruction set?
    Tuesday, January 19, 2010 12:26 PM
  • Hi,

    Please install the hotfix KB969166 and check if you can install ADMGS now.

    A hotfix rollup package for Active Directory Web Service is available for the .NET Framework 3.5 SP1
    http://support.microsoft.com/kb/969166

    Thanks.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Meinolf Weber Wednesday, January 20, 2010 9:09 PM
    • Marked as answer by LJRiveraSR Wednesday, January 20, 2010 10:18 PM
    Wednesday, January 20, 2010 3:52 AM
    Moderator
  • Thank you Jason - Sorry, I replied in haste to your last post. Did notice the KB article number was different. All is well and I am now enjoying the new administrative tools....Thanks again!.
    Wednesday, January 20, 2010 12:02 PM
  • Glad that it works.

    Have a nice day.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, January 21, 2010 1:03 AM
    Moderator
  • I am having the same issue and have installed the hotfix KB969166. Here is the copy of the error log I get when attempting to install AWGS:

    [KB968934.log]
    0.078: ================================================================================
    0.078: 2010/02/02 10:26:49.836 (local)
    0.094: c:\251d1d890dd68535c298af3983c1\update\update.exe (version 6.3.15.0)
    0.094: Hotfix started with following command line:
    0.109: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.141: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.141: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.141: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.141:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is not Present
    0.141: Fist Condition in Prereq.CheckCLR.Section Failed
    0.141: Condition Check for Line 2 of PreRequisite returned FALSE
    0.141: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.156: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.641: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.641: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    90.641: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    90.641: User Input: OK
    90.641: Update.exe extended error code = 0xf0f4
    90.641: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.062: ================================================================================
    0.062: 2010/02/05 08:58:44.500 (local)
    0.062: c:\4ed2570295ca716c726b4919c4ae0f\update\update.exe (version 6.3.15.0)
    0.062: Hotfix started with following command line:
    0.062: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.109: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.109: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.109: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.109:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.109: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Less Than Specified Value
    0.109: Second Condition in Prereq.CheckCLR.Section Failed
    0.109: Condition Check for Line 2 of PreRequisite returned FALSE
    0.109: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.109: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.125: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.125: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.765: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.765: User Input: OK
    7.765: Update.exe extended error code = 0xf0f4
    7.765: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.031: ================================================================================
    0.031: 2010/02/05 09:02:02.890 (local)
    0.031: c:\d14fbec512d08ab27235\update\update.exe (version 6.3.15.0)
    0.031: Hotfix started with following command line:
    0.031: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.046: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.046: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.046: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.046:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.046: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Less Than Specified Value
    0.046: Second Condition in Prereq.CheckCLR.Section Failed
    0.046: Condition Check for Line 2 of PreRequisite returned FALSE
    0.062: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.062: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.062: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.062: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    28.750: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    28.750: User Input: OK
    28.750: Update.exe extended error code = 0xf0f4
    28.750: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.078: ================================================================================
    0.078: 2010/02/05 09:44:56.662 (local)
    0.078: c:\97a3532a3827cc7ab96ab9d0ef3f309c\update\update.exe (version 6.3.15.0)
    0.094: Hotfix started with following command line:
    0.094: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.125: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.125: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.125: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.125:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.125: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    0.125: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    0.125:  C:\WINDOWS\system32\netlogon.dll is Present
    0.125: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    0.125: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    0.125: Condition Check for Line 3 of PreRequisite returned FALSE
    0.141: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.141: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.141: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.141: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    9.359: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    9.359: User Input: OK
    9.359: Update.exe extended error code = 0xf0f4
    9.359: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.078: ================================================================================
    0.093: 2010/02/05 10:11:17.921 (local)
    0.093: c:\3c8ed213a8530cc14dca7e3062\update\update.exe (version 6.3.15.0)
    0.109: Hotfix started with following command line:
    0.109: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.156: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.156: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.156: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.156:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.156: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    0.156: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    0.156:  C:\WINDOWS\system32\netlogon.dll is Present
    0.156: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    0.156: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    0.156: Condition Check for Line 3 of PreRequisite returned FALSE
    0.156: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.156: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.672: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.672: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.218: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.218: User Input: OK
    7.218: Update.exe extended error code = 0xf0f4
    7.218: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.047: ================================================================================
    0.047: 2010/02/05 10:18:38.833 (local)
    0.047: c:\fc3b5f814b77142ca5cddbd3df\update\update.exe (version 6.3.15.0)
    0.047: Hotfix started with following command line:
    0.047: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.062: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.062: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.062: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.062:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.078: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    0.078: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    0.078:  C:\WINDOWS\system32\netlogon.dll is Present
    0.078: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    0.078: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    0.078: Condition Check for Line 3 of PreRequisite returned FALSE
    0.078: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.078: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.078: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.078: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    3.625: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    3.625: User Input: OK
    3.625: Update.exe extended error code = 0xf0f4
    3.625: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.079: ================================================================================
    0.079: 2010/02/05 10:26:57.505 (local)
    0.079: c:\abb2d8d70e100e3b9b48951c\update\update.exe (version 6.3.15.0)
    0.079: Hotfix started with following command line:
    0.079: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.110: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.110: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.110: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.110:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.110: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    0.110: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    0.110:  C:\WINDOWS\system32\netlogon.dll is Present
    0.110: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    0.110: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    0.110: Condition Check for Line 3 of PreRequisite returned FALSE
    0.110: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.110: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.125: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.125: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.625: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    7.625: User Input: OK
    7.625: Update.exe extended error code = 0xf0f4
    7.625: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.078: ================================================================================
    0.093: 2010/02/05 10:35:00.550 (local)
    0.093: c:\e789906fc99235197987dcd4b2ab3dc5\update\update.exe (version 6.3.15.0)
    0.093: Hotfix started with following command line:
    0.093: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    0.140: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    0.140: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    0.140: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    0.140:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    0.140: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    0.140: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    0.140:  C:\WINDOWS\system32\netlogon.dll is Present
    0.140: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    0.140: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    0.140: Condition Check for Line 3 of PreRequisite returned FALSE
    0.140: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.140: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    0.640: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    0.640: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    12.093: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    12.093: User Input: OK
    12.093: Update.exe extended error code = 0xf0f4
    12.093: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    Friday, February 05, 2010 4:38 PM
  • Hi,

    I have the same problem but I have already installed the hotfix KB969166. Here is the copy of the error log I get when attempting to install AWGS:


    [KB968934.log]
    1.953: ================================================================================
    1.953: 2010/02/09 17:01:45.286 (local)
    1.953: c:\8c510c657d36a5eb42b24047c9\update\update.exe (version 6.3.15.0)
    1.985: Hotfix started with following command line:
    2.094: In Function GetReleaseSet, line 1193, RegQueryValueEx failed with error 0x2
    2.657: SYSTEM\CurrentControlSet\Control\ProductOptions\ProductType is Equal To Specified Value
    2.672: First Condition in Prereq.CheckIfAnyInstanceRunning.Section Succeeded
    2.672: Condition succeeded for section Prereq.CheckIfAnyInstanceRunning.Section in Line 1 of PreRequisite
    2.688:  SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5 is Present
    2.688: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5\SP is Greater or Equal To Specified Value
    2.688: Condition succeeded for section Prereq.CheckCLR.Section in Line 2 of PreRequisite
    2.688:  C:\WINDOWS\system32\netlogon.dll is Present
    3.047: FileVersion of C:\WINDOWS\system32\netlogon.dll is Less Than 5.2.3790.4482
    3.047: Second Condition in Prereq.CheckDCLocatorQFEInstalled.Section Failed
    3.047: Condition Check for Line 3 of PreRequisite returned FALSE
    3.047: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    3.047: KB968934 Setup encountered an error:  Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    3.110: ReadStringFromInf: UpdSpGetLineText failed: 0xe0000102
    3.110: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    5.813: Message displayed to the user: Setup cannot continue because one or more prerequisites required to install KB968934 failed. For More details check the Log File c:\windows\KB968934.log
    5.813: User Input: OK
    5.813: Update.exe extended error code = 0xf0f4
    5.813: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    Tuesday, February 09, 2010 5:21 PM
  • You need to apply the .NET Framework 3.5 SP1 update rollup.  The same issue happens on Windows 2008 SP2.  This ADWS update isn't included in Windows 2008 SP2 as it is indicated on the download page.  I tried to install the update and told me it wasn't applicable.  I saw this post and downloaded the .NET Framework 3.5 SP1 update rollup per the:

    "Hi,

    Please install the hotfix KB969166 and check if you can install ADMGS now.

    A hotfix rollup package for Active Directory Web Service is available for the .NET Framework 3.5 SP1
    http://support.microsoft.com/kb/969166

    Thanks."

    This allowed me install the ADWS update to my Windows 2008 SP2 box.

    Unbelievable that MS won't put any type of "you may need this update prior to install" included on the download page.
    Wednesday, February 17, 2010 3:14 PM
  • Hi,

    I've already install the hotfix and restarted the dc but I still get the error.
    The florest and the domain are in 2003 mode and there are no Windows 2008 or 2008 r2 DC.

    Thanks
    Friday, February 19, 2010 12:26 PM
  • Install this hotfix as well. It replaces netlogon.dll with the correct version. ADWS will then install.

     

    http://support.microsoft.com/kb/969429

     

    look at the top of this article for the link to request the hotfix.

    • Proposed as answer by brian310207 Tuesday, April 03, 2012 3:49 PM
    Friday, January 28, 2011 3:10 AM
  • Thanks, this worked for me
    Monday, October 13, 2014 10:04 AM