none
LAN Driver for Windows Server 2008 R2 on Intel DH67BL Motherboard

    Question

  • Hi All,

    I cant install LAN Driver for Windows Server 2008 R2 on Intel DH67BL Motherboard.

    Any known fix?

    Thanks

    Tuesday, December 20, 2011 2:42 AM

Answers

  • Thanks for replies.

    We found the fix.

    With the bundled Driver DVD

    Copy the contents of DVD to desktop and edit

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

     

    ++++++++++++++++++++++++++++++++++++++++++++++++++

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502


    +++++++++++++++++++++++++++++++++++++++++++++++++++

    remove entries from ExcludeFromSelect
    and copy

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    to entries in [Intel.NTamd64.6.1]

    +++++++++++++++++++++++++++++++++++++++++++++++++++

    Saving the .inf file should be like this:

     

    [ControlFlags]
    ExcludeFromSelect =


    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    ************************************************************************

    Reinstall the LAN driver pointing to the edited installer files in desktop

    Thanks

     

     


    • Marked as answer by MGerio Tuesday, December 20, 2011 6:08 AM
    • Edited by MGerio Monday, October 01, 2012 6:22 AM
    Tuesday, December 20, 2011 6:08 AM

All replies

  • Hi,

     

    Based on my research, there is no drivers for Windows Server 2008 R2 with that motherboard. However, there are drivers for 64bit of Windows 7. You can try to install it on Windows Server 2008 R2.

     

    Note: There is no guarantee that the driver will work. If it doesn’t work, please contact Intel.

     

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20679&lang=eng&OSVersion=Windows%207%20(64-bit)*&DownloadType=Drivers

     

    Important Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

     

     

    Best Regards,

    Vincent Hu

     

     

    Tuesday, December 20, 2011 4:18 AM
    Moderator
  • Thanks for replies.

    We found the fix.

    With the bundled Driver DVD

    Copy the contents of DVD to desktop and edit

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

     

    ++++++++++++++++++++++++++++++++++++++++++++++++++

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502


    +++++++++++++++++++++++++++++++++++++++++++++++++++

    remove entries from ExcludeFromSelect
    and copy

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    to entries in [Intel.NTamd64.6.1]

    +++++++++++++++++++++++++++++++++++++++++++++++++++

    Saving the .inf file should be like this:

     

    [ControlFlags]
    ExcludeFromSelect =


    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    ************************************************************************

    Reinstall the LAN driver pointing to the edited installer files in desktop

    Thanks

     

     


    • Marked as answer by MGerio Tuesday, December 20, 2011 6:08 AM
    • Edited by MGerio Monday, October 01, 2012 6:22 AM
    Tuesday, December 20, 2011 6:08 AM
  • Perfect, solve my problem! Very Good.

    Thak You!


    Profissional 4 Estrelas Microsoft - Em busca da Certificação para 5ª estrela - http://www.wansecurity.com.br

    • Proposed as answer by clbadmin Tuesday, August 06, 2013 11:44 AM
    Wednesday, March 21, 2012 5:15 PM
  • Fixed, thank you for your help.

    Wednesday, May 23, 2012 7:10 AM
  • Glad it worked for you too.  :)

    Tuesday, May 29, 2012 8:09 AM
  • Thank you so much MGerio. With the above change we able to install the LAN drivers on 2008 R2. Thank you.
    Friday, June 08, 2012 3:15 PM
  • You're welcome Khadar.

    Monday, June 11, 2012 1:51 AM
  • MGerio:

    Thanks for the Solution it also worked with Intel Desktopboard DH67CL

    I do not understand why Intel do not Support Intel Desktop Boards with Drivers for Windows 2008 Server.

    Not everyone is a Millionarie to buy a Server Board.

    Kilo Films

    Saturday, June 16, 2012 10:59 PM
  • Great!  :)

    Friday, June 22, 2012 8:07 AM
  • Just want to say many many and many thanks. Great job!
    Sunday, September 30, 2012 4:43 PM
  • You're welcome DUC
    Monday, October 01, 2012 6:21 AM
  • MGerio,i had the same board gh67cl,but i cant install the lan driver.so how do u do it bro?
    Sunday, October 07, 2012 3:52 AM
  • MGerio,i had the same board gh67cl,but i cant install the lan driver.so how do u do it bro?

    @micrologixz

    I think same process worked for kilofilm with GH67cl board

    please try.
    Monday, October 08, 2012 12:08 AM
  • You are Great Man.... It works :)
    Saturday, October 13, 2012 7:22 PM
  • Thanks.  This also worked on a ASUS-motherboard with the same onboard Intel-chip.

    O.J.

    Wednesday, October 24, 2012 7:07 AM
  • Hi,

    Thanks.This also helped me. However i want know as found this solution.How do you discovered that? There are same way of make work on any desktop board?

    Excuse-me I'm studying english now!


    Vencedores não nascem... ...Eles são feitos! (desconhecido)

    Saturday, October 27, 2012 2:01 PM
  • Hi,

    It didn't worked for me..

    I did exact steps.. 

    Motherboard - Intel DH67BL

    OS - Microsoft Windows Server 2008 Ent.

    Am i missing something?

    Here is the edited file:

    [ControlFlags]
    ExcludeFromSelect = 

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00011179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503&SUBSYS_00021179

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00011179
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502&SUBSYS_00021179
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    Please help me..

    Thanx

    Tanmay Chandorkar.


    Tanmay K. Chandorkar, MCTS. System Administrator. WIS.

    • Proposed as answer by izuware Friday, August 02, 2013 12:09 PM
    Saturday, October 27, 2012 3:18 PM
  • can you check if you are editing the proper .inf file?

    Should be in this location:

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

    Monday, October 29, 2012 1:27 AM
  • @anderson.. please check the device hardware ID
    Monday, October 29, 2012 1:37 AM
  • Thanks a lottttt MGerio....:)

    Venkat

    Saturday, November 03, 2012 6:25 AM
  • Thanks for replies.

    We found the fix.

    With the bundled Driver DVD

    Copy the contents of DVD to desktop and edit

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

     

    ++++++++++++++++++++++++++++++++++++++++++++++++++

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502


    +++++++++++++++++++++++++++++++++++++++++++++++++++

    remove entries from ExcludeFromSelect
    and copy

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    to entries in [Intel.NTamd64.6.1]

    +++++++++++++++++++++++++++++++++++++++++++++++++++

    Saving the .inf file should be like this:

     

    [ControlFlags]
    ExcludeFromSelect =


    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    ************************************************************************

    Reinstall the LAN driver pointing to the edited installer files in desktop

    Thanks

     

     


    Obrigado. Funcionou pra mim. minha placa mãe é  Intel DH61CR. Obrigodo, thanks
    Tuesday, November 13, 2012 6:49 PM
  • GREAT, WORKED, MANY THANKS

    Wednesday, January 16, 2013 10:18 AM
  • look here it the most helpful you can get

    http://sysadmin.magnix.nl/?p=67

    Wednesday, February 20, 2013 11:27 AM
  • Thanks! It`s worked on Asus P8Z77-V Motherboard.
    Saturday, March 16, 2013 1:32 PM
  • Worked Just fine on INTEL DH77EB with Windows 2008 R2 Enterprise.

    Cheerz from Rio de Janeiro / Brazil

    Wednesday, June 12, 2013 2:27 PM
  • Thanks for replies.

    We found the fix.

    With the bundled Driver DVD

    Copy the contents of DVD to desktop and edit

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

     

    ++++++++++++++++++++++++++++++++++++++++++++++++++

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502


    +++++++++++++++++++++++++++++++++++++++++++++++++++

    remove entries from ExcludeFromSelect
    and copy

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    to entries in [Intel.NTamd64.6.1]

    +++++++++++++++++++++++++++++++++++++++++++++++++++

    Saving the .inf file should be like this:

     

    [ControlFlags]
    ExcludeFromSelect =


    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    ************************************************************************

    Reinstall the LAN driver pointing to the edited installer files in desktop

    Thanks

     

     


    [Manufacturer]
    %Intel%     = Intel, NTamd64.6.1, NTamd64.6.1.1, NTamd64.6.2

    [ControlFlags]
    ExcludeFromSelect = 

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1, PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.2]

    Plz help, not work on GA H87D3H

    Monday, December 30, 2013 1:47 PM
  • Thanks for replies.

    We found the fix.

    With the bundled Driver DVD

    Copy the contents of DVD to desktop and edit

    \Software\Drivers\LAN\PRO1000\Winx64\NDIS62\e1c62x64.inf

     

    ++++++++++++++++++++++++++++++++++++++++++++++++++

     

    [ControlFlags]
    ExcludeFromSelect = \
        PCI\VEN_8086&DEV_1502,\
        PCI\VEN_8086&DEV_1503

    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502


    +++++++++++++++++++++++++++++++++++++++++++++++++++

    remove entries from ExcludeFromSelect
    and copy

    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    to entries in [Intel.NTamd64.6.1]

    +++++++++++++++++++++++++++++++++++++++++++++++++++

    Saving the .inf file should be like this:

     

    [ControlFlags]
    ExcludeFromSelect =


    [Intel]

    [Intel.NTamd64.6.1.1]
    ; DisplayName                   Section              DeviceID
    ; -----------                   -------              --------
    %E1502NC.DeviceDesc%            = E1502.6.1.1,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    [Intel.NTamd64.6.1]
    ; DisplayName                   Section        DeviceID
    ; -----------                   -------        --------
    %E1502NC.DeviceDesc%            = E1502,       PCI\VEN_8086&DEV_1502
    %E1503NC.DeviceDesc%            = E1503.6.1.1,       PCI\VEN_8086&DEV_1503

    ************************************************************************

    Reinstall the LAN driver pointing to the edited installer files in desktop

    Thanks

     

     


    And how about Windows server 2012 ? How to install driver for it?
    Thursday, January 23, 2014 7:10 PM
  • I found this and it worked for my 2012 installation. http://randelhall.blogspot.com/2012/12/installing-2012-server-on-intel-dh67cl.html
    Thursday, May 01, 2014 3:52 PM
  • Hi

    would you like to explain more?

    how can we install this inf file?


    Arvind

    Monday, August 25, 2014 11:14 AM
  • Thank you..!!!
    Monday, October 06, 2014 6:54 PM
  • Thanks for the solution, it work for me.
    Wednesday, October 21, 2015 8:01 AM