none
Taking ownership of TPM ! TakeOwnership' failed (2150121473)_Facing issue when upgrading win 7 systems to win 10 RRS feed

  • Question

  • Hi all,

    Facing a very strange issue of bitlocker ,It only happening with window 7 systems which are migrating to window 10, in the window 10 systems we are not facing such issues , TS failed after the window setup step completed and it try to encrypt the drive with bitlocker . As a troubleshooting steps we just tried to clear the TPM from bios, updated the bios version and checked TPM is activate in BIOS

    Below is the error  :

    Command line: "OSDOfflineBitlocker.exe" /enable /drive:C: /ignoretpm:True /full:False OSDOfflineBitLocker 9/15/2019 10:54:56 PM 1276 (0x04FC)
    Initializing TPM... OSDOfflineBitLocker 9/15/2019 10:54:56 PM 1276 (0x04FC)
    Creating TPM owner authorization value OSDOfflineBitLocker 9/15/2019 10:54:56 PM 1276 (0x04FC)
    Taking ownership of TPM OSDOfflineBitLocker 9/15/2019 10:54:56 PM 1276 (0x04FC)
    'TakeOwnership' failed (2150121473) OSDOfflineBitLocker 9/15/2019 10:54:57 PM 1276 (0x04FC)
    Failed to take ownership of TPM. Ensure that Active Directory permissions are properly configured
    An internal error has occurred within the Trusted Platform Module support program. (Error: 80284001; Source: Windows) OSDOfflineBitLocker 9/15/2019 10:54:57 PM 1276 (0x04FC)
    TPM is not found or not enabled. Ignore this action. OSDOfflineBitLocker 9/15/2019 10:54:57 PM 1276 (0x04FC)
    Process completed with exit code 0 TSManager 9/15/2019 10:54:57 PM 2172 (0x087C)

     

    Monday, September 16, 2019 12:20 PM

Answers

  • The issue is resolved , there was a option in the TPM BIOS " key storage Enable" after i asked the user to check that option and deploy he was able to deploy all 4 machines successfully .
    • Marked as answer by Arunrana5050 Tuesday, September 17, 2019 1:57 PM
    Tuesday, September 17, 2019 1:57 PM

All replies

  • TPM is not found or not enabled.

    You can't take ownership of something that doesn't exist or isn't enabled.

    What version of ConfigMgr are you running, what version of WinPE are your boot images based on, and what version of the COnfigMgr client is in the boot images?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Monday, September 16, 2019 2:04 PM
  • Well there is TPM option in the bios , i have checked it and its 2.0 , we are using Sccm 1902 version  and 1901.1 is boot images version and we are using mdt

    boot image OS version 10.0.17763.1 
    SCCM Client version 5.00.8692.1509

    i attached  the screenshot of the bios also 


    • Edited by Arunrana5050 Monday, September 16, 2019 5:12 PM update
    Monday, September 16, 2019 5:10 PM
  • I m adding the SS of the TS :

    Monday, September 16, 2019 8:24 PM
  • Monday, September 16, 2019 8:25 PM
  • Monday, September 16, 2019 8:25 PM
  • SCCM Client version 5.00.8692.1509

    That's still from ConfigMgr 1806. You should update your boot images with the latest ConfigMgr binaries. See https://docs.microsoft.com/en-us/sccm/osd/get-started/manage-boot-images#update-distribution-points-with-the-boot-image for details.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, September 17, 2019 2:58 AM
  • Hi,

    1.Here are some articles for your reference:
    WINDOWS 7 UNKNOWN DEVICE TPM 2.0 COMPATIBILITY ISSUE
    PSA: Don't use TPM 2.0 on Dell Skylake generation devices
    Installing Bitlocker on Windows 7 with TPM version 2.0 chip

    2. Right-click the default boot images and then check the box "Reload this boot image with the current Windows PE version from the Windows ADK" to update boot images. 

    Thanks for your time.

    Best regards,
    Simon Ren

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 17, 2019 3:56 AM
  • The issue is resolved , there was a option in the TPM BIOS " key storage Enable" after i asked the user to check that option and deploy he was able to deploy all 4 machines successfully .
    • Marked as answer by Arunrana5050 Tuesday, September 17, 2019 1:57 PM
    Tuesday, September 17, 2019 1:57 PM
  • Hi,
     
    Thanks for your sharing. This may help the users who have similar issue. Thank you!
     
    Thanks and regards,
    Simon 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 18, 2019 1:45 AM
  • Hi,

    Thanks for posting in TechNet. Here is a simple summary of this thread:

    Issue Symptom:
    TS failed after the window setup step completed with the error: 'TakeOwnership' failed (2150121473)

    Solution:
    Enable the TPM BIOS " key storage Enable"

    Reference Links:
    How to detect, suspend, and re-enable BitLocker during a Task Sequence

    Thanks and regards,
    Simon

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 27, 2019 9:31 AM