none
Permissions Issue RRS feed

  • Question

  •  Hi,

    We are using windows server 2008 OS and Visual studio 2008. When user trying drag and drop .dll files in c:\windows\assembly folder we gets "Assembly cache viewer- install failed" Access is Denied: 'FileName.dll'.

    User in Local administrator group. I knew this definately a some permissions issue. i.e user need to have permission to update the GAC...not having admin permissions. How I can give permission to user.



    Can you pls help us.

    Thanks in Advance,

    Srini


    Sree
    Wednesday, August 20, 2008 2:26 PM

Answers

  •  

    Hi,

     

    Windows server 2008 introduces new feature UAC (User Access Control) to protect OS from being attacked. Under UAC, accounts in the local Administrators group have two access tokens, one with standard user privileges and one with administrator privileges. Normally, the administrator runs under the standard user privileges unless we explicitly promote it. Please try the following steps to test the result:

     

    1. Replace the Administrators group that is granted access permission on the folder or file with a manually created group or user.

     

    2. Temporarily disable UAC.

     

    The following group policy in the [Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options] branch controls the UAC behavior.

     

    User Account Control: Allow Approval Mode for the Built-in Administrator account

     

    default setting: Disable

     

    This means the local Administrator account will be always run with full administrative privilege.

     

    User Account Control: Behavior of the elevation prompt for administrators in Approval Mode

     

    default setting: Prompt to consent

     

    More information about UAC, please refer to:

     

    How to use User Account Control (UAC) in Windows Vista

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922708

     

    Let me know the results.

    Thursday, August 21, 2008 8:51 AM
    Moderator

All replies

  •  

    Hi,

     

    Windows server 2008 introduces new feature UAC (User Access Control) to protect OS from being attacked. Under UAC, accounts in the local Administrators group have two access tokens, one with standard user privileges and one with administrator privileges. Normally, the administrator runs under the standard user privileges unless we explicitly promote it. Please try the following steps to test the result:

     

    1. Replace the Administrators group that is granted access permission on the folder or file with a manually created group or user.

     

    2. Temporarily disable UAC.

     

    The following group policy in the [Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options] branch controls the UAC behavior.

     

    User Account Control: Allow Approval Mode for the Built-in Administrator account

     

    default setting: Disable

     

    This means the local Administrator account will be always run with full administrative privilege.

     

    User Account Control: Behavior of the elevation prompt for administrators in Approval Mode

     

    default setting: Prompt to consent

     

    More information about UAC, please refer to:

     

    How to use User Account Control (UAC) in Windows Vista

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;922708

     

    Let me know the results.

    Thursday, August 21, 2008 8:51 AM
    Moderator
  • Is there any way to resolve this without resorting to temporarily disabling UAC?
    Tuesday, June 29, 2010 12:10 AM
  • I was facing the same problem, for the user I am using I just grant him security permission on the containing folder, its not copying dlls to GAC normally :) enjoy
    Sunday, November 11, 2012 12:10 PM