none
Problems remotely managing the Virtual Disk Service on Windows 2008 Core. RRS feed

  • Question

  • Greetings.

    I have created a new Windows Server 2008 Core Enterprise Edition server, that I am going to use with Hyper-V to run a couple of test servers (hopefully I will be able to make them production once Hyper-V is RTM'ed).

    I have been able to change its IP, join it to the domain. I have enabled all remote management in the firewall. Using another Windows Server 2008, I am able to use a domain account to connect to the Core server with Computer Manager and the Firewall MMC as well. I even got the read-only Device Manager to work.

    The only thing I seem to be unable to do in Computer Manager is use the Disk Management section. Every time I try, I get the pop-up error "The RPC server is unavailable".

    I made sure the Virtual Disk Service is started, and set to automatic. I have even gone so far as to turn the firewall off completely on the Core server just to remove that as a potential issue, which did not help.

     

    The only clue I seem to have is that I have the following event log entry on the server:

    Log Name:      System

    Source:        storflt

    Date:          3/7/2008 8:44:29 AM

    Event ID:      5

    Task Category: None

    Level:         Warning

    Keywords:      Classic

    User:          N/A

    Computer:      HOSVMSERVER.sheehans.org

    Description:

    The Virtual Storage Filter Driver is disabled through the registry. It is inactive for all disk drives.

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="storflt" />

        <EventID Qualifiers="32774">5</EventID>

        <Level>3</Level>

        <Task>0</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2008-03-07T13:44:29.684Z" />

        <EventRecordID>541</EventRecordID>

        <Channel>System</Channel>

        <Computer>HOSVMSERVER.sheehans.org</Computer>

        <Security />

      </System>

      <EventData>

        <Data>

        </Data>

     

    <Binary>00000000010000000000000005000680000000000000000000000000000000000000000000000000</

    Binary>

      </EventData>

    </Event>

     

    Has anyone run into this before?

     

    I am running this server on a system with an Intel ICH9R RAID controller. I have 4 disks in a RAID 1+0 configuration. Thinking it might be a driver issue, I have tried the current publicly available driver/chipset pack from Intel (from late 2007), and a pre-release pack to see if that had anything to do with this error.

    Nothing seems to make the error go away.

     

    I would really like to get the remote disk management piece working so I can carve up the RAID 1+0. Also it would be nice to have a machine where I didn't have any errors in the logs (warnings or not) before I started using it.

     

    Thanks!
    Saturday, March 8, 2008 3:51 AM

Answers

  • Hi,

     

    I don't know if the error is related. I do know that you have to open the disk management firewall ports on both boxes, the one being managed and the one you are managing from. So you either have to open the ports on both boxes or disable the firewall on both boxes. If either box has the ports closed it won't work.

     

    Andrew

     

    Monday, March 10, 2008 11:50 PM
  • Sigh...I was focusing on Remote Administration and not additional firewall rules.

    Ok - the rules required for this are:

    Remote Volume Management - Virtual Disk Service (RPC)

    Remote Volume Management - Virtual Disk Service Loader (RPC)

    Once I enabled these on both the source and target servers, I was FINALLY able to connect to the core server.

     

    So thank you for pointing me in the right direction. It's VERY non-intuitive that I would need to enable the inbound rule on the source server, and not just the target server (the core server).

     

    I found I didn't need to load the Remote Volume Management (RPC-EPMAP) inbound firewall rule to get this to work.

     

    Wednesday, April 9, 2008 3:04 AM

All replies

  • Hi,

     

    For the Disk Management MMC, you also have to open the firewall port on the Server performing the remote management. It sounds like you had the Server Core firewall configured correctly, use the Firewall MMC on the full server installation to open the disk management ports and it should work fine.

     

    Andrew

     

    Monday, March 10, 2008 4:43 PM
  • AFAIK I configured the firewall correctly because every other function works just fine. Even turning the firewall off completely (just for testing) didn't seem to change anything.

     

    Has anyone else seen or know about the error I posted just on the off chance that the two issues are related?

     

    Monday, March 10, 2008 6:30 PM
  • Hi,

     

    I don't know if the error is related. I do know that you have to open the disk management firewall ports on both boxes, the one being managed and the one you are managing from. So you either have to open the ports on both boxes or disable the firewall on both boxes. If either box has the ports closed it won't work.

     

    Andrew

     

    Monday, March 10, 2008 11:50 PM
  • I have enabled the remote management rules in the windows firewall on the core server which allows me to remotely manage every function except for the disk management.

    I have even turned off the firewall completely, and that did not help.

     

    So something is causing a communication issue between the two nodes on the same LAN. At this point I have to assume it is the virtual disk service since the firewall is off.

     

    Is anyone able to get the remote disk management to work? If so are you seeing the error in your system log I posted?

     

    FYI I finally gave up and just used DISKPART locally to format the additional drive space I needed, but I would still like to get this ironed out.

    Friday, March 14, 2008 11:40 AM
  • Hi,

     

    You need to also open the Disk Management firewall ports on the computer running the Disk Management MMC. For Disk Management the firewall must be opened on both sides.

     

    I have this working, it is just a matter of start VDS and opening the ports on both computers.

     

    Andrew

     

    Saturday, March 15, 2008 4:31 AM
  • Thank you Andrew for stating this elusive but simple configuration change.  All the documentation I've read is entirely focused on configuring the Core Server but neglects that the remote client needs attention too.  Now I am able to access Device Manager in addition to the ability of Disk Management access and is a great bonus discovery.  This concludes all my major Core setup pain points and I'll move on to discovering less obvious ones such as fixing my Hyper-V virtual network adapters, event log information ...etc.  You've been a tremendous help to me and thank you very much.

     

    Tuesday, April 1, 2008 1:15 AM
  • Sorry for not catching the fact you said firewall settings on both servers the first time. Sad

     

    I have run the command "set rule group="remote administration" new enable=yes" succesfully on both nodes under the NETSH ADVFIREWALL FIREWALL section. It enabled the 3 roles succesfully on both nodes.

    I run NET START "virtual disk" as per http://support.microsoft.com/kb/948275 on the Core server (if I start it through the remote Computer Manager I seem to get the error described in the KB article).

    I can see the virtual disk service starting on the Core server, and then stopping a few seconds later.

     

    No matter what I do, I still get the error about the Logical Disk Manager "The RPC server is unavailable".

     

    Any ideas what else I can do to try and get this remote management of the Core server's disks working?

     

    Wednesday, April 9, 2008 2:45 AM
  • Sigh...I was focusing on Remote Administration and not additional firewall rules.

    Ok - the rules required for this are:

    Remote Volume Management - Virtual Disk Service (RPC)

    Remote Volume Management - Virtual Disk Service Loader (RPC)

    Once I enabled these on both the source and target servers, I was FINALLY able to connect to the core server.

     

    So thank you for pointing me in the right direction. It's VERY non-intuitive that I would need to enable the inbound rule on the source server, and not just the target server (the core server).

     

    I found I didn't need to load the Remote Volume Management (RPC-EPMAP) inbound firewall rule to get this to work.

     

    Wednesday, April 9, 2008 3:04 AM
  • Besides the previous entries for the firewall (client/server), give these steps a try as well:

    To manage a server running a Server Core installation by using a terminal server client:

    1. On the server running a Server Core installation, type the following command at a command prompt:

          cscript C:\Windows\System32\Scregedit.wsf /ar 0

    This enables the Remote Desktop for Administration mode to accept connections.

    BTW, in order to view your current settings you can type:

          cscript C:\Windows\System32\Scregedit.wsf /ar /v


    If you see "1" in the script output, that means that RDP connections are denied. If you see a "0", they will be allowed.

    Note: If you are running the Terminal Services client on a previous version of Windows, you must turn off the higher security level that is set by default in Windows Server 2008. To do this, type the following command at the command prompt:

          cscript C:\Windows\System32\Scregedit.wsf /cs 0

    To enable remote management from an RDP connection through the firewall

    1. To enable remote management from any MMC snap-in, type the following:

          netsh advfirewall firewall set rule group="Remote Desktop" new enable=yes (you may have already done this step)

    To open an RDP session with the Server Core machine

    1. On the remote management computer, click Start > Run, type mstsc, and then click OK.
          
    2. In Computer, enter the name of the server running a Server Core installation, and click Connect.
          
    3. Log on using an administrator account.

    4. When the command prompt appears, you can manage the computer using the Windows command-line tools.

          Note that while you're logged on to the server, the original server console session is locked out.

    5. When you have finished remotely managing the computer, type logoff in the command prompt to end your Terminal Server session.

    Also, from the command line of the Server Core box, type: c:\windows\system32\cscript scregedit.wsf /cli   for a listing of all the command line references.

    Hope this helps.

    ***Please note that this information was provided by the following in assisting me***
    http://www.petri.co.il/managing-windows-2008-server-core-rdp.htm
    and
    http://blogs.microsoft.co.il/blogs/guyt/archive/2006/10/24/Server-Core-_2D00_-first-steps.aspx

    Two excellent blogs if you do not know about them...

    Cheers,
    John
    Wednesday, June 25, 2008 10:37 PM
  • I had an issue with hyper-v VHDs today. found the solution here
    Tuesday, July 15, 2008 9:29 PM
  • I had to disable the firewall temporarily at the remote server using the command below, in order to manage the disks remotely

     Netsh advfirewall set allprofiles state off

    • Proposed as answer by mhRabie Tuesday, June 30, 2009 3:46 PM
    Tuesday, June 30, 2009 3:44 PM
  • Hi can you clearly tell me how to enable that rules ?
    Tuesday, April 17, 2012 11:39 AM
  • When i'm trying this from another Win2008R2 machine, i can connect to the disk management WITHOUT having the firewall rules enabled. When using Win7 i do have to enable them on the source machine. Any ideas?
    Wednesday, January 30, 2013 9:48 PM
  • Completing your aswer of our friends 

    You can run following command:

    netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes

    Source http://www.thomasmaurer.ch/2010/12/remote-disk-management-with-rpc-server-is-unavailable-error/

    Good luck! =)

    Derik Yuri Maia


    Friday, March 22, 2013 11:58 AM