Hyper-V integration services (kvp daemon) on Win10 with Linux 4.9 guest? RRS feed

  • Question

  • Originally posted in the hyper-v forum, was directed here.


    I've been tearing my hair out.

    I'm trying to get a VM with a recent Linux kernel running on my fully updated Windows 10 machine as a host.

    Most things work, but I can't get the KVP daemon to function. It's running on the guest, but the host shows "No Contact" as its status description.

    Specifically, I'm having trouble with kernel 4.9. Using the default kernel from debian-jessie (3.16) works fine.

    Here's what I've tried:

    1. Installing a standard install of Debian Jessie (kernel 3.16), plus the hyperv-daemons package - works
    2. Installing linux-image and hyperv-daemons from jessie-backports (both kernel version 4.9) - does not work
    3. Installing Arch Linux with kernel 4.9 and hv_kvm_daemon manually compiled from hv_kvm_daemon.c in the kernel sources - does not work.

    In all of the above cases the hv_* kernel modules are loaded, and hv_kvm_daemon is running.

    Here's what my linux guest says:

    # lsmod | grep hv
    hv_utils               24576  0
    hv_balloon             24576  0
    hv_netvsc              40960  0
    hv_storvsc             20480  0
    scsi_transport_fc      49152  1 hv_storvsc
    scsi_mod              159744  4 sd_mod,hv_storvsc,sr_mod,scsi_transport_fc
    hv_vmbus               57344  7 hv_storvsc,hv_utils,hid_hyperv,hv_balloon,h _netvsc,hyperv_keyboard,hyperv_fb
    # ps aux | grep kvp
    root      51825  0.0  0.0   4820    68 ?        Ss   09:05   0:00 /usr/sbin/hv_kvp_daemon
    # journalctl -f
    Mar 07 09:05:07 hvtest KVP[51825]: KVP starting; pid is:51825
    Mar 07 09:05:07 hvtest KVP[51825]: KVP LIC Version: 3.1

    Here's what my Windows host says:

    PS C:\WINDOWS\system32> Get-VMIntegrationService "hvtest"
    VMName Name                    Enabled PrimaryStatusDescription SecondaryStatusDescription
    ------ ----                    ------- ------------------------ --------------------------
    hvtest Guest Service Interface True    OK
    hvtest Heartbeat               True    OK
    hvtest Key-Value Pair Exchange True    No Contact
    hvtest Shutdown                True    OK
    hvtest Time Synchronization    False   OK
    hvtest VSS                     True    OK                       The protocol version of the component ins...

    I've tried both gen1 and gen2 VMs, and that doesn't make a difference.

    I'm not sure what else to try. Has anyone else had issues (or success?) with Kernel 4.9 and Win10 as a host.

    I don't have easy access to a Windows Server machine that isn't already a VM to test this with, to see if it's localised to Windows 10 or a more general issue.

    Any ideas?

    Wednesday, March 8, 2017 8:55 AM

All replies

  • We encountered some problems with 4.10 out of the box. The stable update for 4.10.2 has some patches that were submitted to stable that may help with your problem. I haven't seen 4.10.2 get published yet, but it's in final review last I checked.

    When it comes to 4.9, though, we did not have any trouble, and many of the Linux distributions have updated to this level of Hyper-V support without incident.

    Josh Poulson Program Manager, Linux Integration Services, Enterprise Open Source Group Microsoft

    Friday, March 10, 2017 10:30 PM
  • Any suggestion on things I could try, other than those I've already listed? If 4.9 works for other people then I don't see why it wouldn't work for me (unless perhaps there's a difference between how Hyper-V works on Win10 vs SomeOtherHost.)

    I reproduced this both with 4.9 from debian-jessie backports and an Arch live environment, and neither worked for me.

    Looks like 10.2 was released yesterday so I'll give that a go, but it would be good to know if there's something else I might be doing wrong. I'm not all that experienced with Hyper-V.


    Monday, March 13, 2017 2:49 PM
  • Is there any update on this topic? I have the same problem, my Debian 9 with 4.9.0-4 has the same effect. Kernel 3.16.0-4 works without any problems in the same system configuration.
    Friday, December 8, 2017 4:06 PM