none
Network Discovery keeps turning itself back OFF ???

    Question

  • I am not sure if this is the correct forum to ask this question but MS said sounds more like a networking issue so I will post it here.

    I am running a new Win 2008 r2 server as a Domain Controller in Hyper-V.  The system is running smoothly.

    The problem: 
    When I turn ON Network Discovery in "Change Advanced Sharing Settings", when I go back to check it it will be OFF. Network Discovery is turned ON inside the Firewall settings, Allow a program or feature through the Windows Firewall.
    What could be causing this?  Why would it show ON in one place and OFF in another?  Which one takes precedence?  thanks - tom
    Wednesday, May 11, 2011 1:18 PM

Answers

  • Hi,

    Thanks for the post.

    This issue will occur if the dependency services are disabled. Please make sure the following services are enabled and running.

    -      DNS Client

    -      Function Discovery Resource Publication

    -      SSDP Discovery

    -      UPnP Device Host

    Hope this helps.

    Miles

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 12, 2011 3:57 AM
    Moderator
  • Hi Poly,

     

    Function Discovery Resource Publication should be manual. Anyway try the following steps

    1. Enable file sharing as shown in below link

    2. make sure you can ping public domain name like yahoo.com

    3. Also make sure client for networks and file and print sharing are enabled on TCP properties

    4. disable third party Antivirus and security solution for time being and check the network discovery

    5. Make sure ssdp discovery and Upnp are manual and started.

     

    Thanks

    uday


    Thursday, May 26, 2011 1:21 PM

All replies

  • Hi,

    Thanks for the post.

    This issue will occur if the dependency services are disabled. Please make sure the following services are enabled and running.

    -      DNS Client

    -      Function Discovery Resource Publication

    -      SSDP Discovery

    -      UPnP Device Host

    Hope this helps.

    Miles

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 12, 2011 3:57 AM
    Moderator
  • Thanks for the reply.
    Ok.  Here are my current settings and my followup question.

    DNS Client     -     Started
    Function Discovery Resource Publication     -     Not started
    SSDP Discovery     -     Not started
    UPnP Device Host     -     Not started

    My question is:  Inside the firewall settings, under "Allow a Program of Feature through the firewall" I have Network Discovery Enabled for Domain, Home, and Public.  But it is still disabled under "Change Advanced Sharing Settings".  Is Network Discovery enabled or not?  Which setting takes precedence, the settings inside the firewall or the setting inside of "Change Advanced Sharing Settings?"

    I will now proceed to enable these services that you have brought to my attention and see if I am able to "turn ON" Network Discover under Change Advanced Sharing Settings.  I will repost afterwards.  thanks again.

    Thursday, May 12, 2011 4:25 PM
  • I went one by one turning on the services that you listed and after turning on each one I went into "Change Advanced Sharing Settings" and turned on Network Discovery then went back in to check to see if it turned back OFF again. 

    It kept turning back OFF until I got to the last one and started it.  After starting all services it will now stay ON in "Change Advanced Sharing Settings".  I still don't understand why/how it showed ON in the firewall and OFF in "Change Advanced Sharing Settings".

    1- Should I set these services to start automatically upon boot? 
    2- Is there a good reason these services should be left OFF? 
    3- Do these services need to be on on other Windows 2008 servers?

    thanks - awaiting your reply

    • Proposed as answer by FlatspinZA Saturday, January 18, 2014 6:42 PM
    Thursday, May 12, 2011 6:22 PM
  • Hi,

    Thanks for the post.

    Please make sure that the startup type of the following three services could be set to Manual. And these service should be logged on with Local Service account.

    Function Discovery Resource Publication    

    SSDP Discovery    

    UPnP Device Host    

    Hope this helps.

    Miles


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 13, 2011 3:38 AM
    Moderator
  • But if they are set to "manual", they won't start and "Network Discovery" will not be ON.  I don't understand.
    Friday, May 13, 2011 12:36 PM
  • MZ-

    can you reply to my last post concerning these services? 

    Monday, May 16, 2011 12:40 PM
  • Hi Poly,

     

    Function Discovery Resource Publication should be manual. Anyway try the following steps

    1. Enable file sharing as shown in below link

    2. make sure you can ping public domain name like yahoo.com

    3. Also make sure client for networks and file and print sharing are enabled on TCP properties

    4. disable third party Antivirus and security solution for time being and check the network discovery

    5. Make sure ssdp discovery and Upnp are manual and started.

     

    Thanks

    uday


    Thursday, May 26, 2011 1:21 PM
  • If you are SBS 2011, check your browser service as well and make sure it is not disabled.  It needs to be set to automatic.  You can map in SBS but  you can't "network discovery" as I understand it... could be wrong, not sure.
    R, J
    • Proposed as answer by FlatspinZA Saturday, January 18, 2014 6:45 PM
    Sunday, June 12, 2011 8:01 PM
  • thanks..it worked after turning on Function Discovery Resource Publication
    Saturday, July 14, 2012 6:17 AM
  • oddly that seems to work although why would this not automatically work?  Seems this is a Windows bug in networking that needs addressed so that checking the radio button to turn on network discovery either prompts you to change the services as above manually or that it makes these changes programatically itself

    Dale Unroe

    Thursday, October 11, 2012 9:11 PM
  • same observed as above on 2x newly created Windows 2008R2 Standard servers ...fully patched

    Dale Unroe

    Thursday, October 11, 2012 9:13 PM
  • This was great help. Thank you very much. Exactly what I needed.
    Monday, November 26, 2012 6:54 AM
  • Udav, what you posted is completely useless. 
    • Edited by f-ms Monday, December 10, 2012 9:03 PM
    Monday, December 10, 2012 9:00 PM
  • thanks man you helped me out alot

    Tuesday, December 18, 2012 1:31 AM
  • where is the link?
    Wednesday, December 19, 2012 11:55 PM
  • Not as completely useless as your post.  You should learn some manors.

    Friday, June 28, 2013 4:25 PM
  • Hi Miles,

    I also was had a problem with not being able to access my files on my laptop, but thanks to your advice it all works alright now.

    The Blue Baron

    Friday, July 05, 2013 7:29 PM
  • So all of these are enabled and running, and I still cannot keep Network discovery on. When I click it, the windows box pops up making sure I give permission, I do, then it turns on and literally right back off again. So frustrating.
    Tuesday, July 30, 2013 1:44 AM
  • Also have this on and enabled and it will NOT stay on.
    Tuesday, July 30, 2013 1:45 AM
  • The firewall setting only "allows" it to pass through.  It is not a statement if the service is actually on or off.
    Saturday, August 17, 2013 6:08 PM
  • I've just had the same problem and found that all my firewall rules were deleted, don't know how that happened, separate issue,  but hitting reset settings worked for me. 
    Thursday, September 12, 2013 2:25 PM
  • Same problem.

    I did nothing, Windows 7 did an Automatic update, come in Monday, turn on the machine and no network sharing.  Just turns itself off all the time after I try to turn it on. 

    The Local FireWall does the same, can't turn it off (I can on Public Networks), this seems just Stupid as Public is more dangerous.

    This seems like stupid Windows bugs again.

    Monday, November 18, 2013 10:25 AM
  • Enabling 'Device Association service' did it for me
    Sunday, February 16, 2014 4:31 AM