none
Internet Explorer Proxy Exceptions not working

    Question

  • I created a GPO for a group of users that sets a web proxy server for them to connect to, and a list of exceptions to bypass use of the proxy.

    When I log on as a test user, I am indeed connected to the web proxy, but the sites I specified in GPO as exceptions are not in the list of exceptions. The list of exceptions is blank. Why won't the exceptions work?

    Here is my GPO:

    User Configuration --> Policies --> Windows Settings --> Internet Explorer Maintenance --> Connection --> Proxy settings: Checked "Enabled proxy settings", typed in the address of proxy and the port, checked the "Use the same proxy server for all addresses" box, added the exception sites in the Exception textfield, and checked "Do not use proxy server for local (intranet) addresses" box.

     

    What am I doing wrong?

     

    P.S. We are using Internet Explorer 8, and I can tell by looking at proxy server logs that the exceptions are not working.


    • Edited by uchelp Wednesday, October 19, 2011 6:23 PM
    Wednesday, October 19, 2011 6:07 PM

Answers

  • Hi,

    Please run GPRESULT/Z to make sure that the GPO has been applied to the test user. Please also post more information here for further research.

    1. Where the GPO linked to? Whether all users in the linked OU have this issue?

    2. Open GPMC, use the Group Policy Results Wizard and follow the steps to check out whether the policy could be applied to the test user.

    Best Regards,

    Yan Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 20, 2011 5:35 AM
    Moderator
  • After gpresult /z

    pls check with 32 bit computer and 32 bit ie,64 bit computer and 32 bit ie , 64 computer and 64 bit.

    Also check xp,win7 and post us the result.

    Pls check the below key in your local computers where gpo has been applied.

    Set Proxy Exceptions
    Hive: HKEY_CURRENT_USER
    Key: Software\Microsoft\Windows\CurrentVersion\Internet Settings
    Name: ProxyOverride
    Data Type: Reg_SZ
    Value: *.microsoft.com;*.myitforum.com

    Above key should be present in registry. I have checked with 32 ie and 32 bit computer. If you will be checked 64 bit computer but 32 bit ie , that key might be different.


    Best regards Biswajit Biswas Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, MCTS, Enterprise Admin

    Thursday, October 20, 2011 6:52 AM

All replies

  • Hi,

    Please run GPRESULT/Z to make sure that the GPO has been applied to the test user. Please also post more information here for further research.

    1. Where the GPO linked to? Whether all users in the linked OU have this issue?

    2. Open GPMC, use the Group Policy Results Wizard and follow the steps to check out whether the policy could be applied to the test user.

    Best Regards,

    Yan Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 20, 2011 5:35 AM
    Moderator
  • After gpresult /z

    pls check with 32 bit computer and 32 bit ie,64 bit computer and 32 bit ie , 64 computer and 64 bit.

    Also check xp,win7 and post us the result.

    Pls check the below key in your local computers where gpo has been applied.

    Set Proxy Exceptions
    Hive: HKEY_CURRENT_USER
    Key: Software\Microsoft\Windows\CurrentVersion\Internet Settings
    Name: ProxyOverride
    Data Type: Reg_SZ
    Value: *.microsoft.com;*.myitforum.com

    Above key should be present in registry. I have checked with 32 ie and 32 bit computer. If you will be checked 64 bit computer but 32 bit ie , that key might be different.


    Best regards Biswajit Biswas Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, MCTS, Enterprise Admin

    Thursday, October 20, 2011 6:52 AM


  • We have a similar situation in which Windows 7 x64 sp1 workstations deployed within the last few weeks are not completely processing our proxy server settings, specifically the proxy exceptions list. New XP deployments and previously deployed Win7 boxes also work fine.

    I've not encountered a situation where a policy was partially applied and am at somewhat of a loss as to how to determine the cause of the issue. The proxy config seems to be the only GPO setting that isn't applying properly.

    I inherited Group Policy administration for workstations but the GPO used to configure proxy server settings has been in place for years and working fine until recently with problems only for Win7 PCs.

    Proxy settings: User Configuration | Windows Settings | Connection | Proxy Settings
    - Enable proxy settings = server & port for all protocols
    - Exceptions = *.domain.com,*.corp.domain.com, etc.
    - Loopback (merge) enabled
    - Scope = Authenticated Users (Security Filtering)

    Problem workstations do not have the ProxyOverride registry value properly populated (value is <local>).

    A gpupdate /force seems to populate the exceptions list properly. Of course, none of the techs reporting the problem have gathered any useful information and have all manually added the exception list into Internet settings foregoing gpupdate (and then complaining about the image build). I've solicited their assistance for capturing event logs and rsop reports but thought it wise to ask the experts here on the forum.

    What might cause policies to be partially applied?
    Is there something unique about proxy settings that could cause this behavior?
    Any suggestions as to how to approach remediating the situation?

    To reiterate: GPO has been in place and properly functioning for years, Windows 7 x64 image build has been successfully deployed for months, proxy exception list issues apparently started appearing mid-to-late October. Gpupdate /force resolves proxy exception list issue.

    Thanks in advance for any insight you might be able to provide.

    ~ JC

     

    Monday, November 14, 2011 10:39 PM
  • Finally resolved the issue.

    There apparently is a bug in the IEAK wizard which writes a proxy section to the Install.ins file even when selecting the 'Do not customize...' option for the Connection page in the wizard. This causes the proxy server settings to be overwritten (cleared) for each new user profile on a target machine.

    The Install.ins file must be edited PRIOR to completing the wizard.

    1. Run IEAK 9 wizard and configure desired options
    2. Stop at the last screen ('Wizard Complete')
    3. Edit the Install.ins file, deleting the entire [Proxy] section
     - <local path>\INS\AMD64_WIN7\ENU\Install.ins
    4. Return to wizard and complete installation package creation
    5. Copy <local path>\FLAT\AMD64_WIN7\ENU\IE9-Setup-Full.msi to network location
    6. Install from network location

    You'll need to run through the IEAK wizard and edit the Install.ins file for each architecture. After installation, the Install.ins file is found at %ProgramFiles(x86)%\Internet Explorer\Custom. This file is used to configure IE for each new user profile.

    Hope this helps someone in the future.

    • Proposed as answer by JC Warren Monday, November 21, 2011 8:52 PM
    Monday, November 21, 2011 8:52 PM
  • Hi I've got a similar problem on our network.

    Our DC's are Server 2003 boxes and I don't think we can install the IEAK9 Wizard on them. Can someone confirm this and if so are there any other options?

    Monday, August 20, 2012 3:25 PM