none
RDP connection issues RRS feed

  • Question

  • Dear all,

    I am getting strange issue when i am connecting to my Active directory domain and additional domain controller.

    When i try to conect the above said servers through RDP, getting the following error

    "This computer can't connect to the remote computer" try again.

    1) i am not using remote desktop services, i am just using the two rdp session which comes with server

    2) disabled firewall and antivirus too.

    3) no group policy set.

    4) i can connect other servers with out any issues.

    Please help me in this regards.


    Monday, July 27, 2015 6:39 AM

Answers

  • Configure Network Level Authentication
    1. Click Start, click Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click Security Packages, and then click Modify.
    4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
    5. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
    6. In the details pane, right-click SecurityProviders, and then click Modify.
    7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
    8. Exit Registry Editor.
    9. Restart the computer.

    This worked for me.

    SecurityProviders key got missed in my registry, created and added "credssp.dll" as value and worked. Thanks.

    • Marked as answer by chandut Monday, July 27, 2015 2:12 PM
    Monday, July 27, 2015 2:12 PM

All replies

  • Hi,

    Please try this. 

    1. Logon to the server locally
    2. Click Start, Run, type "tscc.msc /s" (without quotation marks) and click OK
    3. In the Terminal Services Configuration snap-in double-click Connections, then RDP-Tcp in the right pane
    4. Click the Network Adapter tab, select the correct network adapter and click OK
    5. Make sure that you can establish an RDP connection to the server

           No need for a restart.

    Thanks


    Best Regards, Anuja

    Monday, July 27, 2015 6:45 AM
  • Hi

     Please logon server locally and check is "Network Level Authentication enabled"

    Open Remote settings -,remote if NLA is enabled and you can use you need to add the users on select users tab,if you don't use NLA just uncheck.

    Monday, July 27, 2015 6:55 AM
  • Dear Anujaa,


    tried, getting this problem.

    i am not using any remote Desktop services or terminal services, i am just using the RDP session which come with OS.

    thanks

    chandra

    Monday, July 27, 2015 6:57 AM
  • Dear Anujaa,

    Tried by unchecking NLA and enabling NLA, added user, but doesn't work.Please let me know what else i can check.

    thanks

    chandra.

    Monday, July 27, 2015 7:13 AM
  • Hi

     First check ip settings of Server,run "ipconfig /all" and paste here we can check.And also make sure you can able to Access this server.

    On a client ping the server,then run on cmd "telnet serverip 3389"

    Monday, July 27, 2015 7:31 AM
  • DEar Burak,

    Please find the attached screenshot for ipconfig and telnet

    Monday, July 27, 2015 8:22 AM
  • https://onedrive.live.com/redir?resid=E66D08A537E716A3!21629&authkey=!AOWOPp7umuhmZe4&v=3&ithint=photo%2cpng
    Monday, July 27, 2015 8:24 AM
  • Hi

     The pic's not shown,please paste that on one drive;

    https://onedrive.live.com/

    Monday, July 27, 2015 8:25 AM
  • hi,

    Please find the snapshots in the following link.

    https://onedrive.live.com/redir?resid=E66D08A537E716A3!21629&authkey=!AOWOPp7umuhmZe4&v=3&ithint=photo%2cpng

    Monday, July 27, 2015 8:37 AM
  • Hi

     On screen shoot "DNS :::1 " it is point to ipv6,you need to configure the prefered to ipv4,please configure the binding and network provider order,check this article how to;

    https://technet.microsoft.com/en-us/library/cc732472(v=ws.10).aspx

    Monday, July 27, 2015 8:45 AM
  • Hi,

    Tried, still same issue.

    Monday, July 27, 2015 9:13 AM
  • Configure Network Level Authentication
    1. Click Start, click Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click Security Packages, and then click Modify.
    4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
    5. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
    6. In the details pane, right-click SecurityProviders, and then click Modify.
    7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
    8. Exit Registry Editor.
    9. Restart the computer.

    This worked for me.

    SecurityProviders key got missed in my registry, created and added "credssp.dll" as value and worked. Thanks.

    • Marked as answer by chandut Monday, July 27, 2015 2:12 PM
    Monday, July 27, 2015 2:12 PM
  • Hi,

    Glad to hear that you have found the solution and thank you for sharing with us!

    You solution is very beneficial to others who have similar issues.

    In addition, here is the link for Remote Desktop (Terminal) Services forum below for you if there are any RDS related queries in the future.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserverTS

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 28, 2015 6:49 AM
    Moderator