none
After windows 10 anniversary update none of my save RDP connections work anymore RRS feed

  • Question

  • I just updated yesterday my Windows 10 to windows 10 anniversary update and today when I want to access my Azure machine via remote desktop, none of my RDP files launches the RDP tool.

    It works if I manually add and launch them from the remote desktop manager tool, but the standard RDP does not work anymore. It seems the association between RDP files and the RDP tool does not work.

    Basically when I click on my RDP files, nothing happens. 

    Ideas?

    Wednesday, August 3, 2016 1:23 PM

Answers

  • *******************************************************************
    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.


    Microsoft still needs to address this bug.  RDP Files do not run with custom display font scaling.

    Thursday, August 4, 2016 3:32 PM
  • This bug is known and will be fixed in a forthcoming update. In the interim, disabling custom scaling will help to work around the issue.

    -Elton (MSFT)

    Tuesday, August 16, 2016 7:01 AM
  • It will eventually be fixed in a cumulative update.  I heard maybe the next one.

    WORKING FIX

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    Don't use custom font scaling - just use the slider.


    Microsoft still needs to address this bug.  RDP Files do not run with custom display font scaling.


    Wednesday, August 24, 2016 12:58 PM
  • Release Preview 14393.103 has fixed this for me.

    Thank you!


    -- SvenC

    • Proposed as answer by EinmalIM Friday, August 26, 2016 5:19 AM
    • Marked as answer by Amy Wang_Moderator Wednesday, September 7, 2016 9:45 AM
    Friday, August 26, 2016 5:19 AM

All replies

  • I have the same issue.  After the Windows 10 Anniversary Update was installed on my Windows 10 Pro, .RDP files won't open. Remote Desktop still works if you open it manually and enter in the server info. But my saved .RDP files won't open. Also, right clicking on them and selecting edit also does not work. Nothing happens. I even opened Remote Desktop connection, entered in the server info manually and clicked Save As. That shortcut also won't work.

    I'm still investigating the issue to determine if it's a feature removed from Windows Pro (like many others - thanks MS!) or another issue.   FYI, you can edit the .rdp file with notepad to view your connection info.

    Wednesday, August 3, 2016 4:24 PM
  • Same issue here. Windows 10 Enterprise 64 Version 1607 14393.10. Also cannot get UDP to work (there is no "UDP is used" message under Connection Info rods, on server there is "set to TCP (no UDP packet received)" in Event Log. Also it is not prompting for credentials as usual in some cases. Also in cmd "mstsc /?" does nothing (on previous version it displayed message box with help on switches).
    Wednesday, August 3, 2016 5:06 PM
  • Wednesday, August 3, 2016 6:22 PM
  • The weird thing is that when I clear the 'recent list', and connect with a new RDP session then it does get added to the list, but clicking on it to launch it does absolutely nothing.

    Parameter support is also broken, to the point where you can not even do mstsc /? anymore to find out what the options available are.

    It is supposed to show:

    The params I use a lot are /w: /h: and /v: to create desktop shortcuts to my favorite RDP sessions.


    • Edited by RoChess Wednesday, August 3, 2016 8:02 PM fix image
    Wednesday, August 3, 2016 8:01 PM
  • I have confirmation that this is an upgrade bug.

    Nope. Did fresh install on formatted drive. I think it is not update bug, but mstsc.exe from 1607 (in its current state) bug.

    It appears that starting RDP, then hitting "Load" and loading *.rdp file works (with consistent parameters from file).

    Wednesday, August 3, 2016 9:30 PM
  • Thanks for the update. 
    Wednesday, August 3, 2016 9:47 PM
  • I confirm this behavior. After anniversary update mstsc /? (or any other parameter) does not work anymore, so cannot use RemoteApps.

    But this problem is only with one user. If I login to the computer with another user, every parameter works as expected.

    The user has a roaming profile and the problem follows with the profile to another computer. But if this same user logins to a computer with local profile only, everything works.

    Thursday, August 4, 2016 2:16 PM
  • *******************************************************************
    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.


    Microsoft still needs to address this bug.  RDP Files do not run with custom display font scaling.

    Thursday, August 4, 2016 3:32 PM
  • Lol! Just wanted to write the same thing. You were first! When I set Control Panel -> Display -> Set a custom scale factor -> 150%+ *.rdp files magically start to work!
    • Proposed as answer by jmustonen Thursday, August 4, 2016 6:52 PM
    Thursday, August 4, 2016 5:31 PM
  • Yes, confirmed solution! Removing custom settings and using scale factor from slider, RDP works!

    But this is still a bug in Anniversary update, because custom scale used to work. I confirmed this by returning to original build and everything worked. Updated back to Anniversary and no go, until removing custom scalings!

    Big thanks to INTREPID-5th and the_95_vibe for guiding to the right direction.

    Thursday, August 4, 2016 6:51 PM
  • Hi,

    Glad to hear that a solution has been found and thank you for sharing it with the forum community members!

    Best Regards,

    Amy


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 5, 2016 11:41 AM
    Moderator
  • Hi,

    Glad to hear that a solution has been found and thank you for sharing it with the forum community members!

    Best Regards,

    Amy


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Amy,

    Will you be reporting this bug to Microsoft?

    Regards,

    Marc
    Monday, August 15, 2016 2:20 AM
  • This bug is known and will be fixed in a forthcoming update. In the interim, disabling custom scaling will help to work around the issue.

    -Elton (MSFT)

    Tuesday, August 16, 2016 7:01 AM
  • Thanks, that did the trick for me. All of my RDP shortcuts are now working.
    Wednesday, August 24, 2016 11:29 AM
  • Any ETA for that fix?

    Quite annoying, especially when accessing Azure VMs which you do by downloading and opening rdp files.

    Always have to open them in an editor and extract IP and port...


    -- SvenC

    Wednesday, August 24, 2016 12:23 PM
  • It will eventually be fixed in a cumulative update.  I heard maybe the next one.

    WORKING FIX

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    Don't use custom font scaling - just use the slider.


    Microsoft still needs to address this bug.  RDP Files do not run with custom display font scaling.


    Wednesday, August 24, 2016 12:58 PM
  • Release Preview 14393.103 has fixed this for me.

    Thank you!


    -- SvenC

    • Proposed as answer by EinmalIM Friday, August 26, 2016 5:19 AM
    • Marked as answer by Amy Wang_Moderator Wednesday, September 7, 2016 9:45 AM
    Friday, August 26, 2016 5:19 AM
  • Thank you, thank you, thank you. I had just upgraded a client's computer to the Anniversary Update and the last thing she wanted to check was her ability to connect to her office remotely. But it just wouldn't work.

    You simple solution worked wonders. I can't thank you enough -- and neither can my client who thought I was a genius to figure this out .... until I revealed that you provided the solution.

    Tuesday, August 30, 2016 12:02 AM
  • Hi Elton,

    Can you tel us in which update this bug will be fixed?

    Regards

    Friday, November 25, 2016 4:08 PM
  • It is fixed since 14393.103

    -- SvenC

    Friday, November 25, 2016 4:12 PM