none
Remote Desktop Connection Manager can only open 6 sessions at a time on Server 2012

    Question

  • I am only able to open, and view thumbnails, for a maximum of 6 RDP sessions on my Server 2012 box at a time in Remote Desktop Connection Manager (RDCM). If I add more sessions I just get a variety of connection errors for the additional sessions. If I activate a 7th session one of the existing 6 sessions goes off-line with a connection error message. Sometimes the error says 3334, sometimes the error says 0x8345000E, and sometimes it just says there is a connection error.

    I have checked Group Policy on the server to ensure I don't have any settings restricting the number of RDP sessions.

    In fact, I will often have 30 or 40 RDP simultaneous sessions opened, I am just not able to view them all in RDCM. I have seen reviews of RDCM with screenshots showing dozens of thumbnails so it seems to be something that's possible to do.

    Are there any settings I should make on the server to allow RDCM to connect to more than 6 simultaneous RDP sessions?

    Just to be clear, all these RDP sessions are running on the same server. Also, I am just using the trial license for Server 2012 and Remote Desktop Services right now. I don't think that should have an impact, but I wanted to be thorough.

    Friday, November 16, 2012 9:12 PM

Answers

  • I have solved the problem! After a lot of dead ends I finally found that I could get as many thumb-nails working as I like with RDCM by setting Network DTC access to not require authentication under Component Services. You can access component services on Server 2012 using this command: dcomcnfg

    That said, I have found that it is just too slow to have more than 20 thumbnails running at a time. The refreshes are just too slow and bog RDCM down. However, having 20 thumbnails is a far sight better than the 6 I have been limited too!
    Tuesday, November 20, 2012 2:15 AM

All replies

  • Hello,

    I also use the Remote Desktop Connection Manager version 2.2 to RDP into my server. I do not have any issue opening more connections than the six you mention. There might be some other reason it is not working properly, but I believe it is not related to RDCM


    regards Robert Maijen

    Saturday, November 17, 2012 2:49 PM
  • Are there some settings I need to make on Server 2012 to allow more than 6 RDP sessions? I can easily run up to 50 simultaneous sessions (I haven't tried more), but I just can't view them all in RDCM. I have checked Remote Desktop Group Policy settings to ensure that no limits were in place.

    Is there something else I should check?

    Curiously, RDCM will actually connect to ALL my RDP sessions when I start it, but then it starts disconnecting from one session after another until only 6 active thumbnails are visible. The other RDP sessions are still running, they just aren't visible through RDCM.

    Saturday, November 17, 2012 7:53 PM
  • Hello,

    So it is not just RDCM that cannot connect but sessions are created but disconnected. Do you have GPO's applied for idle time?


    regards Robert Maijen

    Sunday, November 18, 2012 10:16 AM
  • It is just RDCM that seems to have a problem connecting to more than 6 sessions at a time. I have been able to open over 30 RDP sessions within a single RDP session (putting them all in mini windows) without any problem.I

    I do notice a lot of event ID 1104 ("The client failed to establish the multi-transport connection.") and event ID 1026 ("RDP ClientActiveX has been disconnected (Reason= 3334)") messages in the event viewer when I try and open up lots of simultaneous sessions with RDCM.

    I have left the GPO settings for idle not unconfigured.

    I was thinking that maybe this could have been an issue with using NIC teams, so I deleting my NIC team and am just using a single NIC now, but that hasn't helped.

    Sunday, November 18, 2012 8:33 PM
  • To give an update: I have disabled RemoteFX, lowered the color depth, and turned off compression in Group Policy. None of these tweaks have resolve the issue though. I still can only open 6 (or sometimes 7 or 8) simultaneous thumbnails in RDCM.
    Monday, November 19, 2012 5:17 PM
  • I have solved the problem! After a lot of dead ends I finally found that I could get as many thumb-nails working as I like with RDCM by setting Network DTC access to not require authentication under Component Services. You can access component services on Server 2012 using this command: dcomcnfg

    That said, I have found that it is just too slow to have more than 20 thumbnails running at a time. The refreshes are just too slow and bog RDCM down. However, having 20 thumbnails is a far sight better than the 6 I have been limited too!
    Tuesday, November 20, 2012 2:15 AM
  • Any chance you can explain the 'fix' a little more clearly?

    thanks,

    rich

    Wednesday, July 10, 2013 12:52 PM
  • Any chance you can explain the 'fix' a little more clearly?

    thanks,

    rich

    If I'm understanding the 'answer' post correctly, the solution would be to:

    1. On the system where you run RDCMan, Run "dcomcnfg.exe" 
    2. Expand Component Services, My Computer, Distributed Transaction Coordinator.
    3. Right click on "Local DTC" and select properties.
    4. Click the "Security" tab
    5. Check the "Network DTC Access" box.  
    6. Under "Transaction Manager Communication", select the "No Authentication Required" radio button.

    Unfortunately, this doesn't seem to have resolved the issue for me.  Perhaps I'm missing a part of the solution?

    I'm running RDCMan 2.2 on Windows 8.1 Pro.  

    Friday, November 01, 2013 2:28 PM
  • To disable an authentication isn't a sloution for me, but i' ve tested it and it doesn't work for me too.

    If the error 3334 appears i have to restart my RDCMan :/

    RDCMan 2.2 on Windows 8.1 Ent

    Monday, November 11, 2013 7:04 AM
  • I'd also like clarification on the exact steps you used to resolve this. I've fiddled around with the MSDTC settings, to no avail.

    Brian


    Brian Lalancette | MCTS, MOSS 2007 / SharePoint 2010 | Twitter: @brianlala | Blog: http://spinsiders.com/brianlala

    Monday, January 20, 2014 3:49 PM
  • ca we have a update on this

    its a long time we work on Windows 8.1 and rdcm never been updated and 6 session limit its very to low ?

    Monday, February 24, 2014 2:16 PM
  • This is kind of a me too reply.

    Since i upgraded to Windows 8.1 is could only open 7 simultanous sessions with RDCman 2.2

    I have not found the perfet solution but...

    The steps given by Gai jin above did improve my situation. With the following settings I am able to open 10 to 15 sessions.

    - DTC-Networkaccess enabled

    - Outgoing traffic allowed

    - Authentication not required (selected)

    (i have translated these from dutch so i am not sure that these are the precise texts you will see in English dialogs).

    Thursday, February 27, 2014 12:36 PM
  • thanks for this post! very helpful! 

    Thursday, March 06, 2014 6:32 PM
  • Any chance you can explain the 'fix' a little more clearly?

    thanks,

    rich

    If I'm understanding the 'answer' post correctly, the solution would be to:

    1. On the system where you run RDCMan, Run "dcomcnfg.exe" 
    2. Expand Component Services, My Computer, Distributed Transaction Coordinator.
    3. Right click on "Local DTC" and select properties.
    4. Click the "Security" tab
    5. Check the "Network DTC Access" box.  
    6. Under "Transaction Manager Communication", select the "No Authentication Required" radio button.

    Unfortunately, this doesn't seem to have resolved the issue for me.  Perhaps I'm missing a part of the solution?

    I'm running RDCMan 2.2 on Windows 8.1 Pro.  

    worked perfect!!! thanks!

    Thursday, March 06, 2014 6:33 PM
  • For what it's worth... Just returned from the SharePoint Conference, and I noticed one of the presenters (Neil Hodgkinson) was running an interesting "Remote Desktop Connection Manager 2.8" for his VMs... so perhaps there's hope of a new version soon?

    Brian


    Brian Lalancette | MCTS, MOSS 2007 / SharePoint 2010 | Twitter: @brianlala | Blog: http://spinsiders.com/brianlala

    Saturday, March 08, 2014 2:47 AM
  • This did not work for me either. I am running Windows 8.1 and I max out at 6 Server 2012 Sessions.
    Thursday, March 13, 2014 4:03 PM
  • I came across this thread on the forums for mRemoteNG.  The suggested workaround fixed my problem with RDCMan as well.  It's worth noting that I'm seeing RDCMan consume about 150MB per Windows 2012 session (vs 15MB for a 2008 R2 session).

    The proposed workaround is (replace mRemote.exe with RDCMan.exe):

    "The workaround must be to get your hand on Visual Studio, open the "Visual Studio Command Shell", cd to your mRemote directory, make a backup of your mRemote.exe then run "editbin /LARGEADDRESSAWARE mRemote.exe" and thats it! you can now open all the sessions your RAM allows you to"

    • Proposed as answer by EugenBerend Wednesday, March 19, 2014 7:08 AM
    Tuesday, March 18, 2014 1:28 PM
  • Hi B Webster,

    I had the same issue and "editbin /LARGEADDRESSAWARE rdcman.exe" works!

    Thank you for help.

    Wednesday, March 19, 2014 7:09 AM
  • Running this command in Visual Studio Command Prompt fixed my issue with Error 3334!

    editbin /LARGEADDRESSAWARE rdcman.exe

    I guess my only issue is that it maxes out my memory on my Windows 8.1 PC now but it is better then closing out RDCMan.

    Thanks B Webster!

    Tuesday, April 29, 2014 7:46 PM
  • Hi B Webster,

    I had the same issue and "editbin /LARGEADDRESSAWARE rdcman.exe" works!

    Thank you for help.

    yep, works for me too, thanks :)
    Monday, May 19, 2014 2:08 PM
  • Thanks !!! Works also for me. 
    Wednesday, May 28, 2014 6:53 AM
  • /LARGEADDRESSAWARE is a nice first step (it enables RDCMan to use 4 GB of virtual memory instead of being limited to 2 GB), but I got a bit further.

    Because RDCMan is a pure .NET application (and the Remote Desktop ActiveX control it uses is available both to 32-bit and to 64-bit processes), it could, in fact, run as a 64-bit process on 64-bit systems, which would effectively eliminate any memory limit. It runs as a 32-bit process by default only because the executable is marked so.

    Using the corflags utility I was able to switch RDCMan to 64-bit:

    corflags /32bitreq- RDCMan.exe

    in Visual Studio Command Prompt. To be precise: this switches the exe to "AnyCPU", so it will run as 32-bit on 32-bit OS and as 64-bit on 64-bit OS.

    As a quick test, I was able to connect to 25 servers and work without problems. VMMap showed that the application used 4.5 GB of virtual memory. For comparison, 32-bit RDCMan (with /LARGEADDRESSAWARE) started failing (error 3334) after opening 23 connections and maxing out its VM limit (4 GB), while also being noticeably slower than the 64-bit one in refreshing thumbnails.

    Note that BOTH modifications need to be performed, i.e.

    editbin /LARGEADDRESSAWARE RDCMan.exe
    corflags /32bitreq- RDCMan.exe

    HTH,
    Jakub Bereżański

    Friday, July 11, 2014 8:19 AM
  • The solution, that worked for me:

    http://shawn.meunier.com/?p=1#comment-43

    Thursday, September 04, 2014 8:55 AM
  • Thanks Jakub for "corflags" info.

    Unfortunatelly it doesn't work because running mRemoteNG.exe process in 64bit can't load MSTSC ActiveX component (referenced assemblies) because original files were assembled from 32bit dll [mstscax.dll]?

    Error message when making RDP connection:
    Could not load file or assembly 'Interop.MSTSCLib, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.

    I was able to create new AxInterop.MSTSCLib.dll and Interop.MSTSCLib.dll assemblies from 64bit dll version and now it works with "AnyCPU":-)
    http://www.filedropper.com/axinteropmstsclib-mremoteng

    Using AxImp.exe and TlbImp.exe didn't worked for me because it creates assemblies in wrong namespace "MSTSCLib" instead of "Interop.MSTSCLib" (AxImp.exe) and TlbImp.exe for changing namespace generated many "marshaled errors" so final .dll wasn't working.

    Adding MSTSCAX.dll reference in Visual Studio directly created correct and functional assemblies. Who don't know how to create 64bit compatible assemblies or don't have Visual Studio, feel free to check linked file.

    Hope it helps
    P.S. Sorry for possible technical misinterpretation, I am not programmer so creating new assemblies was trial-error process...

    • Edited by ExSport-CZ Friday, November 14, 2014 10:30 AM fixed not approved link
    Friday, November 14, 2014 10:09 AM
  • RDCMan 2.7 is now available for download:

    http://blogs.technet.com/b/rmilne/archive/2014/11/19/remote-desktop-connection-manager-download-rdcman-2-7.aspx


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, November 19, 2014 7:22 PM