none
Task Scheduler failed to start - Additional Data: Error Value: 2147943785 RRS feed

  • Question

  • Hi,

    Scheduled job failes with the below error message.

    "Task Scheduler failed to start "\<task.name>" task for user "<domain\username>". Additional Data: Error Value: 2147943785."

    Last logon Result;

    Logon failure:the user has not been granted requested logon type at thi computer. (0x80070569).

    Could any help me fix this.

    Thanks


    Mahesh

    Wednesday, April 4, 2012 5:12 PM

Answers

  • Hi

    This problem may occur if the task account doesn’t have "logon as a batch job" privilege. Click Start, type "gpedit.msc", try to configure the following policy:
    [Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment]
    -Log on as a batch job.

    Add the domain\username account and any others you may need.

    Retry the task.

    If you find you can't change the security options locally then there might be a group policy that is setting this at the domain or ou level.

    Cheers


    Douks

    Wednesday, April 4, 2012 5:41 PM
  • Hello,


    As some supplements to Douks's reply, I also found that this error might occur when the security policy settings prevent the user from logging on using a local user account.


    Open gpedit.msc, Admin tools -> Local Security Policy -> User rights Assignnment -> Allow Local login. Please add the account that you configured for the task. Please try and let us know the result.


    Thanks
    Zhang

    Thursday, April 5, 2012 3:41 AM
    Moderator

All replies

  • Hi

    This problem may occur if the task account doesn’t have "logon as a batch job" privilege. Click Start, type "gpedit.msc", try to configure the following policy:
    [Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment]
    -Log on as a batch job.

    Add the domain\username account and any others you may need.

    Retry the task.

    If you find you can't change the security options locally then there might be a group policy that is setting this at the domain or ou level.

    Cheers


    Douks

    Wednesday, April 4, 2012 5:41 PM
  • Hello,


    As some supplements to Douks's reply, I also found that this error might occur when the security policy settings prevent the user from logging on using a local user account.


    Open gpedit.msc, Admin tools -> Local Security Policy -> User rights Assignnment -> Allow Local login. Please add the account that you configured for the task. Please try and let us know the result.


    Thanks
    Zhang

    Thursday, April 5, 2012 3:41 AM
    Moderator
  • Thanks for your informartion @ Douks & Zhang

    I will try as you have mentioned and let you know the result

    Thanks in advance.


    Mahesh

    Thursday, April 5, 2012 6:07 AM
  • It worked like a charm..

    Thanks for both of your help :)


    Mahesh

    Wednesday, April 11, 2012 6:39 AM
  • hi to all,

    i have the same issue but i run it with enterprise admin user.i check "log on as batch job rights" and administrators are configured.need help,

    ty

    Julia

    Tuesday, June 19, 2012 12:37 PM
  • Quelques calculs pour obtenir l'erreur:
    2147943785 = 0x80070569
    -> 0x8007 : Partie "8007" du code identifie comme un code d'état de win32.
    -> 0x 0569 = 1385

    net helpmsg 1385 : "Logon failure: the user has not been granted the requested logon type at this computer." 
    Monday, November 25, 2013 2:45 PM
  • This solution is 20/8/2018 still working on sysback V8 and windows10, at my place!!

    Thanks a lot

    Monday, August 20, 2018 8:17 AM
  • This solution is 20/8/2018 still working on syncback (free) V8 and windows10, at my place!!

    Thanks a lot


    Monday, August 20, 2018 8:18 AM
  • Wow - who would have thought that a standard user account (non-admin) on Windows 10 could run the Task Scheduler management console and create scheduled tasks but not actually run any tasks! Rather than add this user or the standard "Users" group to the policy, I ended up adding the user to the "Backup Operators" group which is already listed in this "Log on as a batch job" policy.
    Saturday, January 25, 2020 1:19 AM