none
Hyper-v VSS Windows Backup question RRS feed

  • Question

  • Hi,

    I would appreciate some help for an issue with VSS - HyperV - WindowsBackup
    (WB).

    What happened:
    - Had 2 Hyper-v servers w2k8 with several VM's on them, backed-up with
    Windows Backup.
    - Updated all Hosts and VM's to W2k8-R2.
    - On 1 server WB runs fine.
    - On 1 server WB does not backup the volume containing the VM's, only if
    they are stopped, even so, in the Hyper-v console, the VSS shadow copies
    succedes.
    - The error is that the writer (hyper-v) cannot create the shadow copies.
    "The backup operation that started at '‎2009‎-‎08‎-‎24T10:01:21.706000000Z'
    has failed because the Volume Shadow Copy Service operation to create a
    shadow copy of the volumes being backed up failed with following error code
    '2155348129'. Please review the event details for a solution, and then rerun
    the backup operation once the issue is resolved." (there is no more
    detail.....)

    What I did:
    - Recreated all VM's by using the existing VHD's only.
    - Resinstalled Hyper-v
    - Tried to remove all shadow copies: "C:\>vssadmin delete shadows /All".
    Got :
    "vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Error: Snapshots were found, but they were outside of your allowed context.
    Try removing them with the backup application which created them."

    I'm stucked here....
    I do not know how to use WBadmin to remove the shadows nor if I'm on a good
    path to troubleshoot this.

    Thanks in advance.

    TMT.

    asc
    Wednesday, October 14, 2009 3:50 PM

Answers

  • Hi,

    I activated the "automount" option on the server where WB could not do the backup and that was it. Everything works just fine now and several dayly backups ran ok.
    What bothers me is the poor error handling by MS that made many people search for the solution for many weeks. That's a shame in the era of w2k8-r2!
    Thomas.
    asc
    Monday, October 19, 2009 5:52 AM
  • I also experienced this issue on a hardware server upgraded from Windows 2008 SP2 to R2.

    To clarify Thomas' posting, if you experience the unexpected WSB failure mentioned in the original post above, you activate the "automount" feature as follows:

    1. Open a Command Windows in elevated mode.

    2. At the command prompt, type MountVol /E, and then press ENTER.

     

    3. Reboot the server and run WSB again.  Now it should work.

    As an aside, before I began the upgrade, I had to remove the Hyper-V role in order to fully clear network teaming information on adapters, since I planed to re-arrange the NICs post-upgrade.  After upgrading, I installed updated NIC drivers and re-built the teams.  I was able to make a full WSB image before I re-installed the Hyper-V role, but not after - this was when I first got the error described above.  Moreover, when I attached a USB drive containing the VHDs I wanted to import, the disk would not mount because the "automount" feature had become disabled.  This was my first clue that there was an issue, which I did not realize at first, but in retrospect it clearly points it out.

    1010 Mancer
    MCITP-EA

    This thread also discusses the same issue:
    http://social.technet.microsoft.com/Forums/en/windowsserver2008r2management/thread/ac7c22a7-787c-4e6d-a8fd-a174583a4145

    Tuesday, January 5, 2010 6:57 PM

All replies

  • Hi,

     

    Updated all Hosts and VM's to W2k8-R2.

     

    >> Did you mean you upgrade the system from RTM to R2? If so, this is a know issue and our product group is working on this.

     

    By the way, we have a post discussed the similar issue, you can refer to:

     

    Backups fail with Volume Shadow Copy operation failure

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2management/thread/ac7c22a7-787c-4e6d-a8fd-a174583a4145

     

    Best Regards,

    Vincent Hu

     

    Thursday, October 15, 2009 9:49 AM
    Moderator
  • ·         Hi,

     

    Have you tried the suggestion? I want to see if the information provided was helpful. Your feedback is very useful for the further research. Please feel free to let me know if you have addition questions.

     

     

    Best regards,

    Vincent Hu

    Monday, October 19, 2009 2:53 AM
    Moderator
  • Hi,

    I activated the "automount" option on the server where WB could not do the backup and that was it. Everything works just fine now and several dayly backups ran ok.
    What bothers me is the poor error handling by MS that made many people search for the solution for many weeks. That's a shame in the era of w2k8-r2!
    Thomas.
    asc
    Monday, October 19, 2009 5:52 AM
  • I also experienced this issue on a hardware server upgraded from Windows 2008 SP2 to R2.

    To clarify Thomas' posting, if you experience the unexpected WSB failure mentioned in the original post above, you activate the "automount" feature as follows:

    1. Open a Command Windows in elevated mode.

    2. At the command prompt, type MountVol /E, and then press ENTER.

     

    3. Reboot the server and run WSB again.  Now it should work.

    As an aside, before I began the upgrade, I had to remove the Hyper-V role in order to fully clear network teaming information on adapters, since I planed to re-arrange the NICs post-upgrade.  After upgrading, I installed updated NIC drivers and re-built the teams.  I was able to make a full WSB image before I re-installed the Hyper-V role, but not after - this was when I first got the error described above.  Moreover, when I attached a USB drive containing the VHDs I wanted to import, the disk would not mount because the "automount" feature had become disabled.  This was my first clue that there was an issue, which I did not realize at first, but in retrospect it clearly points it out.

    1010 Mancer
    MCITP-EA

    This thread also discusses the same issue:
    http://social.technet.microsoft.com/Forums/en/windowsserver2008r2management/thread/ac7c22a7-787c-4e6d-a8fd-a174583a4145

    Tuesday, January 5, 2010 6:57 PM