none
Teamed NIC for Domain Controller... RRS feed

  • Question

  • We have teamed NIC for domain controller and during promotion it is asking for DHCP assigned addres. Though the teamed NIC have static IP assigned. We tried with disable all other NIC as well as by disabling the passive NIC . Can anyone please suggest for this issue.
    Tuesday, February 12, 2013 11:36 AM

Answers

  • NIC Teaming does not by Microsoft. Disable the NIC teaming.

    http://social.technet.microsoft.com/Forums/en/winserverDS/thread/f5dea401-5a3b-4ddb-8bb8-8d2b2e2db55b


    Regards
    Biswajit Biswas

    My Blogs|MCC |TNWiki Ninja

    Best regards Biswajit Biswas Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, MCTS, Enterprise Admin


    Tuesday, February 12, 2013 12:12 PM
  • Load balanced teamed NIC's are a bad practice for Domain Controllers, fault tolerant teamed NIC's should be fine.  I have confirmed this in the past with PSS.

    Are you saying you have a single NIC enabled on your box with a static IP address?  If not this is what is the normal practice for a DC, I would also make sure you uninstalled any teaming software and then rebooted the DC before pressing on.  There is plenty of poorly written teaming software out there and Microsoft has attempted to correct this with a new teaming feature in Server 2012.
    http://blogs.technet.com/b/privatecloud/archive/2012/06/19/nic-teaming-in-windows-server-2012-brings-simple-affordable-traffic-reliability-and-load-balancing-to-your-cloud-workloads.aspx

    My recommendation would not team, although as I said it is supported in a fault tolerant mode.

    -- 
    Paul Bergson
    MVP - Directory Services
    MCITP: Enterprise Administrator
    MCTS, MCT, MCSE, MCSA, Security+, BS CSci
    2008, Vista, 2003, 2000 (Early Achiever), NT4
    http://www.pbbergs.com    Twitter @pbbergs
    http://blogs.dirteam.com/blogs/paulbergson

    Please no e-mails, any questions should be posted in the NewsGroup. This posting is provided "AS IS" with no warranties, and confers no rights.


    Tuesday, February 12, 2013 12:58 PM
    Moderator

All replies

  • NIC Teaming does not by Microsoft. Disable the NIC teaming.

    http://social.technet.microsoft.com/Forums/en/winserverDS/thread/f5dea401-5a3b-4ddb-8bb8-8d2b2e2db55b


    Regards
    Biswajit Biswas

    My Blogs|MCC |TNWiki Ninja

    Best regards Biswajit Biswas Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, MCTS, Enterprise Admin


    Tuesday, February 12, 2013 12:12 PM
  • Load balanced teamed NIC's are a bad practice for Domain Controllers, fault tolerant teamed NIC's should be fine.  I have confirmed this in the past with PSS.

    Are you saying you have a single NIC enabled on your box with a static IP address?  If not this is what is the normal practice for a DC, I would also make sure you uninstalled any teaming software and then rebooted the DC before pressing on.  There is plenty of poorly written teaming software out there and Microsoft has attempted to correct this with a new teaming feature in Server 2012.
    http://blogs.technet.com/b/privatecloud/archive/2012/06/19/nic-teaming-in-windows-server-2012-brings-simple-affordable-traffic-reliability-and-load-balancing-to-your-cloud-workloads.aspx

    My recommendation would not team, although as I said it is supported in a fault tolerant mode.

    -- 
    Paul Bergson
    MVP - Directory Services
    MCITP: Enterprise Administrator
    MCTS, MCT, MCSE, MCSA, Security+, BS CSci
    2008, Vista, 2003, 2000 (Early Achiever), NT4
    http://www.pbbergs.com    Twitter @pbbergs
    http://blogs.dirteam.com/blogs/paulbergson

    Please no e-mails, any questions should be posted in the NewsGroup. This posting is provided "AS IS" with no warranties, and confers no rights.


    Tuesday, February 12, 2013 12:58 PM
    Moderator
  • Thank you Guys. Thank you pbbergs.

    Actually my intention was to use it for fault tolerence only .Though it was a demand from client side.

    I removed the IP addresses , dissolved the team and and disabled all other NICs which were not the part of team. Then I reassign the IP addresses to all teamed adapters. This time it worked fine. No Idea why it was not taking before.

    Regards,

    Wednesday, February 13, 2013 3:18 PM