2012 R2 RDS Temporary Profile issue RRS feed

  • Question

  • I have set up a standard 3 node 2012 R2 RDS for testing. All virtualized on VMware ESXi 5.0. I have a connection Broker, session host, and web access server. I have published several applications and I can access them without a problem. Here is my issue:

    When I try to log on to my session host server either locally or thru RDP, I am always logged in with a Temporary profile. It does not mater what user account I use. Even logging on locally as the administrator I get a temporary profile.

    All windows updates are installed and current.

    I have removed the server from the domain, deleted the account, and rejoined it to the domain.

    I have deleted all .bak registry entries from here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    There is a hotfix here for a similar issue on 2012 but it does not apply to 2012 R2

    The only event viewer errors are:

    1515 (Windows has backed up this user profile. Windows will automatically try to use the backup profile the next time this user logs on.)

    1511 (Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.)

    Any suggestions to resolve would be greatly appreciated.


    Monday, December 30, 2013 8:40 PM

All replies

  • Hi Russ,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Jeremy Wu

    TechNet Community Support

    Thursday, January 2, 2014 3:16 AM
  • Hi Russ,

    Did you configure ProfileDisks for the collection? If so, check access rights on the folder you defined for this.

    I know for a fact that a RemoteApp session collection cannot share profiledisks with a Remote Desktop session collection, so maybe there's a conflict in this somewhere?

    If you have not yet configured profile disks for the RemoteApp session collection, configure this. I think logging on locally or through RDP to the desktop will keep using local profiles, but not 100% sure.



    Thursday, January 2, 2014 9:37 AM
  • User Profile disks are configured and working properly. We are just using RemoteApp and not Remote Desktop sessions so there is not conflict there. The issue happens when logging directly into the Session Host server.


    Thursday, January 2, 2014 2:48 PM
  • the hotfix for windows server 2012 R2

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, January 3, 2014 8:30 AM
  • has not been published at the moment , you might be need wait for more while.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, January 3, 2014 8:31 AM
  • We got the same issue over here. Is the hotfix already published?
    Tuesday, January 14, 2014 10:55 AM
  • hi,

    i have same issue with RDS 2012 R2. Is there any hotfix published for temp profile?

    Tuesday, January 14, 2014 2:19 PM
  • I discovered yesterday that if I add my Session Host server to the Windows Authorization Access Group in Active Directory and reboot it resolves the issue. Here is what I did. Keep in mind I have a Domain Admin account and also a regular user account.

    1) Log on to the server as a Domain Admin

    2) Add my regular user account to the local admin group

    3) add the session host server to the Windows Authorization Access Group

    4) Reboot

    5) Log on to the session host server as my regular user account and delete my Domain Admin Profile

    6) Log off my regular user account and log on as my Domain Admin account (No temporary profile now)

    7) Delete the regular user account from the Local Administrator group.

    Hope this works for you.


    Tuesday, January 14, 2014 6:36 PM
  • I have the same problem with temp profiles, I have 5 servers setup right know, that will support 100 plus users.  The most I’ve had access my term farm is about 40 users and this problem was not fun.

    1st one is the termcontrol (was 2012 base, now 2012 r2) that i have setup for admin stuff.

    3 2012 base terms that are setup for session base hosting and web access.

    1 2012 R2 term I set this one up just to test to see if MS fixed the problem in R2.

    i have done this fix with windows Authorization access group, I’ll go 2 to 3 days without a .BAK in the registry.

    I tried the KB fix that started this thread, and I get the error “the update us not applicable to your computer”.

    Tuesday, January 14, 2014 8:35 PM
  • Hi!

    I do have the same problem on a single server setup. Profilediscs can work for several days and then sudenly some users are logged on with a temporary profile.

    Someone mentioned a hotfix for windows 2012 R2 where can I find that?


    Tuesday, February 4, 2014 8:18 PM
  • hello,

    we have the same problem on a single server. any solution ready?

    this problem is really annoying us.


    • Edited by florian-st Wednesday, February 19, 2014 8:41 AM
    Wednesday, February 19, 2014 8:41 AM
  • I have same problem as thread-starter on a small TS farm with 2 RD hosts.

    No hotfix for 2012 R2 available yet. Microsoft come on, please fix this now.....


    Thursday, February 20, 2014 8:41 PM
  • Exact same issue here on 2012 R1. Also small farm with two host servers, using UPD. Started after power failure that caused the server to reboot. Created the second (virtual) host server after the problems started on the first but the problems continued on the new server immediately. 

    Where can I get the hotfix for R1? Is there any Technet documentation available on this?

    Thursday, April 24, 2014 7:37 PM
  • We've been having issues with temp profiles too, in our environment, users who are getting a temp profile always seem to be ending up on the same RDS Session host server. Different users who get a temp profile will end up on different RDS servers - but the same user always ends up on the same RDS server. A work around for us is to disable logins on a particular RDS server to force a user onto a different server - when we do this the user does NOT get a temp profile. If I re-enable logins back on the original RDS server - the user can log into that server and does not get a temp profile again.

    Monday, June 2, 2014 10:13 PM
  • +1... same problem here. 

    Session host server getting a temporary profile.  Other servers are working fine.  Getting same event ID 15 with similar messages.

    We could really use that hotfix about now...

    Wednesday, June 4, 2014 7:59 PM
  • +1 ... where the **** is the fix??
    Sunday, June 15, 2014 7:39 PM
  • +1... waiting for a hotfix.
    Monday, June 16, 2014 4:30 PM
  • Thank you!, suffering from almost the same issue (using standard profiles though not ProfileDisks, Server 2012 std Not R2) 

    I went through your fixes (out of desperation at this point, and yes i tried all the useless hotfixes),  and it is now working correctly and pulling down profiles, might be worth mentioned that it only worked after completing steps 4 - 7 though previously the host server was not a member of the Windows Authorization Access Group.


    Wednesday, June 25, 2014 2:59 PM
  • The same problem here - weeks of trying to solve the temporary profile issue.  Ours actually goes out and touches the remote profiles share, creates the appropriate folder, updates the timestamp, but we only get a temporary profile!  The directories on the shares are empty.  I've triple-checked the permissions.

    This thread at least tells me that there are a LOT of folks having this issue.

    I added my two RDS servers to the Windows Authorization group, deleted all old profiles, and....  TEMPORARY PROFILE.  I'm working my tail off to get away from Citrix and go with just MS RDS, but this is just frustrating the heck out of us here.

    20122 R2, all updates, tried re-installing KBKB2887595, just to make certain everything was there, but it is definitely installed already.  Added the key from same KB. 

    Any other ideas?  sheesh

    Wednesday, June 25, 2014 9:48 PM
  • Actually, found this tidbit, which SEEMS to have solved it.  We had originally created the collection with UDP, then apparently broke it and re-created WITHOUT UDP.  I broke it and recreated with UDP, and the proper things appear to be happening now.

    If this changes, I'll keep this updated.

    Thursday, June 26, 2014 1:55 PM
  • Bad news again, it works once and only once.  It actually creates the proper profile on the UDP share, but the next time we log in, it creates a TEMP profile and that's that.  Nothing seems to fix it.

    I'm going to gen up two brand new servers and see what happens.  This is SOOOOOOOOOOO frustrating and expensive.

    Thursday, June 26, 2014 4:26 PM
  •  We had the same issue,

    noticed that the mounted profile vhdx was still in use, while user was not logged on at all.

    detached the profile vhdx.. Tadaaaaaaaaaaaaaaa.. logging in and the normal profile was available again ..

    Thursday, July 17, 2014 10:55 AM
  • Can you provide steps on how to do this?  I believe I have the same problem.
    Monday, July 21, 2014 4:11 PM
  • I experienced this issue when keeping UPD share on NAS storage.  The NAS would compress the files if they were not accessed regularly.  Uncompressing the VHDX allowed the profile disk to be mounted, and shutting off compression on the volume prevented the issue from recurring. 
    Thursday, August 21, 2014 8:15 PM
  • We are also having this issue. We are running UPD with Store All Settings and Data on profile disk checked. Has anyone experimented with only storing items more selectively to see if it makes a positive difference in regards to not loading temp profiles?

    Steve J.

    Friday, September 19, 2014 6:39 PM
  • Having the same problem now as well :( This makes me sad! User Profile Disks seemed like such a good idea, but just seems so unreliable... Could be my set up, but surely it should recover after having a problem!!
    Wednesday, November 12, 2014 10:09 AM
  • You are using VMware?
    Sunday, November 16, 2014 11:07 PM
  • You are using VMware?

    I'm having exact same problem and is runing the 2012 servers on VMWare ESXi v5.5

    @Sharik987 do you think that's the problem ?

    Wednesday, January 7, 2015 11:13 PM
  • Hi,

    Us too. We have various devices connecting to the server farm : 4 session hosts with a broker.

    We have all patches and fixes up to Jan 2015 and still we end up with UPDs being locked even though all users have logged out. We have 250 users on the farm with around 125 active at any one time and get around 10-15 reports a day of temporary profiles. 

    Any resources that will help mitigate this would be useful and a proper fix from MS would be just great around now. 

    Our UPDs store most information but not My Docs/Music/Pics. All users get affected at some point however only once every few days they get a temp profile. Some of the fixes we perform:

    1. When we see the user has an active and disconnected session, we log them both out and then they're ok
    2. When the user is constantly getting temp profiles but has just one session, we log them out and then clear the file locks on the UPD
    3. When a user has one session and the UPD VHD isn't locked after logout it's because their profile is corrupt and we have to ditch the UPD and start again for that user. 

    If anyone can tell me what it is in the UPD that tells the RDS Session Host that it's corrupt then that would be a bonus so I don't have to recreate UPDs. Restoring a UPD from the night before doesn't work - is there a watermark in A/D somewhere ?

    MS please get your act together, this should work so well - any news on anything related to this at all ??

    Thursday, January 8, 2015 2:07 PM
  • I think one of the problems is with Adobe PDF reader. It creates locked files in users profile, please check for those files in users /Locale Settings/Temp folder...

    I would like both Microsoft and Adobe to fix this issue. It has been around for a long long time...

    The fix mentioned to create the ACROT.INI file does not work for me on W2012R2....

    Wednesday, January 14, 2015 11:12 AM
  • Also see this post: indicating that Adobe PDF Reader is the reason....
    Wednesday, January 14, 2015 11:23 AM
  • I am having this problem as well on a 2012 R2 RDS with UPD's.  It doesn't happen on every login, maybe every 5th or so, even as Admin on the console.  I've been investigating with process monitor and have found that Svchost.exe is creating the profile folders, then closing them. Opening them back up, but locking the file. Then access is denied from then on.  I also took a process monitor boot capture on a correct boot up and none of the errors occur.  In fact there are no "sharing violations" at all. I'm still sifting through the process monitor data, as I think something else is causing svchost.exe to lock the files.  I have a picture which makes this easier to understand but account verification is taking it's time today.  And just for good measure I uninstalled Adobe Reader and my Antivirus with no change in this problem.
    Friday, January 16, 2015 5:17 PM
  • Here is my picture
    Friday, January 16, 2015 6:35 PM
  • I have come to a conclusion that hope fully might help others in a similar situation.  While rebooting to collect many boot logs with Process Monitor, I noticed If I signed in on the console as soon as the login screen appeared I would receive a temporary profile. 100% of the time. If I was to let the login screen sit for 2 minutes before actually logging in, I would never receive a temporary profile.  I am storing my UPD on a SAS raid array, so maybe by logging in to quickly, the raid array isn't yet recognized.

    Notice on the left side of the picture, when logging in quickly there is no mention of the UPD (VHDX). However on the right, on a successful login, svchost.exe is able to make a connection to the UPD. This isn't a production server, so I don't know if remote users would still receive temporary profiles. i will have to find some guinea pigs.

    Friday, January 16, 2015 10:02 PM
  • I'm having this same issue and came across this thread which is over 1 year old.  I'm not having a good feeling about using UPD.  It's hard to believe the issue has been around so long an Microsoft hasn't done anything to resolve it.
    Thursday, February 19, 2015 8:32 PM
  • +1 I am having the same issue. Please release a hotfix ASAP!
    Friday, February 27, 2015 3:10 PM
  • For those who are still having this issue, I have done what others have suggested by checking the registry for .bak entries here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. However, I have also had to recreate the UPD by mounting the "bad one", copying the data, then renaming to .old and allowing the system to recreate the UPD. Not the work around I was hoping for, but it gets my users back to work. Hopefully Microsoft will release a hotfix soon. 
    Monday, March 2, 2015 7:52 PM
  • Hi all!

    In my case, I use RDS Farm,  problem was in hanged access to UVHD. Check Computer management -> Shared Folders -> Open files on server with UVHD, it`s not possible to connect to several RDS Farm servers at same time if you use User profile disks. 

    • Proposed as answer by Alakey Monday, March 5, 2018 10:13 PM
    • Unproposed as answer by Alakey Monday, March 5, 2018 10:13 PM
    Tuesday, April 7, 2015 1:43 PM
  • @Ilya Matveikin No same problem. This problem is regarding locked files in profile when user logs off....
    Tuesday, May 12, 2015 7:37 AM
  • We`ve still the same Problem on 2 2012 R2 Servers. One of them is the Connection Broker and the other is one of the RDS Host.

    On the connection Broker is no GPO with Roaming Profile Settings linked and we dont use UPD`s. The local Administrator get`s a temporary profile too. No pending Profile List entrys or Tempfolders present.

    Tuesday, August 18, 2015 2:00 PM
  • We have just set up a small 2012R2 RDS farm with two 2012R2 vm's and have profiles disks on a management servers hard drive share

    All of a sudden one user that has logged in and out many times with no issues has gotten a temp profile issue

    And news on a fix for this as it will be hard to convince my bosses that this is the way to go ahead if this keeps recurring 

    • Edited by Mantobrew Tuesday, September 15, 2015 5:56 AM
    Tuesday, September 15, 2015 4:50 AM
  • A quick fix I have found is to grab a profile disk copy from the last known good logon from previous versions (shadow copy) and this worked
    Wednesday, September 16, 2015 10:58 PM
  • Same issue. Users are getting temporary profiles. Have looked all over the internet, and nothing I have tried helped.

    We need a fix from microsoft...!

    Monday, September 21, 2015 6:57 PM
  • Still having this issue here.  I cannot believe it's been broken for 18 MONTHS!
    Monday, October 12, 2015 3:28 PM
  • I solved this type of problems (sometimes the user get temp profile)  by putting new RDS host server(s) as connection servers in the collection, with deny new logon settings.  The connection name point only to this server(s).

    When the clients connect to this server, the SB immediatly redirect them to Production hosts.


    Thursday, October 15, 2015 9:02 AM
  • Hi Jalos,

    Can you please add a few more details regarding your fix please. Not sure if you mean connection broker or not?

    I've spent hours on this issue and read countless articles. Clearly there is an issue with UPD and RDS 2012r2. I'm completely dumb founded! I had thought I'd resolved the issue by removing caching from the drive where the UPD share is. Rebooted the server and it was fine for the first couple of logins... then same problem. I am wondering if this issue could in part be cause by adding the folder  '\AppData\Local\Microsoft' to the UPD. 

    I also had an issue with the connection broker not load balancing. To resolve this issue, I edited the file and added in the farm name - solved. Painful for thin clients however!


    The issue is:

    1. An RDS farm load balances.

    2. If the VHDX doesn't unload from the previous login and the user re-logs in to the farm and they get pushed to another server, they get a temporary file.

    3. Given load balancing works... this issue will never go away!

    • Edited by AL711 Wednesday, November 11, 2015 1:44 AM
    Wednesday, November 11, 2015 1:42 AM
  • BTW: If you add a file as opposed to a folder to be included with the UPD, you will likely get a temp profile
    Wednesday, November 11, 2015 1:44 AM
  • We had this same problem with all users getting a temp profile, ours was caused by a folder redirect issue in Group Policy.
    Monday, November 16, 2015 12:01 PM
  • Yup. I'm waiting for an answer as well. I have 2 servers this happens on.

    Saturday, November 28, 2015 7:33 PM
  • Hi, we are in France, even without a virtual disk, the same problem, on a random connection to the eighth, the tenth ... etc. Up..
    Monday, November 30, 2015 2:12 PM
  • Have you guys install this fix already?

    Hari Kumar --- Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights

    Tuesday, December 1, 2015 9:02 PM
  • Hi

    3092688 Message : Not for my system (2012 R2)...sorry

    Wednesday, December 2, 2015 7:09 AM
  • We also have the RDS UPD problems. 

    Microsoft should really take the time to fix this 2012 R2 problem!

    I usually fix the problem by doing the following when suddenly getting a TEMP profile when logging into the domain admin on the RDS Host server:

    1. I went to where the UPD file is, and "mounted" the admin UPD disk, then to "my computer" and "eject" the "user profile" disk that was mounted.

    2. After this i delete the entire admin user folder under "profilelist" in the registry. (it has a path to a TEMP folder in it.)

    3. Relogging(not disconnect) and then the admin user gets its old UPD back.

    So the problem here is that the "locking" of the UPD file isnt removed correctly after a a disconnection/logoff, and the next time the user tries to log on, it cannot mount the UPD. 


    Consultant. System, Network & Communication

    Friday, December 4, 2015 10:12 AM
  • I have the exact same issue here, I have 1 VM that has this problem. No user can login into the server with their profile. Right now is not an issue because its an app server but we do not want this top happen with the other servers. since this one is part of very important cluster.

    I found this hotfix., but I do not know if this will fix it. And I cant go on installing random patches in a cluster

    Thursday, December 10, 2015 12:20 AM
  • Megg...tried that hotfix (3092688) but no difference here.
    Thursday, December 17, 2015 1:52 PM
  • I'm experiencing the same issue. I'm testing 5 users on 2 terminal servers. Four of the 5 users don't have issue. Any suggestion from anyone?
    Monday, December 21, 2015 11:00 PM
  • Hello Russ,

    I have some similar situation earlier.

    Please check two things.

    1. first one is session limit.

    2. Update the permission from User profile disk in session collection properties.


    Pankaj Singh

    • Edited by Singh, Pankaj Wednesday, December 23, 2015 4:19 PM
    • Proposed as answer by Singh, Pankaj Wednesday, December 23, 2015 4:19 PM
    Wednesday, December 23, 2015 4:19 PM
  • Hi everyone,

    Like many of us, I have the same issue ... till today (???).

    The 2012R2 (win updates done yesterday) infra : 1 RDWA/RDCB, 5 RDSH, 1 FILER. 

    Issue : whoever the user is, the temp profile is used instead UPD (set to FILER). btw, you know that.

    I made some changes in the comp GPOs and, surprisingly, I can logon many times w/o having the temp profile issue !! 

    This is what I did:

    1. On every RDSH, delete all .bak in the reg,

    2. Delete the users' folder through the explorer,

    3. Delete the users' vhdx,

    4. On the dedicated Comp GPO to RDSH servers, 

    System/Logon "Always wait the network at computer start up and logon" -> Enabled

    Windows Components/RDS/RDSH/Connections "Automatic reconnection" -> Disabled

    Windows Components/RDS/RDSH/Connections "Configure keep-alive connection interval" -> Disabled

    Windows Components/RDS/RDSH/Connections "Restrict RDS users to a single RDS Session" -> Enabled

    Windows Components/RDS/RDSH/Temporary Folders "Do not delete temp folders upon exit" -> Disabled

    5. Reboot all servers.

    I enabled the "Always wait ..." cause the network is longer to be accessed than local profile and "Configure keep-alive..." (I let you read the description...). The "Restrict RDS users..." is to be sure that the vhdx can be modified.
    I checked with Sidder.exe (usefull for RDS admin).

    Try and share your feedback ;)

    Thanks and Hope it solve the issue.

    • Proposed as answer by AK47SysAdmin Friday, November 23, 2018 5:58 PM
    Thursday, January 7, 2016 11:24 AM
  • Thanks JeRoX1.

    It worked!

    BUT make sure to deleted the .BAK profiles in your Registry!!!!

    • Edited by Sylvain68 Tuesday, January 12, 2016 3:45 PM
    Tuesday, January 12, 2016 1:25 PM
  • Hello People,

    I have been having the same issue you all described with a 3 server 2012 R2 RDS setup.
    First server being Gateway/web access/connection broker/rdsh and the two others being rdsh servers.

    And solved it.

    -> I did delete all profileList .bak entries.

    -> I deleted user local folders on RDSH servers.

    -> I didn't deleted any UPD. (.vhdx)

    -> At first I disabled GPO linked to RDSH server.
    Reboot of server necessary for GPO apply.

    The problem is then gone.

    I carrefully removed all configuration by the GPO before enabling it back. Now I don't have the problem anymore while I keep setting up GPO settings that cannot conflict in any way with any settings that could be done or undone by available settings in Collection Properties.
    My opinion, the bug is here! Getting into confilcting settings that are set by the RDS farm Collection and other that are set by the GPO.

    Note that in JeRoX1 solution, on his GPO, are only enbaled settings that cannot be setup by the collection options.

    Curious to see others testing this solution.

    Best Regards.

    • Proposed as answer by yvanm2 Wednesday, January 13, 2016 2:24 PM
    Wednesday, January 13, 2016 2:16 PM
  • I found the problem in my scenario.  It turned out that the problem are certain thinclients that don't support NLA.

    When the thinclient connects to one session hosts is prompted for credentials. Apparently, after entering it's credentials by the action of the load balancer is sent to another session host and asked for credentials for a second time. That's a very common problem with legacy thinclients and Windows XP.

    During the redirect from the first session host to the second one the profile (VHDX) remains locked for a few seconds. If the user types the password fast enough then he gets the temporary profile because the VHDX was still locked.

    I found more people with the same scenario and the same problem:


    Thursday, January 14, 2016 12:13 AM
  • Hi Everybody

    There is no solution by Microsoft in fact..may be in 2016 server, business is business !

    Then i decide to use TSPLUS or TS2LOG in France and bye bye the bugs of the profiles and others.

    Best regards.

    Saturday, January 23, 2016 6:29 AM
  • I have tried JeRoX1 solution (and many others) but in our case this is unfortunately not the solution... Still working with MS support to find the root cause.... almost about to give up.

    Wednesday, January 27, 2016 1:18 PM
  • I encountered the same thing on a System with two RDS servers a RDGateway and thin clients.

    After applying the suggestions done before, i still had users getting temp profiles. The phnemona disappeared after logging of all the users, deleting all the .bak files from

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    Then recreated the User Profile Disks belonging to the affected users.

    I understand, it doesn't get to the origin of the issue, but it solved my problem :)

    Th system has been running for 48 hours without any trouble now.

    Monday, February 15, 2016 10:12 AM
  • I realise this is an old thread but it does seem to be an ongoing issue, and my resolution is different to anything I've seen here or elsewhere.

    We had a group policy setting that was pointing to a decommissioned server that was causing everyone connecting to an RDS server to be logged on with a temporary profile.

    The policy is called "Set path for Remote Desktop Services Roaming user Profile"

    The policy is located here:- Computer Config/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Profiles

    Hope this helps someone

    Thursday, May 19, 2016 3:01 PM
  • At the time of logoff on the server that hosts the UPDs I was seeing \DevModePerUser reg keys not clearing down in time (Event ID 1530) and the file lock remaining. Looking into this some people in previous versions of TS/RDS installed on VMWare were blaming the SharedFolders component of VMWare tools.

    I've removed this from our session hosts and file server as it's not needed (seemingly it's a feature only utilize in Vmware Workstation installs not VSphere) and since then I haven't had reports of temp profiles.
    Worth considering if you have a VMWare Hypervisor.

    • Edited by NSR89 Wednesday, August 3, 2016 1:16 PM
    Wednesday, August 3, 2016 1:15 PM
  • i had that problem with one user.. got rid of it by deleting the corresponding HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\ -> Entry (watch for the Guid)

    .. and delete that Guid from 

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileGuid\ -> {GUID}

    • Proposed as answer by rush222 Thursday, July 27, 2017 6:08 PM
    Wednesday, August 31, 2016 7:37 PM
  • What are you logging on to in order to delete the GUID?

    The host server or the Client computer?  

    I am having the same issue only it is happening when the user is logging into a VDI session.

    Monday, September 19, 2016 5:59 PM
  • At the time of logoff on the server that hosts the UPDs I was seeing \DevModePerUser reg keys not clearing down in time (Event ID 1530) and the file lock remaining. Looking into this some people in previous versions of TS/RDS installed on VMWare were blaming the SharedFolders component of VMWare tools.

    I've removed this from our session hosts and file server as it's not needed (seemingly it's a feature only utilize in Vmware Workstation installs not VSphere) and since then I haven't had reports of temp profiles.
    Worth considering if you have a VMWare Hypervisor.

    Thanks, but VMware tools does not include the Shared Folders option on installs with the "typical" configuration. It is not enabled on any of our Servers and we are still experiencing the issue every day.
    Thursday, September 22, 2016 9:34 PM
  • I solved this issue:

    open regedit

    search for the username and delete all entries. this fixed it for me.



    Tuesday, October 11, 2016 7:56 AM
  • I've been working with Microsoft and they have released KB3192404 that I can say does fix the temporary profiles. We found that App-V 5.1 (not App-V 5.0) was holding on to the VFS directory in the users profile. Apply this KB update to the connection brokers, RDSH, and file servers.
    Monday, October 31, 2016 9:13 PM
  • KB3192404 has not fixed the temporary profile issue.  I tried on one of our servers no luck.
    Friday, November 4, 2016 10:11 PM
  • We were experiencing this issue on a brand new RDS host server. In our case, it was happening because a user with administrator rights had the user's UPD mounted when the user attempted to log in. A reboot closed the open files and the user was able to login without a temp profile being created. You could also go through the process of finding the open file and closing it manually, but that is a fairly laborious process documented nicely here:

    The moral of this story is don't mount UPDs!

    • Edited by Doug HFCU Tuesday, November 8, 2016 11:02 PM
    Tuesday, November 8, 2016 11:02 PM
  • Hi

    I find a problem possible with the SID of the servers. In a virtual environement, i have tow AD replicated, with the same SID and two TSE with the same SID (different of the SID's ADs). I execute sysprep after deconnection  TSE of the domain, and reconnection to the domain, no problem after 12 hours...idem with the second AD,depromote, deconnection of the domain, sysprep and dc promote

    Potential problem also is the domain".local" in 2012; i read the domain must be different of .local, like .com or .net ...etc

    For read the SID :

    to be continue

    Wednesday, November 23, 2016 5:14 PM
  • Has anyone tried this with Server 2k16? For real Microsoft, that's just not fair. So many people have problems with this RDS Stuff and they just don't say anything about this. I really want to use it but it's impossible like this. We switched back to single TS which 'solved' the problem..
    Friday, December 16, 2016 10:01 AM
  • Has anyone tried this with Server 2k16? For real Microsoft, that's just not fair. So many people have problems with this RDS Stuff and they just don't say anything about this. I really want to use it but it's impossible like this. We switched back to single TS which 'solved' the problem..
    I am running a 2 Session farm (4 total server with CB and GW) on 2k16 and can confirm that its still a problem. I am using this article right now to try and help fix the damn issue.
    • Edited by iwifia07 Tuesday, December 20, 2016 8:00 PM added server
    • Proposed as answer by Jb85VH Monday, February 6, 2017 1:07 PM
    • Unproposed as answer by Jb85VH Monday, February 6, 2017 1:07 PM
    Tuesday, December 20, 2016 7:59 PM
  • Hello, i am french, we have a farm rds 2012 r2,
    Having not found a solution we have put in place a powershell script in a planned task that cleanly deletes each profile appropriately
    We have therefore bypassed the problem
    Monday, February 6, 2017 1:08 PM
  • Try this below link. It worked for me.

    Wednesday, February 8, 2017 12:01 AM
  • Try this below link. It worked for me.

    • Proposed as answer by AcetiK Friday, November 10, 2017 8:25 AM
    Wednesday, February 8, 2017 12:01 AM
  • Hi there,

    I deleted the profiles under ProfileList registry key and it worked for me.

    Friday, November 10, 2017 8:26 AM
  • I started to have the same issue with the temporary profiles (for Administrator too) after a unsafe shutdown of the server.

    2012 R2 - DC controller, RDS with UPD

    I tried everything suggested

    - I created an another account with the membership of the all administrator groups. Then I tried to delete and recreate the administrator account. That is not possible due to the fact it's a builtin account. You can not remove it only disable it. Enabling/disabling didn't help either.

    - I removed the admin (.vxhd) , TEMP and any system created Administrator* folders from C:\Users. After that the admin account SID from registry 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileGuid

    then reboot. It didnt solve the issue.

    What helped was (all the steps above for every account) and disabling UPD. 

    After the reboot the system created the proper "Administrator" folder (for other AD users too).

    I had to deal with only 3 accounts,barely in use yet. This would be very frustrating issue for tens or hundreds of accounts.


    Monday, January 15, 2018 12:32 AM
  • I am having this issue with 2016 as well.  Anyone find anything that will help?  Tried everything but opening up a case with microsoft.  That will be next.


    Sunday, January 21, 2018 8:09 PM
  • have the same issue on 2012 r2 rds server.

    in  vhd shared folder i have new profile disks like this: 


    Tuesday, January 23, 2018 3:42 PM
  • I know this is an old thread, and I haven't read through every post. I had the same issue I created a VM template from my production host servers. This brought over lost of user profile folders. I tried the reg fix and many others. Eventually, I took the time to clean up all the host server c:\users directory. Once I did that it worked. 

    Key Config Details

    1. Profile directory share is replicated from production (using profile VHDs)
    2. All RDS server in DR came from a VM template from production servers
    3. Window 2012 R2.

    I've been dealing with this problem for a while now, and nothing seemed to work, so I'm throwing in my 2 cents to hopefully help someone in the same boat...

    • Edited by Todd.M Monday, July 16, 2018 3:07 PM
    Monday, July 16, 2018 3:06 PM
  • Dude..... you are my hero right now. This works!!!!!!!!!!!!!!
    Friday, November 23, 2018 5:59 PM
  • Same problem here, regularely, with different infrastructure with UPD, 2012 R2 or 2016...

    Last infrastrcuture with UPD, the problem appears a lot with GPO that connect shared printer on user profiles. Have to bring back with local printer in IP mode.

    Must manually clean registry (with profilelist and check that VHDX not in used) every time a temporary profile appears


    Wednesday, April 10, 2019 3:12 PM
  • For us, after trying literally everything above and much more, I stepped back to think about how this actually works.

    Checking for the UVHD-template file in the TS SHare, I found it missing - disabling and reenabling the user profile disk in the collection fixed it for us.  Uhg!

    Problem appears to be *finally* resolved.

    Saturday, April 20, 2019 5:35 PM
  • I  have opened a case Microsoft premiere about it .   We have 2 Session Host with 35 vms inside , creates from template.  And we have the same issue ,  "temp profile" . 
    Wednesday, July 17, 2019 7:17 AM