none
Remote Management issues from Server Manager 2016 RRS feed

  • Question

  • Hi. I have set up a Windows Service 2016 test-environment containing 5 servers with the 2016 RTM code.

    The problem is that i can't seem to manage any remote servers from Server Manager 2016. The "Managebility" column of Server manager says "online", so i assume connectivity is OK. Remote management is enabled on the remote servers and the firewall exceptions have been enabled. When I select remote management i get the standard error message that asks to to check that the firewall permissions have been enabled. I also cannot restart any of the servers remotely ("One or more servers cannot be restarted").

    Just to troubleshoot i fired up an old Windows 2012 R2 server. To my surprise i was able to remote manage all the servers in question with that. Any advise how to proceed with the troubleshooting?

    I of course have tried searching though the event viewer, but haven't found any errors in this regard.


    • Edited by KasperBC Sunday, October 9, 2016 12:26 PM
    Sunday, October 9, 2016 12:24 PM

Answers

  • Hi,

    According to your description, my understanding is that it failed to manage Windows Server 2016 remotely via Server Manager – All Servers. 

    >When I select remote management i get the standard error message that asks to check that the firewall permissions have been enabled. I also cannot restart any of the servers remotely ("One or more servers cannot be restarted").
    On the computer that you want to manage remotely, open a Windows PowerShell session with elevated user rights. Type the following, and then press Enter to enable all required firewall rule exceptions:
    Configure-SMRemoting.exe -enable

    If the problem persists, try to disable Windows Firewall temporarily on both sides, and check the result.

    Besides, local administrator accounts other than the built-in Administrator account may not have rights to manage a server remotely, even if remote management is enabled. The Remote User Account Control (UAC) LocalAccountTokenFilterPolicy registry setting must be configured to allow local accounts of the Administrators group other than the built-in administrator account to remotely manage the server.

    To disable UAC remote restrictions, change the value of “LocalAccountTokenFilterPolicy” to 1:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps:
    1. On the Edit menu, point to New, and then click DWORD Value.
    2. Type LocalAccountTokenFilterPolicy, and then press ENTER.

    Remember to back up the registry before any change. You can undo the change via restoration if there is any problem happens later. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 11, 2016 6:55 AM

All replies

  • Hi,

    According to your description, my understanding is that it failed to manage Windows Server 2016 remotely via Server Manager – All Servers. 

    >When I select remote management i get the standard error message that asks to check that the firewall permissions have been enabled. I also cannot restart any of the servers remotely ("One or more servers cannot be restarted").
    On the computer that you want to manage remotely, open a Windows PowerShell session with elevated user rights. Type the following, and then press Enter to enable all required firewall rule exceptions:
    Configure-SMRemoting.exe -enable

    If the problem persists, try to disable Windows Firewall temporarily on both sides, and check the result.

    Besides, local administrator accounts other than the built-in Administrator account may not have rights to manage a server remotely, even if remote management is enabled. The Remote User Account Control (UAC) LocalAccountTokenFilterPolicy registry setting must be configured to allow local accounts of the Administrators group other than the built-in administrator account to remotely manage the server.

    To disable UAC remote restrictions, change the value of “LocalAccountTokenFilterPolicy” to 1:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps:
    1. On the Edit menu, point to New, and then click DWORD Value.
    2. Type LocalAccountTokenFilterPolicy, and then press ENTER.

    Remember to back up the registry before any change. You can undo the change via restoration if there is any problem happens later. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 11, 2016 6:55 AM
  • Hi,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 17, 2016 10:10 AM