none
Unable to configure Virtual Switch on Windows 8 Pro RRS feed

  • Question

  • I'm using Windows 8 Pro RTM and am attempting to configure an External Virtual Switch.  I have an Asus P8Z68-V and it has a single Intel 82579V controller.  I'm attempting to use the option to share the NIC with the management OS.  When I attempt to apply the changes, I get the following error:

    [Window Title]
    Virtual Switch Manager

    [Main Instruction]
    Error applying Virtual Switch Properties changes

    [Content]
    Adding ports to the switch 'External Virtual Switch' failed.

    The operation failed because the file was not found.

    [Close]

    I also have this in the System event log:

    Log Name:      System
    Source:        Microsoft-Windows-Hyper-V-VmSwitch
    Date:          8/19/2012 11:00:28 AM
    Event ID:      32
    Task Category: (1022)
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      
    Description:
    Failed to connect NIC /DEVICE/{1CCAC89B-831B-4CE4-BF4B-68A74397D9B4} (Friendly Name: ) to port BFBD137F-C428-44D2-A266-993D7D65AE5B (Friendly Name: ) on switch B42108B1-77B7-4703-A7AE-C6B1120FA93F (Friendly Name: ), status = Object Name not found..
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Hyper-V-VmSwitch" Guid="{67DC0D66-3695-47C0-9642-33F76F7BD7AD}" />
        <EventID>32</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>1022</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2012-08-19T18:00:28.099312900Z" />
        <EventRecordID>1086</EventRecordID>
        <Correlation />
        <Execution ProcessID="1932" ThreadID="1976" />
        <Channel>System</Channel>
        <Computer></Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="Status">3221225524</Data>
        <Data Name="NicNameLen">46</Data>
        <Data Name="NicName">/DEVICE/{1CCAC89B-831B-4CE4-BF4B-68A74397D9B4}</Data>
        <Data Name="NicFNameLen">1</Data>
        <Data Name="NicFName">
        </Data>
        <Data Name="PortNameLen">36</Data>
        <Data Name="PortName">BFBD137F-C428-44D2-A266-993D7D65AE5B</Data>
        <Data Name="PortFNameLen">1</Data>
        <Data Name="PortFName">
        </Data>
        <Data Name="SwitchNameLen">36</Data>
        <Data Name="SwitchName">B42108B1-77B7-4703-A7AE-C6B1120FA93F</Data>
        <Data Name="SwitchFNameLen">1</Data>
        <Data Name="SwitchFName">
        </Data>
      </EventData>
    </Event>

    Once this error message occurs, the NIC has a Device code 10 (cannot start) and network connectivity is lost for the host.  I have to scan for hardware changes and the NIC comes back online. Thoughts on what could be wrong?


    http://sharepoint.nauplius.net

    Sunday, August 19, 2012 6:09 PM

Answers

  • I put in a new Intel Gigabit CT adapter and I had no issues creating the switch against that card using the default settings.

    http://sharepoint.nauplius.net

    Monday, August 27, 2012 4:21 PM

All replies

  • did you get the same issue if you uncheck the option "Share the NIC with management OS"?
    Tuesday, August 21, 2012 2:13 AM
  • Hi,

    Please try to use the following PowerShell command to create the External Virtual Switch to see whether you get the same issue.

    New-VMSwitch -Name “ExternalVirtualSwitch” -NetAdapterName “D-Link02” -AllowManagementOS $True
    Note: ExternalVirtualSwitch is the name of the External Virtual Switch you want to name. D-Link02 is the physical network adapter name bind to the External Virtual Switch. Adjust them accordingly.

     

    • Proposed as answer by advanceit2004 Friday, September 7, 2012 10:42 PM
    Tuesday, August 21, 2012 9:02 AM
    Moderator
  • Zephryhu - Currently I only have one NIC, but I have another one on the way.

    Vincent, I was actually able to create the Virtual Switch by unchecking the Microsoft Windows Filtering Platform extension prior to binding to my existing NIC.


    http://sharepoint.nauplius.net

    Tuesday, August 21, 2012 2:00 PM
  • Hi,

    What did you mean by “unchecking the Microsoft Windows Filtering Platform extension”? Have you tried the PowerShell command?

     

    Tuesday, August 21, 2012 3:54 PM
    Moderator
  • Exactly that, while the VS was set in Internal mode, I unchecked the WFP extension under the VS extensions, saved that change, then set the switch to External.

    No, I have not tried the PS command.


    http://sharepoint.nauplius.net

    Tuesday, August 21, 2012 3:59 PM
  • Hi,

    How about the issue? Is there any update?

    Monday, August 27, 2012 6:30 AM
    Moderator
  • I put in a new Intel Gigabit CT adapter and I had no issues creating the switch against that card using the default settings.

    http://sharepoint.nauplius.net

    Monday, August 27, 2012 4:21 PM