none
Laptop screen dims even though adaptive brightness is turned off. What can I do? RRS feed

  • Question

  • Laptop screen dims even though adaptive brightness is turned off. What can I do? I have an Inpiron 14z with both the Intel 4000 and AMD 7570M graphics. Thanks

    It bothers me so much I'm thinking about uninstalling Win 8. Also, I've got all of the latest drivers from Intel, AMD (ATI) and Dell.


    James A+, Network+, MCP

    Tuesday, January 1, 2013 7:44 PM

Answers

  • After you try everything (including changing the power options, and Dell Intelligent Display), try this.

    It may be caused by intel's graphic control panel. When you're using battery, and if you have another separate graphic card, most likely you're switching over to intel's graphic card to save power. Open the screen (below), and make sure the power conversion option is set properly.

    • Proposed as answer by Wyck Wednesday, February 19, 2014 1:39 PM
    • Marked as answer by Michael_MartinModerator Monday, June 30, 2014 2:56 PM
    Saturday, August 24, 2013 7:49 AM

All replies

  • Its dims or is it permanently dim?  Just want to be sure its not the LCD backlight going bad causing it to always be dim.

    Be kind and Mark as Answer if I helped.

    Wednesday, January 2, 2013 7:21 AM
  • It dims as I change screens or pull up darker colors. Basically it's like adaptive brightness is stuck on.

    James A+, Network+, MCP

    Wednesday, January 2, 2013 1:36 PM
  • Please try to disable Adaptive Brightness service for a test.

    Open Services console -> stop and disable Sensor Monitoring Service


    Niki Han
    TechNet Community Support

    Thursday, January 3, 2013 5:43 AM
    Moderator
  • I did. It still happens. Only on battery. I don't see anything listed with AMD either.

    James A+, Network+, MCP

    Thursday, January 3, 2013 1:54 PM
  • Check your BIOS.  There are options in laptop BIOS to dim the display when on battery.

    Be kind and Mark as Answer if I helped.

    Thursday, January 3, 2013 2:44 PM
  • I checked the BIOS and there are no settings for it. I also downloaded all of the latest drivers. The LCD was even replaced once.

    James A+, Network+, MCP

    Saturday, January 12, 2013 2:25 AM
  • I have this exact problem and will be returning my laptop tomorrow if I can't figure out how to sort it. Did you get it resolved?

    Also, have you tried disabling Dell Intelligent Display on the battery monitor page (this was suggested to me, but the option is missing from my menu)?

    Sunday, March 17, 2013 11:24 AM
  • I checked all of the above settings even the ATI settings. Still dims. At this point, I'm getting pretty angry.

    James A+, Network+, MCP

    Saturday, May 18, 2013 11:28 PM
  • Have you tried loading another OS, such as a Linux boot CD just to test?  If it never happens in another OS then I'd state that its drivers of some sort that is "wonky" on your end so please contact Dell.  If it happens in another OS then it is hardware....please contact Dell.  Either way, I think you've done all you could and should contact Dell for support.

    Be kind and Mark as Answer if I helped.

    Sunday, May 19, 2013 8:08 AM
  • I believe it is a setting under the advanced power options menu. I have an Inspiron 15z and it does the same thing. It only does it on battery to preserve the battery life (as I am sure you already are aware ;-). It took me a while to realize what was going on too.

    Saturday, June 8, 2013 2:52 PM
  • After you try everything (including changing the power options, and Dell Intelligent Display), try this.

    It may be caused by intel's graphic control panel. When you're using battery, and if you have another separate graphic card, most likely you're switching over to intel's graphic card to save power. Open the screen (below), and make sure the power conversion option is set properly.

    • Proposed as answer by Wyck Wednesday, February 19, 2014 1:39 PM
    • Marked as answer by Michael_MartinModerator Monday, June 30, 2014 2:56 PM
    Saturday, August 24, 2013 7:49 AM
  • Thank you Harvey. Your solution fixed my problem!
    Thursday, August 29, 2013 11:34 PM
  • Thank you very much, Harvey Darvey! This stupid Intel Drivers... I may have spent hours trying to figure it out on my own...
    Friday, June 20, 2014 12:30 AM
  • How do i get to this page? please help
    Friday, June 20, 2014 5:36 AM
  • YES! Worked perfectly. Thanks.

    I had fixed this years ago, why it showed up again, no rational human being will ever know.

    Wednesday, July 23, 2014 9:50 PM
  • New Intel drivers do not have this option, but i do have it set to Maxium performance, service is disabled, Windows options have it disabled and it STILL is doing it...


    • Proposed as answer by Anton Beseda Tuesday, May 26, 2015 4:02 PM
    • Unproposed as answer by Anton Beseda Tuesday, May 26, 2015 4:02 PM
    Saturday, March 7, 2015 9:21 PM
  • Can you see a small white arrow near "Power". Choose "on battery there"
    Tuesday, May 26, 2015 4:03 PM
  • This answer is still valid in 2017 and with Windows 10. Thanks! Adaptive brightness was driving me up the wall.
    Sunday, July 16, 2017 5:32 AM
  • Thank you so much. This solved my problem (windows 10). I couldn't figure out why everything kept dimming while on battery. 
    Monday, December 25, 2017 3:43 PM
  • Here we are in 2018, and I am having the basic same issue with my Windows 10 Dell Inspiron 15 with the exception that it's only when it is plugged in. It does the dimming on and off every 10 seconds on the dot, but not when it is on battery.

    The computer has the integrated Intel graphics.

    I am in the process of trying all the above mentioned cures, I will report if I have any or no success in fixing my issue.

    Thank you.


    • Edited by TJMB Friday, January 19, 2018 7:29 PM
    • Proposed as answer by AnaghaB Sunday, September 23, 2018 7:06 PM
    • Unproposed as answer by AnaghaB Sunday, September 23, 2018 7:06 PM
    Friday, January 19, 2018 7:24 PM
  • I've always had this annoying issue on different laptops running Windows OS's from Windows Vista, Windows 7, Windows 8 and Windows 10 so my only guess is that it has been done intentionally by windows. 
    Wednesday, December 12, 2018 8:37 PM
  • Just plug and un-plug the charging cable. Works like a charm. :D
    Friday, January 25, 2019 2:22 PM