DHCP/DNS Wireless vs Docked IP updating issue RRS feed

  • Question

  • I am lost on this one... we are in the process of migrating to Windows 10. We mostly use Dell laptops. DNS addressing is handled by DHCP. DNS Scavenging is not configured. 

    So I think our problem is due to the new Windows 10 computers and how they automatically disable the wireless card when docked. Windows 7 would leave the wireless card active. This becomes an issue when the active DNS record is for the wireless card. not the wired connection. I noticed this when trying to connect with SCCM remote tools. If I tried by computer name no luck. but if I asked the user their IP I could then connect. SCCM was hitting DNS which was handing out the wireless IP instead of the docked IP. This is also causing major issues with other systems, RSA in particular. 

    I guess my question is how do I get DNS updated with the correct (docked) IP? The computer is not power cycled during docking, so it is not automatically trying to renew IP, which would then update DNS? right? What am I missing here?

    Thanks in advance for your help!

    Monday, August 27, 2018 10:45 PM

All replies

  • Hi,

    Thank you for your question.

    Since the docking station has its own mac address, it also receives a DHCP lease to get an IP address and register its own records in the DNS. The wireless network card does not register the correct record in the DNS, so the remote connections can only be established by IP address instead of hostname.

    I recommend that you manually disable the wireless card or use a script to disable it automatically. You can also post your issue on the Dell forum: or contact your docking provider for assistance.

    Best Regards,


    Tuesday, August 28, 2018 10:07 AM
  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,


    Monday, September 10, 2018 2:20 AM
  • Hi,

    As this thread has been quiet for a while, we will mark it as ‘Answered’ as the information provided should be helpful. If you need further help, please feel free to reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    BTW, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

    Best Regards,


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, September 12, 2018 2:33 AM