locked
windows 2008: w32time service could not be started

    Question

  • Hi,

    In windows 2008, I am not able to start the windows time service. I have tried to restart the system.
    I tried to w32tm / unregister - restart, then w32tm /register - restart then start but still could be started.

    C:\Users\administrator.ANNAIK>net start w32time
    The Windows Time service is starting.
    The Windows Time service could not be started.

    A system error has occurred.

    System error 1792 has occurred.

    An attempt was made to logon, but the network logon service was not started.

    C:\Users\administrator.ANNAIK>w32tm /config /update
    The following error occurred: The service has not been started. (0x80070426)

    I tried to search in google or in support.microsoft.com I am unable to find any info on this.

    Please help how I can set my domain controller to act as the time server for my network so that all the local systems in the network has the same time.

    Thanks & Rgds,
    Riyaz

    Monday, January 04, 2010 2:42 AM

All replies

  • Hi,
    Did you try this ?
    To configure the PDC emulator to synchronize from its internal hardware clock
    Open a Command Prompt.
    Type the following command and then press ENTER:
    w32tm /config /syncfromflags:domhier /reliable:yes /update
    Type the following command and then press ENTER:
    net stop w32time
    Type the following command and then press ENTER:
    net start w32time
    The above post at:
    http://technet.microsoft.com/en-us/library/cc784882(WS.10).aspx
    If cannot ask again
    Hope it work.

    Monday, January 04, 2010 6:50 AM
  • Hi,

    I receive the following error when I do that. The problem here for me is the windows time service can't even get started.

    C:\Users\administrator.ANNAIK>w32tm /config /syncfromflags:domhier /reliable:yes
     /update
    The following error occurred: The service has not been started. (0x80070426)

    Please advice on the above situation.
    Monday, January 04, 2010 6:58 AM
  • Hi,

    I find one KB quite similar to your problem

    You may try it

    http://support.microsoft.com/kb/892501

    That for Windows Server 2003
     If you want you can try.

    Monday, January 04, 2010 12:41 PM
  • Hi,

    If KB892501 cannot solve the problem, please help to collect the following information:

    1.    On Windows Server 2008, run elevated CMD and run "gpresult /h gp.html", send gp.html file to tfwst@microsoft.com.
    2.    Does this problem occur on any other computer in your Domain?
    3.    On problematic computer, run "services.msc", double-click Windows Time service, switch to Log On tab, which option was selected?

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, January 06, 2010 9:02 AM
    Moderator
  • Hi,

    If KB892501 cannot solve the problem, please help to collect the following information:

    1.    On Windows Server 2008, run elevated CMD and run "gpresult /h gp.html", send gp.html file to tfwst@microsoft.com.
    "Send to the mentioned Email"- Email Subject: " Windows Time Service in Win2008 Server"

    2.    Does this problem occur on any other computer in your Domain?
    " As far as I have checked the other server has started the service already." This is the only server that is Win2008, the rest of them all Win2003.

    3.    On problematic computer, run "services.msc", double-click Windows Time service, switch to Log On tab, which option was selected?
    " This account and user name is LocalService"

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Hi Mervyn,

    Thanks for the Quote.

    I have answer each below the questions that you have raised..

    Please help.

    Thanks. Rgds, Riyaz
    Thursday, January 07, 2010 7:30 AM
  • Hi,

    Thank you for update. From the report, we can find you have configured Group Policy to setup Windows Time Service. I suggest you disable Windows Time (Startup Mode: Automatic) and test.

    If the issue persists, let’s dump the permission of the Netlogon and the Windows Time Service using the below command on a working Windows Server 2008 system.

    Sc sdshow Netlogon >Netlogon.txt
    Sc sdshow w32time >WindowsTime.txt

    Back to the problem server

    net stop netlogon
    sc sdset w32time <string from working sesc rver>
    sc sdset w32time <string from working server>
    net start netlogon
    net start w32time

    what’s the result?

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, January 11, 2010 6:26 AM
    Moderator
  • Hi,

    Is there any update?

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, January 13, 2010 10:34 AM
    Moderator
  • Hi Sorry, I was on Course.. So no access to the server.

    I was using the working WindowsTime config from server 2003. Below is the error message that I receive. I have also set the WindowsTime service to Manual.

    C:\Users\administrator.ANNAIK>sc sdset w32time <D:(A;;CCLCSWLORC;;;AU)(A;;CCDCLC
    SWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLORC;;;PU)(A;;CCLCSWRPLO;;;IU)(A;;CCLCSWRPLO
    ;;;BU)S:(AU;FA;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;WD)>
    The syntax of the command is incorrect.

    C:\Users\administrator.ANNAIK>sc sdset w32time D:(A;;CCLCSWLORC;;;AU)(A;;CCDCLCS
    WRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLORC;;;PU)(A;;CCLCSWRPLO;;;IU)(A;;CCLCSWRPLO;
    ;;BU)S:(AU;FA;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;WD)
    [SC] SetServiceObjectSecurity SUCCESS

    C:\Users\administrator.ANNAIK>net start netlogon
    The Netlogon service is starting.......
    The Netlogon service was started successfully.


    C:\Users\administrator.ANNAIK>net start w32time
    The service is not responding to the control function.

    More help is available by typing NET HELPMSG 2186."

    When I try to start using the services.. The error message is "Error 1053, the service did not respond to the start or control request in a timely fashion."

    Thursday, January 14, 2010 12:36 AM